aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-05-27 19:29:07 +0800
committereik <eik@FreeBSD.org>2004-05-27 19:29:07 +0800
commit97689dfc528dc49732f3763d58efd44392298f03 (patch)
tree68525fc4d6794158b13dc54fa027cf9f1800f80b
parent61625c2d812fe7342856ceb1f026d3ecd4c1975b (diff)
downloadfreebsd-ports-graphics-97689dfc528dc49732f3763d58efd44392298f03.tar.gz
freebsd-ports-graphics-97689dfc528dc49732f3763d58efd44392298f03.tar.zst
freebsd-ports-graphics-97689dfc528dc49732f3763d58efd44392298f03.zip
Update net/openldap22-* to 2.2.11 and follow the OpenLDAP soname change:
<http://www.openldap.org/lists/openldap-devel/200403/msg00101.html> While I'm not totally happy with their choice, I believe it is better to be in sync with the upstream library naming scheme. No objection from: portmgr
-rw-r--r--Mk/bsd.port.mk25
-rw-r--r--UPDATING8
-rw-r--r--net/openldap22-server/Makefile8
-rw-r--r--net/openldap22-server/distinfo4
-rw-r--r--net/openldap22-server/files/patch-build::top.mk21
-rw-r--r--net/openldap22-server/files/patch-build::version.var13
-rw-r--r--net/openldap22-server/pkg-plist7
-rw-r--r--net/openldap22-server/pkg-plist.client15
-rw-r--r--net/openldap23-server/Makefile8
-rw-r--r--net/openldap23-server/distinfo4
-rw-r--r--net/openldap23-server/files/patch-build::top.mk21
-rw-r--r--net/openldap23-server/files/patch-build::version.var13
-rw-r--r--net/openldap23-server/pkg-plist7
-rw-r--r--net/openldap23-server/pkg-plist.client15
-rw-r--r--net/openldap24-server/Makefile8
-rw-r--r--net/openldap24-server/distinfo4
-rw-r--r--net/openldap24-server/files/patch-build::top.mk21
-rw-r--r--net/openldap24-server/files/patch-build::version.var13
-rw-r--r--net/openldap24-server/pkg-plist7
-rw-r--r--net/openldap24-server/pkg-plist.client15
20 files changed, 87 insertions, 150 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 66fd41c5f2c..306f08b63e9 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -273,10 +273,12 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# Default: not set.
##
#
-# USE_OPENLDAP - Says that the port uses the OpenLDAP libraries
-# Implies: WANT_OPENLDAP_VER?=21
-# WANT_OPENLDAP_VER - Legal values are: 20, 21, and 22
-# If set to an unkown value, the port is marked BROKEN.
+# USE_OPENLDAP - Says that the port uses the OpenLDAP libraries
+# Implies: WANT_OPENLDAP_VER?=21
+# WANT_OPENLDAP_VER - Legal values are: 21, 22
+# If set to an unkown value, the port is marked BROKEN.
+# WANT_OPENLDAP_SASL - Says that the system should use OpenLDAP libraries
+# with SASL support.
#
##
# USE_AUTOTOOLS - Says that the port uses various GNU autotools
@@ -1329,12 +1331,17 @@ WANT_OPENLDAP_VER= ${USE_OPENLDAP_VER}
.endif
.if defined(USE_OPENLDAP)
-.if !empty(WANT_OPENLDAP_VER:M2[0-9]) && \
- exists(${PORTSDIR}/net/openldap${WANT_OPENLDAP_VER}-client/Makefile)
-OPENLDAP_LIB_VER= ${WANT_OPENLDAP_VER:C/^2[0-1]$/2/:C/^2([2-9])$/20\1/}
-LIB_DEPENDS+= ldap.${OPENLDAP_LIB_VER}:${PORTSDIR}/net/openldap${WANT_OPENLDAP_VER}-client
+.if defined(WANT_OPENLDAP_SASL)
+_OPENLDAP_FLAVOUR= -sasl
.else
-BROKEN= "unknown OpenLDAP version: ${WANT_OPENLDAP_VER}"
+_OPENLDAP_FLAVOUR=
+.endif
+.if ${WANT_OPENLDAP_VER} == 22
+LIB_DEPENDS+= ldap-2.2.7:${PORTSDIR}/net/openldap22${_OPENLDAP_FLAVOUR}-client
+.elif ${WANT_OPENLDAP_VER} == 21
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21${_OPENLDAP_FLAVOUR}-client
+.else
+BROKEN= "unknown OpenLDAP version: ${WANT_OPENLDAP_VER}"
.endif
.endif
diff --git a/UPDATING b/UPDATING
index 62ff9e5927d..7f6474f5334 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,14 @@ You should get into the habit of checking this file for changes each
time you update your ports collection, before attempting any port
upgrades.
+20040527:
+ AFFECTS: users of net/openldap22-client
+
+ The OpenLDAP library soname has changed, requiring a recompilation
+ of all dependent ports:
+
+ portupgrade -rf net/openldap22-client
+
20040525:
AFFECTS: users of databases/postgresql-client
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index f8e91678d87..003fa023555 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 2.2.10
+PORTVERSION= 2.2.11
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -71,13 +71,11 @@ OPENLDAP_PKGNAMESUFFIX= ${PKGNAMESUFFIX_SERVER}
OPENLDAP_PKGFILESUFX=
.if defined(WITH_SASL)
-RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.202:${PORTSDIR}/net/openldap22-sasl-client
-#RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-sasl-client
+RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-sasl-client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.[!2].*
.else
-RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.202:${PORTSDIR}/net/openldap22-client
-#RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-client
+RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[!2].* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.*
.endif
diff --git a/net/openldap22-server/distinfo b/net/openldap22-server/distinfo
index c62d2c99147..1a5703d3667 100644
--- a/net/openldap22-server/distinfo
+++ b/net/openldap22-server/distinfo
@@ -1,2 +1,2 @@
-MD5 (openldap-2.2.10.tgz) = 3620465b331626308463a7651e4fb9c6
-SIZE (openldap-2.2.10.tgz) = 2558755
+MD5 (openldap-2.2.11.tgz) = 45d92c2d466130ffc084d074fdd6c18b
+SIZE (openldap-2.2.11.tgz) = 2559765
diff --git a/net/openldap22-server/files/patch-build::top.mk b/net/openldap22-server/files/patch-build::top.mk
index b6ec9f5e165..1a7d0bb0164 100644
--- a/net/openldap22-server/files/patch-build::top.mk
+++ b/net/openldap22-server/files/patch-build::top.mk
@@ -1,20 +1,11 @@
---- build/top.mk.orig Wed Mar 24 22:51:22 2004
-+++ build/top.mk Wed Mar 31 22:28:53 2004
-@@ -69,7 +69,7 @@
- LIBTOOL = @LIBTOOL@
- LIBRELEASE = @OPENLDAP_LIBRELEASE@
- LIBVERSION = @OPENLDAP_LIBVERSION@
--LTVERSION = -release $(LIBRELEASE) -version-info $(LIBVERSION)
-+LTVERSION = -version-info $(LIBVERSION)
-
- # libtool --only flag for libraries: platform specific
- NT_LTONLY_LIB = # --only-$(BUILD_LIBS_DYNAMIC)
-@@ -191,6 +191,8 @@
-
+--- build/top.mk.orig Mon Apr 12 20:21:07 2004
++++ build/top.mk Wed May 5 12:49:13 2004
+@@ -194,6 +194,8 @@
SLAPD_LIBS = @SLAPD_LIBS@ @SLAPD_PERL_LDFLAGS@ @SLAPD_SQL_LDFLAGS@ @SLAPD_SQL_LIBS@ @SLAPD_SLP_LIBS@
SLURPD_LIBS = @SLURPD_LIBS@
-+
-+SLAPI_LIBS = @SLAPI_LIBS@
++SLAPI_LIBS = @SLAPI_LIBS@
++
# Our Defaults
CC = $(AC_CC)
+ DEFS = $(LDAP_INCPATH) $(XINCPATH) $(XDEFS) $(AC_DEFS) $(DEFINES)
diff --git a/net/openldap22-server/files/patch-build::version.var b/net/openldap22-server/files/patch-build::version.var
deleted file mode 100644
index 0a60e601f13..00000000000
--- a/net/openldap22-server/files/patch-build::version.var
+++ /dev/null
@@ -1,13 +0,0 @@
---- build/version.var.orig Fri Apr 16 17:34:39 2004
-+++ build/version.var Fri Apr 16 22:56:05 2004
-@@ -17,7 +17,7 @@
- ol_minor=2
- ol_patch=10
- ol_api_inc=20210
--ol_api_current=7
--ol_api_revision=3
--ol_api_age=0
-+ol_api_current=202
-+ol_api_revision=2
-+ol_api_age=200
- ol_release_date="2004/04/16"
diff --git a/net/openldap22-server/pkg-plist b/net/openldap22-server/pkg-plist
index 8ebdafd53d1..b1d925c17b8 100644
--- a/net/openldap22-server/pkg-plist
+++ b/net/openldap22-server/pkg-plist
@@ -7,12 +7,13 @@ etc/openldap/slapd.conf.default
@exec [ -f %B/slapd.conf ] || cp %B/%f %B/slapd.conf
%%SLAPI%%lib/libslapi.a
%%SLAPI%%lib/libslapi.so
-%%SLAPI%%lib/libslapi.so.202
-@comment %%SLAPI%%lib/libslapi-2.2.so
-@comment %%SLAPI%%lib/libslapi-2.2.so.7
+%%SLAPI%%lib/libslapi-2.2.so
+%%SLAPI%%lib/libslapi-2.2.so.7
libexec/slapd
libexec/slurpd
+@comment sbin/slapacl
sbin/slapadd
+@comment sbin/slapauth
sbin/slapcat
sbin/slapdn
sbin/slapindex
diff --git a/net/openldap22-server/pkg-plist.client b/net/openldap22-server/pkg-plist.client
index dcc079b0ec3..dc0a65c6383 100644
--- a/net/openldap22-server/pkg-plist.client
+++ b/net/openldap22-server/pkg-plist.client
@@ -21,19 +21,16 @@ include/ldap_utf8.h
include/slapi-plugin.h
lib/liblber.a
lib/liblber.so
-lib/liblber.so.202
-@comment lib/liblber-2.2.so
-@comment lib/liblber-2.2.so.7
+lib/liblber-2.2.so
+lib/liblber-2.2.so.7
lib/libldap.a
lib/libldap.so
-lib/libldap.so.202
-@comment lib/libldap-2.2.so
-@comment lib/libldap-2.2.so.7
+lib/libldap-2.2.so
+lib/libldap-2.2.so.7
lib/libldap_r.a
lib/libldap_r.so
-lib/libldap_r.so.202
-@comment lib/libldap_r-2.2.so
-@comment lib/libldap_r-2.2.so.7
+lib/libldap_r-2.2.so
+lib/libldap_r-2.2.so.7
share/openldap/ucdata/case.dat
share/openldap/ucdata/cmbcl.dat
share/openldap/ucdata/comp.dat
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index f8e91678d87..003fa023555 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 2.2.10
+PORTVERSION= 2.2.11
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -71,13 +71,11 @@ OPENLDAP_PKGNAMESUFFIX= ${PKGNAMESUFFIX_SERVER}
OPENLDAP_PKGFILESUFX=
.if defined(WITH_SASL)
-RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.202:${PORTSDIR}/net/openldap22-sasl-client
-#RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-sasl-client
+RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-sasl-client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.[!2].*
.else
-RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.202:${PORTSDIR}/net/openldap22-client
-#RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-client
+RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[!2].* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.*
.endif
diff --git a/net/openldap23-server/distinfo b/net/openldap23-server/distinfo
index c62d2c99147..1a5703d3667 100644
--- a/net/openldap23-server/distinfo
+++ b/net/openldap23-server/distinfo
@@ -1,2 +1,2 @@
-MD5 (openldap-2.2.10.tgz) = 3620465b331626308463a7651e4fb9c6
-SIZE (openldap-2.2.10.tgz) = 2558755
+MD5 (openldap-2.2.11.tgz) = 45d92c2d466130ffc084d074fdd6c18b
+SIZE (openldap-2.2.11.tgz) = 2559765
diff --git a/net/openldap23-server/files/patch-build::top.mk b/net/openldap23-server/files/patch-build::top.mk
index b6ec9f5e165..1a7d0bb0164 100644
--- a/net/openldap23-server/files/patch-build::top.mk
+++ b/net/openldap23-server/files/patch-build::top.mk
@@ -1,20 +1,11 @@
---- build/top.mk.orig Wed Mar 24 22:51:22 2004
-+++ build/top.mk Wed Mar 31 22:28:53 2004
-@@ -69,7 +69,7 @@
- LIBTOOL = @LIBTOOL@
- LIBRELEASE = @OPENLDAP_LIBRELEASE@
- LIBVERSION = @OPENLDAP_LIBVERSION@
--LTVERSION = -release $(LIBRELEASE) -version-info $(LIBVERSION)
-+LTVERSION = -version-info $(LIBVERSION)
-
- # libtool --only flag for libraries: platform specific
- NT_LTONLY_LIB = # --only-$(BUILD_LIBS_DYNAMIC)
-@@ -191,6 +191,8 @@
-
+--- build/top.mk.orig Mon Apr 12 20:21:07 2004
++++ build/top.mk Wed May 5 12:49:13 2004
+@@ -194,6 +194,8 @@
SLAPD_LIBS = @SLAPD_LIBS@ @SLAPD_PERL_LDFLAGS@ @SLAPD_SQL_LDFLAGS@ @SLAPD_SQL_LIBS@ @SLAPD_SLP_LIBS@
SLURPD_LIBS = @SLURPD_LIBS@
-+
-+SLAPI_LIBS = @SLAPI_LIBS@
++SLAPI_LIBS = @SLAPI_LIBS@
++
# Our Defaults
CC = $(AC_CC)
+ DEFS = $(LDAP_INCPATH) $(XINCPATH) $(XDEFS) $(AC_DEFS) $(DEFINES)
diff --git a/net/openldap23-server/files/patch-build::version.var b/net/openldap23-server/files/patch-build::version.var
deleted file mode 100644
index 0a60e601f13..00000000000
--- a/net/openldap23-server/files/patch-build::version.var
+++ /dev/null
@@ -1,13 +0,0 @@
---- build/version.var.orig Fri Apr 16 17:34:39 2004
-+++ build/version.var Fri Apr 16 22:56:05 2004
-@@ -17,7 +17,7 @@
- ol_minor=2
- ol_patch=10
- ol_api_inc=20210
--ol_api_current=7
--ol_api_revision=3
--ol_api_age=0
-+ol_api_current=202
-+ol_api_revision=2
-+ol_api_age=200
- ol_release_date="2004/04/16"
diff --git a/net/openldap23-server/pkg-plist b/net/openldap23-server/pkg-plist
index 8ebdafd53d1..b1d925c17b8 100644
--- a/net/openldap23-server/pkg-plist
+++ b/net/openldap23-server/pkg-plist
@@ -7,12 +7,13 @@ etc/openldap/slapd.conf.default
@exec [ -f %B/slapd.conf ] || cp %B/%f %B/slapd.conf
%%SLAPI%%lib/libslapi.a
%%SLAPI%%lib/libslapi.so
-%%SLAPI%%lib/libslapi.so.202
-@comment %%SLAPI%%lib/libslapi-2.2.so
-@comment %%SLAPI%%lib/libslapi-2.2.so.7
+%%SLAPI%%lib/libslapi-2.2.so
+%%SLAPI%%lib/libslapi-2.2.so.7
libexec/slapd
libexec/slurpd
+@comment sbin/slapacl
sbin/slapadd
+@comment sbin/slapauth
sbin/slapcat
sbin/slapdn
sbin/slapindex
diff --git a/net/openldap23-server/pkg-plist.client b/net/openldap23-server/pkg-plist.client
index dcc079b0ec3..dc0a65c6383 100644
--- a/net/openldap23-server/pkg-plist.client
+++ b/net/openldap23-server/pkg-plist.client
@@ -21,19 +21,16 @@ include/ldap_utf8.h
include/slapi-plugin.h
lib/liblber.a
lib/liblber.so
-lib/liblber.so.202
-@comment lib/liblber-2.2.so
-@comment lib/liblber-2.2.so.7
+lib/liblber-2.2.so
+lib/liblber-2.2.so.7
lib/libldap.a
lib/libldap.so
-lib/libldap.so.202
-@comment lib/libldap-2.2.so
-@comment lib/libldap-2.2.so.7
+lib/libldap-2.2.so
+lib/libldap-2.2.so.7
lib/libldap_r.a
lib/libldap_r.so
-lib/libldap_r.so.202
-@comment lib/libldap_r-2.2.so
-@comment lib/libldap_r-2.2.so.7
+lib/libldap_r-2.2.so
+lib/libldap_r-2.2.so.7
share/openldap/ucdata/case.dat
share/openldap/ucdata/cmbcl.dat
share/openldap/ucdata/comp.dat
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index f8e91678d87..003fa023555 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 2.2.10
+PORTVERSION= 2.2.11
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -71,13 +71,11 @@ OPENLDAP_PKGNAMESUFFIX= ${PKGNAMESUFFIX_SERVER}
OPENLDAP_PKGFILESUFX=
.if defined(WITH_SASL)
-RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.202:${PORTSDIR}/net/openldap22-sasl-client
-#RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-sasl-client
+RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-sasl-client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.[!2].*
.else
-RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.202:${PORTSDIR}/net/openldap22-client
-#RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-client
+RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[!2].* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.*
.endif
diff --git a/net/openldap24-server/distinfo b/net/openldap24-server/distinfo
index c62d2c99147..1a5703d3667 100644
--- a/net/openldap24-server/distinfo
+++ b/net/openldap24-server/distinfo
@@ -1,2 +1,2 @@
-MD5 (openldap-2.2.10.tgz) = 3620465b331626308463a7651e4fb9c6
-SIZE (openldap-2.2.10.tgz) = 2558755
+MD5 (openldap-2.2.11.tgz) = 45d92c2d466130ffc084d074fdd6c18b
+SIZE (openldap-2.2.11.tgz) = 2559765
diff --git a/net/openldap24-server/files/patch-build::top.mk b/net/openldap24-server/files/patch-build::top.mk
index b6ec9f5e165..1a7d0bb0164 100644
--- a/net/openldap24-server/files/patch-build::top.mk
+++ b/net/openldap24-server/files/patch-build::top.mk
@@ -1,20 +1,11 @@
---- build/top.mk.orig Wed Mar 24 22:51:22 2004
-+++ build/top.mk Wed Mar 31 22:28:53 2004
-@@ -69,7 +69,7 @@
- LIBTOOL = @LIBTOOL@
- LIBRELEASE = @OPENLDAP_LIBRELEASE@
- LIBVERSION = @OPENLDAP_LIBVERSION@
--LTVERSION = -release $(LIBRELEASE) -version-info $(LIBVERSION)
-+LTVERSION = -version-info $(LIBVERSION)
-
- # libtool --only flag for libraries: platform specific
- NT_LTONLY_LIB = # --only-$(BUILD_LIBS_DYNAMIC)
-@@ -191,6 +191,8 @@
-
+--- build/top.mk.orig Mon Apr 12 20:21:07 2004
++++ build/top.mk Wed May 5 12:49:13 2004
+@@ -194,6 +194,8 @@
SLAPD_LIBS = @SLAPD_LIBS@ @SLAPD_PERL_LDFLAGS@ @SLAPD_SQL_LDFLAGS@ @SLAPD_SQL_LIBS@ @SLAPD_SLP_LIBS@
SLURPD_LIBS = @SLURPD_LIBS@
-+
-+SLAPI_LIBS = @SLAPI_LIBS@
++SLAPI_LIBS = @SLAPI_LIBS@
++
# Our Defaults
CC = $(AC_CC)
+ DEFS = $(LDAP_INCPATH) $(XINCPATH) $(XDEFS) $(AC_DEFS) $(DEFINES)
diff --git a/net/openldap24-server/files/patch-build::version.var b/net/openldap24-server/files/patch-build::version.var
deleted file mode 100644
index 0a60e601f13..00000000000
--- a/net/openldap24-server/files/patch-build::version.var
+++ /dev/null
@@ -1,13 +0,0 @@
---- build/version.var.orig Fri Apr 16 17:34:39 2004
-+++ build/version.var Fri Apr 16 22:56:05 2004
-@@ -17,7 +17,7 @@
- ol_minor=2
- ol_patch=10
- ol_api_inc=20210
--ol_api_current=7
--ol_api_revision=3
--ol_api_age=0
-+ol_api_current=202
-+ol_api_revision=2
-+ol_api_age=200
- ol_release_date="2004/04/16"
diff --git a/net/openldap24-server/pkg-plist b/net/openldap24-server/pkg-plist
index 8ebdafd53d1..b1d925c17b8 100644
--- a/net/openldap24-server/pkg-plist
+++ b/net/openldap24-server/pkg-plist
@@ -7,12 +7,13 @@ etc/openldap/slapd.conf.default
@exec [ -f %B/slapd.conf ] || cp %B/%f %B/slapd.conf
%%SLAPI%%lib/libslapi.a
%%SLAPI%%lib/libslapi.so
-%%SLAPI%%lib/libslapi.so.202
-@comment %%SLAPI%%lib/libslapi-2.2.so
-@comment %%SLAPI%%lib/libslapi-2.2.so.7
+%%SLAPI%%lib/libslapi-2.2.so
+%%SLAPI%%lib/libslapi-2.2.so.7
libexec/slapd
libexec/slurpd
+@comment sbin/slapacl
sbin/slapadd
+@comment sbin/slapauth
sbin/slapcat
sbin/slapdn
sbin/slapindex
diff --git a/net/openldap24-server/pkg-plist.client b/net/openldap24-server/pkg-plist.client
index dcc079b0ec3..dc0a65c6383 100644
--- a/net/openldap24-server/pkg-plist.client
+++ b/net/openldap24-server/pkg-plist.client
@@ -21,19 +21,16 @@ include/ldap_utf8.h
include/slapi-plugin.h
lib/liblber.a
lib/liblber.so
-lib/liblber.so.202
-@comment lib/liblber-2.2.so
-@comment lib/liblber-2.2.so.7
+lib/liblber-2.2.so
+lib/liblber-2.2.so.7
lib/libldap.a
lib/libldap.so
-lib/libldap.so.202
-@comment lib/libldap-2.2.so
-@comment lib/libldap-2.2.so.7
+lib/libldap-2.2.so
+lib/libldap-2.2.so.7
lib/libldap_r.a
lib/libldap_r.so
-lib/libldap_r.so.202
-@comment lib/libldap_r-2.2.so
-@comment lib/libldap_r-2.2.so.7
+lib/libldap_r-2.2.so
+lib/libldap_r-2.2.so.7
share/openldap/ucdata/case.dat
share/openldap/ucdata/cmbcl.dat
share/openldap/ucdata/comp.dat