aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2009-06-12 21:40:55 +0800
committerskreuzer <skreuzer@FreeBSD.org>2009-06-12 21:40:55 +0800
commit984ea7ad79994c10644f93a487bfa77e3bc1ef87 (patch)
tree2a141d148ab7607b37cdbcd15fe9ae374fa85fa7
parent23fa4b93e48472b72f79b95f51fdfd556ed7efdb (diff)
downloadfreebsd-ports-graphics-984ea7ad79994c10644f93a487bfa77e3bc1ef87.tar.gz
freebsd-ports-graphics-984ea7ad79994c10644f93a487bfa77e3bc1ef87.tar.zst
freebsd-ports-graphics-984ea7ad79994c10644f93a487bfa77e3bc1ef87.zip
Atom takes in plain text with simple layout hints and outputs as HTML
or LaTeX. PR: ports/135424 Submitted by: Chris Rees <chris@bayofrum.net> Approved by: wxs (mentor)
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/atom/Makefile38
-rw-r--r--textproc/atom/distinfo3
-rw-r--r--textproc/atom/pkg-descr4
4 files changed, 46 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index c725d9756f7..c90b329ba03 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -24,6 +24,7 @@
SUBDIR += asm2html
SUBDIR += aspell
SUBDIR += aspell-without-dicten
+ SUBDIR += atom
SUBDIR += az-aspell
SUBDIR += bar
SUBDIR += bbe
diff --git a/textproc/atom/Makefile b/textproc/atom/Makefile
new file mode 100644
index 00000000000..e6d1b256888
--- /dev/null
+++ b/textproc/atom/Makefile
@@ -0,0 +1,38 @@
+# New ports collection Makefile for: atom
+# Date created: 3 June 2009
+# Whom: utisoft@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= atom
+PORTVERSION= 1.0
+CATEGORIES= textproc
+MASTER_SITES= http://www.bayofrum.net/atom/ \
+ http://muuz.deadbbs.com/FreeBSD/atom/
+
+MAINTAINER= utisoft@gmail.com
+COMMENT= Converts text files to html with special attrs
+
+MAN1= atom.1
+MANCOMPRESSED= no
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/atom
+PORTDOCS= COPYING \
+ README \
+ TODO \
+ testFile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for DOC in ${PORTDOCS}
+ ${CP} -R ${WRKSRC}/${DOC} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/atom/distinfo b/textproc/atom/distinfo
new file mode 100644
index 00000000000..8653d4e7469
--- /dev/null
+++ b/textproc/atom/distinfo
@@ -0,0 +1,3 @@
+MD5 (atom-1.0.tar.gz) = d437c8dad83173bf0001d70ca68ed4af
+SHA256 (atom-1.0.tar.gz) = 852413c1051977b613d3b1796215e40698d6545c9195c395fa6fef0113818280
+SIZE (atom-1.0.tar.gz) = 103239
diff --git a/textproc/atom/pkg-descr b/textproc/atom/pkg-descr
new file mode 100644
index 00000000000..f9791ada913
--- /dev/null
+++ b/textproc/atom/pkg-descr
@@ -0,0 +1,4 @@
+This port takes plain text files like ASCII as input, and outputs
+mark files such as HTML or (unsupported) LaTeX.
+
+WWW: http://www.bayofrum.net/atom/