aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-03 10:49:53 +0800
committermiwi <miwi@FreeBSD.org>2014-02-03 10:49:53 +0800
commit98dab0a8c506584c70eefd4abadbdaf68529f224 (patch)
tree06f14e2c23413551f07af7f2223a6017eecace50
parente99bb638e9d80d28ba2d2a8a6da868c54a4be710 (diff)
downloadfreebsd-ports-graphics-98dab0a8c506584c70eefd4abadbdaf68529f224.tar.gz
freebsd-ports-graphics-98dab0a8c506584c70eefd4abadbdaf68529f224.tar.zst
freebsd-ports-graphics-98dab0a8c506584c70eefd4abadbdaf68529f224.zip
- Stage support
-rw-r--r--print/gsfonts/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/print/gsfonts/Makefile b/print/gsfonts/Makefile
index add7bc718dd..3c15a283e8f 100644
--- a/print/gsfonts/Makefile
+++ b/print/gsfonts/Makefile
@@ -16,10 +16,10 @@ COMMENT= Standard Fonts for Ghostscript
NO_WRKSUBDIR= yes
NO_BUILD= yes
-PLIST_SUB= FONTSDIR="${FONTSDIR:S|${PREFIX}/||}"
+PLIST_SUB= FONTSDIR="${FONTSDIR:S|${STAGEDIR}${PREFIX}/||}"
OPTIONS_DEFINE= DOCS
-FONTSDIR= ${PREFIX}/share/ghostscript/fonts
+FONTSDIR= ${STAGEDIR}${PREFIX}/share/ghostscript/fonts
CJKFONTS?= std.ja_JP/Ryumin-Light \
std.ja_JP/GothicBBB-Medium \
std.ja_JP/Ryumin-Light.gs7 \
@@ -28,7 +28,6 @@ CJKFONTS?= std.ja_JP/Ryumin-Light \
std.zh_CN/STSong-Light \
std.zh_CN/MSung-Light
-NO_STAGE= yes
do-install:
${MKDIR} ${FONTSDIR}
cd ${WRKSRC}/fonts && \
@@ -43,12 +42,10 @@ do-install:
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= ChangeLog README README.tweaks TODO
post-install:
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/fonts && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/fonts && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>