aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-17 16:37:08 +0800
committermiwi <miwi@FreeBSD.org>2007-01-17 16:37:08 +0800
commit9904c921f16d1963aefca99c4f67e9983ff69dce (patch)
treeb5814c58fcc56e0d009efe7ddc8387c06404de61
parentd81c45c59b7d64c4bae1b2ffe8e45d264aaf9bb3 (diff)
downloadfreebsd-ports-graphics-9904c921f16d1963aefca99c4f67e9983ff69dce.tar.gz
freebsd-ports-graphics-9904c921f16d1963aefca99c4f67e9983ff69dce.tar.zst
freebsd-ports-graphics-9904c921f16d1963aefca99c4f67e9983ff69dce.zip
The XmlAda library includes a set of Ada2005 packages to manipulate XML
input. It implements the XML 1.0 standard, as well as support for namespaces and a number of other optional standards related to XML. WWW: http://libre.adacore.com/ PR: ports/107435 Submitted by: John Merryweather Cooper <john_m_cooper@yahoo.com> Repocopy by: marcus
-rw-r--r--textproc/xmlada-gcc/Makefile77
-rw-r--r--textproc/xmlada-gcc/distinfo6
-rw-r--r--textproc/xmlada-gcc/files/patch-Makefile.in85
-rw-r--r--textproc/xmlada-gcc/files/patch-schema_schema-validators-extensions.adb18
-rw-r--r--textproc/xmlada-gcc/files/patch-schema_schema-validators-restrictions.adb11
-rw-r--r--textproc/xmlada-gcc/files/patch-shared.gpr.in9
-rw-r--r--textproc/xmlada-gcc/pkg-descr19
-rw-r--r--textproc/xmlada-gcc/pkg-plist37
8 files changed, 166 insertions, 96 deletions
diff --git a/textproc/xmlada-gcc/Makefile b/textproc/xmlada-gcc/Makefile
index 07b0560ac64..cb5163d616a 100644
--- a/textproc/xmlada-gcc/Makefile
+++ b/textproc/xmlada-gcc/Makefile
@@ -1,53 +1,54 @@
-# New ports collection makefile for: xmlada-gcc
-# Date created: 24 Dec 2006
-# Whom: hopet@ics.muni.cz
+# New ports collection makefile for: xmlada-gps
+# Date created: 31 Dec 2006
+# Whom: John Merryweather Cooper
#
# $FreeBSD$
#
-PORTNAME= xmlada
-PORTVERSION= 5.0.4
+PORTNAME= xmlada-gps
+PORTVERSION= 3.1.3
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= gnuada
-PKGNAMESUFFIX= -gcc
-DISTNAME= gnat-gcc-xmlada-4.1.1_gnat_5.04a-r6.src
-EXTRACT_SUFX= .rpm
+MASTER_SITES= http://libre.adacore.com/
+EXTRACT_SUFX= -src.tgz
-MAINTAINER= hopet@ics.muni.cz
-COMMENT= An XML parsing library for Ada 95, port for lang/gnat-gcc41
+MAINTAINER= john_m_cooper@yahoo.com
+COMMENT= The Ada Unicode and XML Library
-BUILD_DEPENDS= ${LOCALBASE}/bin/gcc41/gcc41:${PORTSDIR}/lang/gnat-gcc41
-
-EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
-
-.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= makeinfo:${PORTSDIR}/print/texinfo \
- pdftex:${PORTSDIR}/print/teTeX
-.endif
-
-WRKSRC= ${WRKDIR}/xmlada-gnat-5_04a
+BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat
CONFLICTS= xmlada-[0-9]*
-CONFIGURE_ENV+= PATH=${LOCALBASE}/bin/gcc41:${PATH} CC=${LOCALBASE}/bin/gcc41/gcc41
-MAKE_ENV+= PATH=${LOCALBASE}/bin/gcc41:${PATH} CC=${LOCALBASE}/bin/gcc41/gcc41
-
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-
-ADACFLAGS?= # none
-CFLAGS= ${ADACFLAGS}
+USE_GMAKE= yes
-XMLADAPKGNAME= xmlada-gnat-5_04a.tar.bz2
+# Check for GNAT sources.
+.if !exists(${DISTDIR}/${DISTFILE}) && !defined(PACKAGE_BUILDING)
+ECHO_MSG= ${PRINTF}
+IGNORE=Because of licensing and registration restrictions, you must fetch\n \
+ the source distribution manually. Please access\n \
+ http://libre.adacore.com/\ with a web browser, register\n \
+ (It's free!) and log in. Download the source files:\n\n \
+ \t${DISTFILE}\n\n \
+ and place them in ${DISTDIR}\n
+ ${ECHO_MSG} ${IGNORE}
+.endif
-do-extract:
- if [ ! -d ${WRKDIR} ]; then \
- ${MKDIR} ${WRKDIR}; \
- fi
- ( cd ${WRKDIR} && \
- rpm2cpio.pl <${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | ${CPIO} -i ${XMLADAPKGNAME} && \
- tar jxf ${XMLADAPKGNAME} )
+WRKSRC= ${WRKDIR}/xmlada-2.1
+DOCSDIR= ${PREFIX}/share/doc/xmlada
+MAKE_ENV= "INSTALL_DATA=${INSTALL_DATA}" \
+ "INSTALL_SCRIPT=${INSTALL_SCRIPT}"
+
+# Weird permission problems creep up on install unless done explicitly
+# this way.
+do-install:
+ @(cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install)
+# Manual install of info file since it lacks an entry field
+.if !defined(NOPORTDOCS)
+ @(cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install_docs)
+ @install-info --entry "XmlAda" ${DOCSDIR}/xml.info \
+ ${DOCSDIR}/dir
+.endif
.include <bsd.port.mk>
diff --git a/textproc/xmlada-gcc/distinfo b/textproc/xmlada-gcc/distinfo
index de3c15cff1d..5d942df7f29 100644
--- a/textproc/xmlada-gcc/distinfo
+++ b/textproc/xmlada-gcc/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnat-gcc-xmlada-4.1.1_gnat_5.04a-r6.src.rpm) = ed706dabe25e0d3d81c1db419eb2e010
-SHA256 (gnat-gcc-xmlada-4.1.1_gnat_5.04a-r6.src.rpm) = 80ac743dec2068d6d4fe0003d1496cd4c36ae1807fa8ed591aaa2465f222908b
-SIZE (gnat-gcc-xmlada-4.1.1_gnat_5.04a-r6.src.rpm) = 374751
+MD5 (xmlada-gps-3.1.3-src.tgz) = 6673657fd6e05e4d4e7c3f843b1201d3
+SHA256 (xmlada-gps-3.1.3-src.tgz) = a9fbee538185f27541c813bf3c7ecd97dead86166c43e54db8ad841d9d57846a
+SIZE (xmlada-gps-3.1.3-src.tgz) = 686514
diff --git a/textproc/xmlada-gcc/files/patch-Makefile.in b/textproc/xmlada-gcc/files/patch-Makefile.in
index 639fdbb683d..4b89efae087 100644
--- a/textproc/xmlada-gcc/files/patch-Makefile.in
+++ b/textproc/xmlada-gcc/files/patch-Makefile.in
@@ -1,11 +1,80 @@
---- Makefile.in.orig Sun Dec 24 23:38:00 2006
-+++ Makefile.in Sun Dec 24 23:38:17 2006
-@@ -30,7 +30,7 @@
+--- Makefile.in.orig Wed Jan 18 06:38:29 2006
++++ Makefile.in Sun Jan 14 18:14:09 2007
+@@ -2,8 +2,8 @@
+ PREFIX=@EXEC_PREFIX@
- .PHONY: all obj clean install install_dirs
+ ## The type of library we want to build
+-LIBRARY_TYPE=relocatable
+-# LIBRARY_TYPE=static
++# LIBRARY_TYPE=relocatable
++LIBRARY_TYPE=static
--all: obj
-+all: obj docs
+ GNATMAKE=gnatmake
+ CC=gcc
+@@ -11,9 +11,10 @@
+ # Compiler mode: one of "distrib", "debug", "optimize", "profile"
+ MODE=distrib
- obj: force
- ${GNATMAKE} -Punicode/unicode.gpr -XMODE=${MODE} -XLIBRARY_TYPE=${LIBRARY_TYPE}
+-CHMOD=chmod
+-CP=cp -p -f
+-MKDIR=mkdir -p
++CHMOD=/bin/chmod
++CP_DATA=${INSTALL_DATA}
++CP_SCRIPT=${INSTALL_SCRIPT}
++MKDIR=/bin/mkdir -p
+
+ ifeq (${OS}, Windows_NT)
+ LN=cp -f -p
+@@ -52,36 +53,37 @@
+
+ # Rule for installing the modules
+ %_inst: force
+- ${CP} $*/*.ad[bs] ${PREFIX}/include/xmlada
+- -${CP} $*/lib/*.ali ${PREFIX}/lib/xmlada/
+- -${CP} $*/lib/*xmlada_* ${PREFIX}/lib/xmlada/
++ ${CP_DATA} $*/*.ad[bs] ${PREFIX}/include/xmlada
++ -${CP_DATA} $*/lib/*.ali ${PREFIX}/lib/xmlada
++ -${CP_DATA} $*/lib/*xmlada_* ${PREFIX}/lib/xmlada
+ ${RM} ${PREFIX}/lib/*xmlada_$**
+ cd ${PREFIX}/lib; ${foreach lib, ${notdir ${wildcard $*/lib/*xmlada_*}}, \
+ ${RM} ${PREFIX}/lib/${lib}; \
+ ${LN} xmlada/${lib} ${PREFIX}/lib/${lib};}
+- cd ${PREFIX}/lib/xmlada; ${CHMOD} ugo-w *.ali
+ cd $*; ls *.ad[bs] > ${PREFIX}/lib/gnat/xmlada/xmlada_$*.lgpr
+
+ install_dirs: force
+ @${MKDIR} ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/lib
+ @${MKDIR} ${PREFIX}/lib/xmlada
+- @${MKDIR} ${PREFIX}/share/doc/xmlada
+ @${MKDIR} ${PREFIX}/include/xmlada
+ @${MKDIR} ${PREFIX}/lib/gnat
+ @${MKDIR} ${PREFIX}/lib/gnat/xmlada
+- @${MKDIR} ${PREFIX}/share/gps/plug-ins/
++ @${MKDIR} ${PREFIX}/share/gps/plug-ins
+
+ install: obj install_dirs ${MODULE_INSTALL}
+- ${CP} distrib/${LIBRARY_TYPE}/*.gpr ${PREFIX}/lib/gnat
+- ${CP} xmlada-config ${PREFIX}/bin
+- -${CP} docs/xml.ps ${PREFIX}/share/doc/xmlada 2>/dev/null
+- -${CP} docs/xml.pdf ${PREFIX}/share/doc/xmlada
+- -${CP} docs/xml.html ${PREFIX}/share/doc/xmlada
+- -${CP} docs/xml.info ${PREFIX}/share/doc/xmlada
+- ${CHMOD} +x ${PREFIX}/bin/xmlada-config
+- ${CP} distrib/xmlada.gpr ${PREFIX}/lib/gnat/xmlada.gpr
+- ${CP} distrib/xmlada_gps.py ${PREFIX}/share/gps/plug-ins/
++ ${CP_SCRIPT} xmlada-config ${PREFIX}/bin/xmlada-config
++ ${CP_SCRIPT} distrib/xmlada_gps.py \
++ ${PREFIX}/share/gps/plug-ins/xmlada_gps.py
++ ${CP_DATA} distrib/${LIBRARY_TYPE}/*.gpr ${PREFIX}/lib/gnat
++ ${CP_DATA} distrib/xmlada.gpr ${PREFIX}/lib/gnat/xmlada.gpr
++
++install_docs:
++ @${MKDIR} ${PREFIX}/share/doc/xmlada
++ -${CP_DATA} docs/xml.ps ${PREFIX}/share/doc/xmlada 2>/dev/null
++ -${CP_DATA} docs/xml.pdf ${PREFIX}/share/doc/xmlada
++ -${CP_DATA} docs/xml.html ${PREFIX}/share/doc/xmlada
++ -${CP_DATA} docs/xml.info ${PREFIX}/share/doc/xmlada
+
+ clean: force
+ gnat clean -q -r -Punicode/unicode.gpr
diff --git a/textproc/xmlada-gcc/files/patch-schema_schema-validators-extensions.adb b/textproc/xmlada-gcc/files/patch-schema_schema-validators-extensions.adb
new file mode 100644
index 00000000000..47470082b93
--- /dev/null
+++ b/textproc/xmlada-gcc/files/patch-schema_schema-validators-extensions.adb
@@ -0,0 +1,18 @@
+--- schema/schema-validators-extensions.adb.orig Tue Jan 2 10:16:54 2007
++++ schema/schema-validators-extensions.adb Tue Jan 2 10:19:58 2007
+@@ -199,13 +199,13 @@
+ begin
+ Had_Extension := True;
+
+- if Validator.Base.Block_Restriction and then Had_Restriction then
++ if Validator.Base.Block_Restriction then
+ Validation_Error
+ ("Restrictions of type """
+ & Get_Local_Name (Validator.Base) & """ are forbidden");
+ end if;
+
+- if Validator.Base.Block_Extension and then Had_Extension then
++ if Validator.Base.Block_Extension then
+ Validation_Error
+ ("Extensions of type """
+ & Get_Local_Name (Validator.Base) & """ are forbidden");
diff --git a/textproc/xmlada-gcc/files/patch-schema_schema-validators-restrictions.adb b/textproc/xmlada-gcc/files/patch-schema_schema-validators-restrictions.adb
new file mode 100644
index 00000000000..7bf9514d52e
--- /dev/null
+++ b/textproc/xmlada-gcc/files/patch-schema_schema-validators-restrictions.adb
@@ -0,0 +1,11 @@
+--- schema/schema-validators-restrictions.adb.orig Tue Jan 2 10:28:58 2007
++++ schema/schema-validators-restrictions.adb Tue Jan 2 10:30:55 2007
+@@ -201,7 +201,7 @@
+ begin
+ Had_Restriction := True;
+
+- if Validator.Base.Block_Restriction and then Had_Restriction then
++ if Validator.Base.Block_Restriction then
+ Validation_Error
+ ("Restrictions of type """
+ & Get_Local_Name (Validator.Base) & """ are forbidden");
diff --git a/textproc/xmlada-gcc/files/patch-shared.gpr.in b/textproc/xmlada-gcc/files/patch-shared.gpr.in
deleted file mode 100644
index 029f84db45b..00000000000
--- a/textproc/xmlada-gcc/files/patch-shared.gpr.in
+++ /dev/null
@@ -1,9 +0,0 @@
---- shared.gpr.in.orig Mon Dec 25 00:14:30 2006
-+++ shared.gpr.in Mon Dec 25 00:14:48 2006
-@@ -1,5 +1,5 @@
- project Shared is
-- Version := "@XMLADA_MAJOR_VERSION@.@XMLADA_MINOR_VERSION@";
-+ Version := "@XMLADA_MAJOR_VERSION@";
-
- type Library_Type_Type is ("relocatable", "static");
- Library_Type : Library_Type_Type := external ("LIBRARY_TYPE", "relocatable");
diff --git a/textproc/xmlada-gcc/pkg-descr b/textproc/xmlada-gcc/pkg-descr
index 2d36a28d0bd..4826a6af694 100644
--- a/textproc/xmlada-gcc/pkg-descr
+++ b/textproc/xmlada-gcc/pkg-descr
@@ -1,16 +1,5 @@
-XML/Ada is a set of modules that provide a simple manipulation of XML
-streams. It supports the whole XML 1.0 specifications, and can parse
-any file that follows this standard (including the contents of the
-DTD).
+The XmlAda library includes a set of Ada2005 packages to manipulate XML
+input. It implements the XML 1.0 standard, as well as support for
+namespaces and a number of other optional standards related to XML.
-It also provides support for a number of other standard associated
-with XML, like SAX and DOM.
-
-In addition, It includes a module to manipulate Unicode streams, since
-this is required by the XML standard.
-
-This version of GtkAda is designed to be used with lang/gnat-gcc41.
-
-WWW: https://libre2.adacore.com/xmlada/
-WWW: http://gnuada.sourceforge.net/
-Author: Petr Holub <hopet@ics.muni.cz>
+WWW: http://libre.adacore.com/
diff --git a/textproc/xmlada-gcc/pkg-plist b/textproc/xmlada-gcc/pkg-plist
index b153352fe75..4072f5306fb 100644
--- a/textproc/xmlada-gcc/pkg-plist
+++ b/textproc/xmlada-gcc/pkg-plist
@@ -200,16 +200,11 @@ lib/gnat/xmlada_input.gpr
lib/gnat/xmlada_sax.gpr
lib/gnat/xmlada_schema.gpr
lib/gnat/xmlada_unicode.gpr
-lib/libxmlada_dom.so
-lib/libxmlada_dom.so.2
-lib/libxmlada_input_sources.so
-lib/libxmlada_input_sources.so.2
-lib/libxmlada_sax.so
-lib/libxmlada_sax.so.2
-lib/libxmlada_schema.so
-lib/libxmlada_schema.so.2
-lib/libxmlada_unicode.so
-lib/libxmlada_unicode.so.2
+lib/libxmlada_dom.a
+lib/libxmlada_input_sources.a
+lib/libxmlada_sax.a
+lib/libxmlada_schema.a
+lib/libxmlada_unicode.a
lib/xmlada/dom-core-attrs.ali
lib/xmlada/dom-core-cdata_sections.ali
lib/xmlada/dom-core-character_datas.ali
@@ -230,16 +225,11 @@ lib/xmlada/input_sources-file.ali
lib/xmlada/input_sources-http.ali
lib/xmlada/input_sources-strings.ali
lib/xmlada/input_sources.ali
-lib/xmlada/libxmlada_dom.so
-lib/xmlada/libxmlada_dom.so.2
-lib/xmlada/libxmlada_input_sources.so
-lib/xmlada/libxmlada_input_sources.so.2
-lib/xmlada/libxmlada_sax.so
-lib/xmlada/libxmlada_sax.so.2
-lib/xmlada/libxmlada_schema.so
-lib/xmlada/libxmlada_schema.so.2
-lib/xmlada/libxmlada_unicode.so
-lib/xmlada/libxmlada_unicode.so.2
+lib/xmlada/libxmlada_dom.a
+lib/xmlada/libxmlada_input_sources.a
+lib/xmlada/libxmlada_sax.a
+lib/xmlada/libxmlada_schema.a
+lib/xmlada/libxmlada_unicode.a
lib/xmlada/sax-attributes.ali
lib/xmlada/sax-encodings.ali
lib/xmlada/sax-exceptions.ali
@@ -363,14 +353,15 @@ lib/xmlada/unicode-names-yi_radicals.ali
lib/xmlada/unicode-names-yi_syllables.ali
lib/xmlada/unicode-names.ali
lib/xmlada/unicode.ali
+%%PORTDOCS%%%%DOCSDIR%%/dir
%%PORTDOCS%%%%DOCSDIR%%/xml.html
%%PORTDOCS%%%%DOCSDIR%%/xml.info
%%PORTDOCS%%%%DOCSDIR%%/xml.pdf
share/gps/plug-ins/xmlada_gps.py
-@dirrmtry share/gps/plug-ins
-@dirrmtry share/gps
+@dirrm share/gps/plug-ins
+@dirrm share/gps
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/xmlada
@dirrm lib/gnat/xmlada
-@dirrmtry lib/gnat
+@dirrm lib/gnat
@dirrm include/xmlada