aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2016-11-27 05:32:50 +0800
committerosa <osa@FreeBSD.org>2016-11-27 05:32:50 +0800
commit9e8db7b2c5e4b07259816f986ce462b34fa6f213 (patch)
tree4b9e937a1fb23435ce4d130a98e1b356dd43710a
parentc919d4e23e3ff35daf49fd1a135f396a50fde96c (diff)
downloadfreebsd-ports-graphics-9e8db7b2c5e4b07259816f986ce462b34fa6f213.tar.gz
freebsd-ports-graphics-9e8db7b2c5e4b07259816f986ce462b34fa6f213.tar.zst
freebsd-ports-graphics-9e8db7b2c5e4b07259816f986ce462b34fa6f213.zip
Fix the functionality issue of the third-party modsecurity module.
Found by: Rami Jebara <rami.jebara@tuangru.com> (in private mail)
-rw-r--r--www/nginx-devel/Makefile5
-rw-r--r--www/nginx/Makefile5
2 files changed, 8 insertions, 2 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 7d49db67c1b..5b1977ea788 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -870,6 +870,7 @@ LIB_DEPENDS+= libapr-1.so:devel/apr1 \
libyajl.so:devel/yajl
USE_APACHE= 22+
USE_GNOME+= libxml2
+USES+= pkgconfig shebangfix
MASTER_SITES+= http://www.modsecurity.org/tarball/${NGINX_MODSECURITY_VERSION:S/RC/rc/}/:modsecurity
DISTFILES+= modsecurity-${NGINX_MODSECURITY_VERSION}.tar.gz:modsecurity
CONFIGURE_ARGS+=--add-module=${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION}/nginx/modsecurity
@@ -1282,7 +1283,9 @@ post-patch:
pre-configure:
.if ${PORT_OPTIONS:MMODSECURITY}
( cd ${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION} && \
- CC="${CC}" ${CONFIGURE_CMD} --enable-standalone-module && \
+ CC="${CC}" ${CONFIGURE_CMD} --enable-standalone-module \
+ --with-pcre=${LOCALBASE} --with-yajl=${LOCALBASE} \
+ --with-curl=${LOCALBASE} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} )
.endif
.if ${PORT_OPTIONS:MSMALL_LIGHT}
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 322dbbb6458..a4f6c79bdae 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -862,6 +862,7 @@ LIB_DEPENDS+= libapr-1.so:devel/apr1 \
libyajl.so:devel/yajl
USE_APACHE= 22+
USE_GNOME+= libxml2
+USES+= pkgconfig shebangfix
MASTER_SITES+= http://www.modsecurity.org/tarball/${NGINX_MODSECURITY_VERSION:S/RC/rc/}/:modsecurity
DISTFILES+= modsecurity-${NGINX_MODSECURITY_VERSION}.tar.gz:modsecurity
CONFIGURE_ARGS+=--add-module=${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION}/nginx/modsecurity
@@ -1272,7 +1273,9 @@ post-patch:
pre-configure:
.if ${PORT_OPTIONS:MMODSECURITY}
( cd ${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION} && \
- CC="${CC}" ${CONFIGURE_CMD} --enable-standalone-module && \
+ CC="${CC}" ${CONFIGURE_CMD} --enable-standalone-module \
+ --with-pcre=${LOCALBASE} --with-yajl=${LOCALBASE} \
+ --with-curl=${LOCALBASE} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} )
.endif
.if ${PORT_OPTIONS:MSMALL_LIGHT}