aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2005-09-16 02:31:01 +0800
committerlth <lth@FreeBSD.org>2005-09-16 02:31:01 +0800
commit9f240042ff2aecb27fa02d99592b75e862d7da64 (patch)
tree96fd0cf2cceadd88e8a9a7b4127568d16647638c
parent9047b69a5b5691b7c4a2e6b3f0624c09e6caa3df (diff)
downloadfreebsd-ports-graphics-9f240042ff2aecb27fa02d99592b75e862d7da64.tar.gz
freebsd-ports-graphics-9f240042ff2aecb27fa02d99592b75e862d7da64.tar.zst
freebsd-ports-graphics-9f240042ff2aecb27fa02d99592b75e862d7da64.zip
Add p5-HTML-Template-HashWrapper 1.3, easy way to use the associate
option from HTML::Template. PR: ports/86157 Submitted by: Zach Thompson <hideo@lastamericanempire.com>
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Template-HashWrapper/Makefile31
-rw-r--r--www/p5-HTML-Template-HashWrapper/distinfo2
-rw-r--r--www/p5-HTML-Template-HashWrapper/pkg-descr3
-rw-r--r--www/p5-HTML-Template-HashWrapper/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 417d0baeaaa..c6628fd259a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -530,6 +530,7 @@
SUBDIR += p5-HTML-Template
SUBDIR += p5-HTML-Template-Associate
SUBDIR += p5-HTML-Template-Expr
+ SUBDIR += p5-HTML-Template-HashWrapper
SUBDIR += p5-HTML-Template-JIT
SUBDIR += p5-HTML-TokeParser-Simple
SUBDIR += p5-HTML-Tree
diff --git a/www/p5-HTML-Template-HashWrapper/Makefile b/www/p5-HTML-Template-HashWrapper/Makefile
new file mode 100644
index 00000000000..64d28884aa6
--- /dev/null
+++ b/www/p5-HTML-Template-HashWrapper/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-HTML-Template-HashWrapper
+# Date Created: 15 Sep 2005
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Template-HashWrapper
+PORTVERSION= 1.3
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Easy way to use the associate option from HTML::Template
+
+RUN_DEPENDS= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Template::HashWrapper.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-Template-HashWrapper/distinfo b/www/p5-HTML-Template-HashWrapper/distinfo
new file mode 100644
index 00000000000..e44e0c93b51
--- /dev/null
+++ b/www/p5-HTML-Template-HashWrapper/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTML-Template-HashWrapper-1.3.tar.gz) = eee47d1b8e86dd309539898f6afe458d
+SIZE (HTML-Template-HashWrapper-1.3.tar.gz) = 4973
diff --git a/www/p5-HTML-Template-HashWrapper/pkg-descr b/www/p5-HTML-Template-HashWrapper/pkg-descr
new file mode 100644
index 00000000000..f057a03dc63
--- /dev/null
+++ b/www/p5-HTML-Template-HashWrapper/pkg-descr
@@ -0,0 +1,3 @@
+A module to use the associate option from HTML::Template via hash references.
+
+WWW: http://search.cpan.org/~gregfast/HTML-Template-HashWrapper-1.3/
diff --git a/www/p5-HTML-Template-HashWrapper/pkg-plist b/www/p5-HTML-Template-HashWrapper/pkg-plist
new file mode 100644
index 00000000000..7e2bbdf5b56
--- /dev/null
+++ b/www/p5-HTML-Template-HashWrapper/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/HTML/Template/HashWrapper.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/HashWrapper/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/HashWrapper
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML/Template 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML 2>/dev/null || true