aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-23 20:43:13 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-23 20:43:13 +0800
commita19406f2f5251cbf8ffb33cb6442511e44fed2eb (patch)
tree15dcb71842466ed4e740f9b2395bff1bc4a86434
parent90a2d456853b7c23f5ea60d04884042546cf8519 (diff)
downloadfreebsd-ports-graphics-a19406f2f5251cbf8ffb33cb6442511e44fed2eb.tar.gz
freebsd-ports-graphics-a19406f2f5251cbf8ffb33cb6442511e44fed2eb.tar.zst
freebsd-ports-graphics-a19406f2f5251cbf8ffb33cb6442511e44fed2eb.zip
devel/boost-libs: always verbose build after r421635
PR: 199601 Approved by: portmgr blanket
-rw-r--r--devel/boost-all/compiled.mk3
-rw-r--r--devel/boost-libs/Makefile3
-rw-r--r--devel/boost-python-libs/Makefile3
3 files changed, 3 insertions, 6 deletions
diff --git a/devel/boost-all/compiled.mk b/devel/boost-all/compiled.mk
index a38eb91b78c..057d830ac0a 100644
--- a/devel/boost-all/compiled.mk
+++ b/devel/boost-all/compiled.mk
@@ -10,6 +10,7 @@ PKG_MESSAGE_FILE_PYTHON= ${PORTSDIR}/devel/boost-all/pkg-message.python
BJAM_ARGS= --layout=system \
--prefix=${PREFIX} \
+ -d2
# Our compiler-flags will be added AFTER those set by bjam. We remove
# the optimization level, because Boost sets it itself (to -O3 in case
@@ -21,8 +22,6 @@ BOOST_TOOLSET= ${CHOSEN_COMPILER_TYPE}
BJAM_ARGS+= --toolset=${BOOST_TOOLSET} \
${_MAKE_JOBS}
-VERBOSE_BUILD_VARS= BJAM_ARGS+=-d2
-
DEBUG_VARS= BJAM_ARGS+=debug
DEBUG_VARS_OFF= BJAM_ARGS+=release
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index 0547b9bf16b..7b0a1065c8d 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -8,11 +8,10 @@ COMMENT= Free portable C++ libraries (without Boost.Python)
BUILD_DEPENDS+= bjam:devel/boost-jam
-OPTIONS_DEFINE= VERBOSE_BUILD DEBUG OPTIMIZED_CFLAGS
+OPTIONS_DEFINE= DEBUG OPTIMIZED_CFLAGS
OPTIONS_MULTI= LOCALE
OPTIONS_MULTI_LOCALE= ICONV ICU
OPTIONS_DEFAULT= ICONV ICU
-VERBOSE_BUILD_DESC= Show compiler messages
ICONV_DESC= Boost.Locale with iconv encoding support
ICU_DESC= Boost.Regex/Locale with ICU unicode support
diff --git a/devel/boost-python-libs/Makefile b/devel/boost-python-libs/Makefile
index 4985a8ccdb0..6486a560c8e 100644
--- a/devel/boost-python-libs/Makefile
+++ b/devel/boost-python-libs/Makefile
@@ -6,8 +6,7 @@ COMMENT= Framework for interfacing Python and C++
USES+= python
-OPTIONS_DEFINE= VERBOSE_BUILD DEBUG OPTIMIZED_CFLAGS
-VERBOSE_BUILD_DESC= Show compiler messages
+OPTIONS_DEFINE= DEBUG OPTIMIZED_CFLAGS
.include "${.CURDIR}/../boost-all/common.mk"