aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-07-31 15:07:36 +0800
committerrm <rm@FreeBSD.org>2012-07-31 15:07:36 +0800
commita1da55047ae8fecd9ac21041a789a6143e115530 (patch)
tree2f33fc6adcb8961bac660e87ea4498503549b373
parentd79ed9f7450e13ab352333e3826822ad7bef2c0d (diff)
downloadfreebsd-ports-graphics-a1da55047ae8fecd9ac21041a789a6143e115530.tar.gz
freebsd-ports-graphics-a1da55047ae8fecd9ac21041a789a6143e115530.tar.zst
freebsd-ports-graphics-a1da55047ae8fecd9ac21041a789a6143e115530.zip
- add LATEST_LINK for py-beautifulsoup32
- fix dependency name and bump PORTREVISION for dependend ports Reported by: pointyhat (erwin)
-rw-r--r--deskutils/calibre/Makefile3
-rw-r--r--devel/py-deliciousapi/Makefile5
-rw-r--r--multimedia/freevo/Makefile4
-rw-r--r--textproc/archmage/Makefile3
-rw-r--r--www/py-beautifulsoup32/Makefile2
-rw-r--r--www/py-flexget/Makefile3
6 files changed, 13 insertions, 7 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index f7822605cbc..cde8f93d440 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -7,6 +7,7 @@
PORTNAME= calibre
PORTVERSION= 0.8.61
+PORTREVISION= 1
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
@@ -29,7 +30,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:${PORTSDIR}/devel/py-setupto
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
${PYTHON_PKGNAMEPREFIX}dnspython>=0:${PORTSDIR}/dns/py-dnspython \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:${PORTSDIR}/devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:${PORTSDIR}/www/py-beautifulsoup32 \
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup32>=0:${PORTSDIR}/www/py-beautifulsoup32 \
${PYTHON_PKGNAMEPREFIX}imaging>=0:${PORTSDIR}/graphics/py-imaging \
${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}mechanize>=0:${PORTSDIR}/www/py-mechanize \
diff --git a/devel/py-deliciousapi/Makefile b/devel/py-deliciousapi/Makefile
index e0a7a35a771..6852225ea0c 100644
--- a/devel/py-deliciousapi/Makefile
+++ b/devel/py-deliciousapi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= deliciousapi
PORTVERSION= 1.6.7
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,8 +16,8 @@ DISTNAME= DeliciousAPI-${PORTVERSION}
MAINTAINER= sbz@FreeBSD.org
COMMENT= Unofficial Python API for retrieving data from Delicious.com
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/BeautifulSoup.py:${PORTSDIR}/www/py-beautifulsoup \
- ${PYTHON_PKGNAMEPREFIX}simplejson>=1.7:${PORTSDIR}/devel/py-simplejson
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup32>=0:${PORTSDIR}/www/py-beautifulsoup32 \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=1.7:${PORTSDIR}/devel/py-simplejson
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
diff --git a/multimedia/freevo/Makefile b/multimedia/freevo/Makefile
index 403e4f8142d..04af528317c 100644
--- a/multimedia/freevo/Makefile
+++ b/multimedia/freevo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freevo
PORTVERSION= 1.9.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/Freevo%20releases/${PORTVERSION}
@@ -23,7 +23,7 @@ RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
${PYTHON_SITELIBDIR}/kaa/__init__.py:${PORTSDIR}/multimedia/py-kaa-base \
${PYTHON_SITELIBDIR}/kaa/imlib2/__init__.py:${PORTSDIR}/multimedia/py-kaa-imlib2 \
${PYTHON_SITELIBDIR}/kaa/metadata/__init__.py:${PORTSDIR}/multimedia/py-kaa-metadata \
- ${PYTHON_SITELIBDIR}/BeautifulSoup.py:${PORTSDIR}/www/py-beautifulsoup \
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup32>=0:${PORTSDIR}/www/py-beautifulsoup32 \
${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game \
${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging \
${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twisted \
diff --git a/textproc/archmage/Makefile b/textproc/archmage/Makefile
index 9ad2d4e97b0..bbfb57b2a17 100644
--- a/textproc/archmage/Makefile
+++ b/textproc/archmage/Makefile
@@ -7,6 +7,7 @@
PORTNAME= archmage
PORTVERSION= 0.2.4
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= SF
@@ -14,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Extensible reader/decompiler of files in CHM format
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/chm/chm.py:${PORTSDIR}/textproc/pychm \
- ${PYTHON_SITELIBDIR}/BeautifulSoup.py:${PORTSDIR}/www/py-beautifulsoup
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup32>=0:${PORTSDIR}/www/py-beautifulsoup32
NO_BUILD= yes
USE_BZIP2= yes
diff --git a/www/py-beautifulsoup32/Makefile b/www/py-beautifulsoup32/Makefile
index f92415ee70b..cd8a653e031 100644
--- a/www/py-beautifulsoup32/Makefile
+++ b/www/py-beautifulsoup32/Makefile
@@ -19,6 +19,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= BeautifulSoup
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}32
+
CONFLICTS= py[0-9]*-beautifulsoup-3.0.*
.include <bsd.port.mk>
diff --git a/www/py-flexget/Makefile b/www/py-flexget/Makefile
index df1a10be926..1e7fcae47ef 100644
--- a/www/py-flexget/Makefile
+++ b/www/py-flexget/Makefile
@@ -7,6 +7,7 @@
PORTNAME= flexget
PORTVERSION= 1.0r2315
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= http://download.flexget.com/unstable/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -27,7 +28,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.7:${PORTSDIR}/databases/py-sql
${PYTHON_PKGNAMEPREFIX}pynzb>=0:${PORTSDIR}/news/py-pynzb \
${PYTHON_PKGNAMEPREFIX}feedparser>=0:${PORTSDIR}/textproc/py-feedparser \
${PYTHON_PKGNAMEPREFIX}rss2gen>=0:${PORTSDIR}/textproc/py-rss2gen \
- ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:${PORTSDIR}/www/py-beautifulsoup \
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup32>=0:${PORTSDIR}/www/py-beautifulsoup32 \
${PYTHON_PKGNAMEPREFIX}cherrypy>=3.2.0:${PORTSDIR}/www/py-cherrypy \
${PYTHON_PKGNAMEPREFIX}Flask>=0:${PORTSDIR}/www/py-flask \
${PYTHON_PKGNAMEPREFIX}html5lib>=0.11:${PORTSDIR}/www/py-html5lib \