aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>2003-07-19 10:34:32 +0800
committerfoxfair <foxfair@FreeBSD.org>2003-07-19 10:34:32 +0800
commita4b30cf35495a2c151848392acbc016143dbaf01 (patch)
treed9ac77fa86141641528e52bc73443b8949303719
parent34ff3b3eabebf274d7ebdce2f4dd06411951949c (diff)
downloadfreebsd-ports-graphics-a4b30cf35495a2c151848392acbc016143dbaf01.tar.gz
freebsd-ports-graphics-a4b30cf35495a2c151848392acbc016143dbaf01.tar.zst
freebsd-ports-graphics-a4b30cf35495a2c151848392acbc016143dbaf01.zip
Add hostsentry 0.02, a Login Anomaly Detector.
PR: 48127 Submitted by: Andre Ramos <andre.ramos@netcabo.pt>
-rw-r--r--security/Makefile1
-rw-r--r--security/hostsentry/Makefile38
-rw-r--r--security/hostsentry/distinfo1
-rw-r--r--security/hostsentry/files/patch-aa11
-rw-r--r--security/hostsentry/pkg-descr5
-rw-r--r--security/hostsentry/pkg-message5
-rw-r--r--security/hostsentry/pkg-plist34
7 files changed, 95 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 24f1b7426fe..4790a5cfe65 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -96,6 +96,7 @@
SUBDIR += hashish
SUBDIR += heimdal
SUBDIR += hlfl
+ SUBDIR += hostsentry
SUBDIR += hping
SUBDIR += hydra
SUBDIR += ident2
diff --git a/security/hostsentry/Makefile b/security/hostsentry/Makefile
new file mode 100644
index 00000000000..2c1c688f5da
--- /dev/null
+++ b/security/hostsentry/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: hostsentry
+# Date created: 7 February 2003
+# Whom: Andre Ramos <andre.ramos@netcabo.pt>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hostsentry
+PORTVERSION= 0.02
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.netsys.com/len/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Login Anomaly Detector
+
+RUN_DEPENDS= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python
+
+post-install:
+.if !defined(NOPORTSDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/hostsentry
+ ${INSTALL_DATA} ${WRKSRC}/README.BUGS \
+ ${WRKSRC}/README.credits \
+ ${WRKSRC}/README.install \
+ ${WRKSRC}/README.intro \
+ ${WRKSRC}/README.modules \
+ ${WRKSRC}/README.paper \
+ ${WRKSRC}/README.technical \
+ ${WRKSRC}/README.why_python \
+ ${WRKSRC}/README.wtmp \
+ ${PREFIX}/share/doc/hostsentry
+.endif
+
+ ${INSTALL_DATA} ${WRKSRC}/hostsentry.conf \
+ ${PREFIX}/etc/hostsentry.conf
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/hostsentry/distinfo b/security/hostsentry/distinfo
new file mode 100644
index 00000000000..bb1aa43444f
--- /dev/null
+++ b/security/hostsentry/distinfo
@@ -0,0 +1 @@
+MD5 (hostsentry-0.02.tar.gz) = 3de0bbb7d456bb53683de56dfdf98362
diff --git a/security/hostsentry/files/patch-aa b/security/hostsentry/files/patch-aa
new file mode 100644
index 00000000000..3d5e31e60cc
--- /dev/null
+++ b/security/hostsentry/files/patch-aa
@@ -0,0 +1,11 @@
+--- ../hostSentryConfig.py Thu Mar 25 22:06:01 1999
++++ hostSentryConfig.py Sun Feb 9 14:49:38 2003
+@@ -35,7 +35,7 @@
+
+ # This is the default config file. I'll make this more
+ # accessible in the future.
+-CONFIG='/usr/local/abacus/hostsentry/hostsentry.conf'
++CONFIG='/usr/local/etc/hostsentry.conf'
+
+ class hostSentryConfig(hostSentryCore):
+
diff --git a/security/hostsentry/pkg-descr b/security/hostsentry/pkg-descr
new file mode 100644
index 00000000000..eecf8b053e9
--- /dev/null
+++ b/security/hostsentry/pkg-descr
@@ -0,0 +1,5 @@
+HostSentry is a program to trace suspicious user's activity, unknown user
+logins and suspicious login domains, taking measures against compromised
+accounts and unethical user's behaviour.
+
+WWW: http://sourceforge.net/projects/sentrytools/
diff --git a/security/hostsentry/pkg-message b/security/hostsentry/pkg-message
new file mode 100644
index 00000000000..edd83f41bf1
--- /dev/null
+++ b/security/hostsentry/pkg-message
@@ -0,0 +1,5 @@
+
+
+ Edit /usr/local/etc/hostssentry.conf and change"
+ your settings if you haven't already."
+
diff --git a/security/hostsentry/pkg-plist b/security/hostsentry/pkg-plist
new file mode 100644
index 00000000000..8e175f3ed60
--- /dev/null
+++ b/security/hostsentry/pkg-plist
@@ -0,0 +1,34 @@
+abacus/hostsentry/hostSentryConfig.py
+abacus/hostsentry/hostSentryCore.py
+abacus/hostsentry/hostSentryDB.py
+abacus/hostsentry/hostSentryLog.py
+abacus/hostsentry/hostSentryStat.py
+abacus/hostsentry/hostSentryTTY.py
+abacus/hostsentry/hostSentryTTYDB.py
+abacus/hostsentry/hostSentryUser.py
+abacus/hostsentry/hostSentryUtmp.py
+abacus/hostsentry/hostsentry.py
+abacus/hostsentry/modules/moduleExample.py
+abacus/hostsentry/modules/moduleFirstLogin.py
+abacus/hostsentry/modules/moduleForeignDomain.allow
+abacus/hostsentry/modules/moduleForeignDomain.py
+abacus/hostsentry/modules/moduleHistorySuspicious.py
+abacus/hostsentry/modules/moduleHistoryTruncated.py
+abacus/hostsentry/modules/moduleLoginLogout.py
+abacus/hostsentry/modules/moduleMultipleLogins.allow
+abacus/hostsentry/modules/moduleMultipleLogins.py
+abacus/hostsentry/modules/moduleOddDirnames.py
+abacus/hostsentry/modules/moduleRhostsCheck.py
+@dirrm abacus/hostsentry/modules
+@unexec rmdir %D/abacus/hostsentry 2>/dev/null || true
+@unexec rmdir %D/abacus 2>/dev/null || echo "If you are permanently removing this port, you should do a "rm -rf ${PKG_PREFIX}/abacus" to remove any binary, configuration and log files left." | fmt
+%%PORTDOCS%%share/doc/hostsentry/README.BUGS
+%%PORTDOCS%%share/doc/hostsentry/README.credits
+%%PORTDOCS%%share/doc/hostsentry/README.install
+%%PORTDOCS%%share/doc/hostsentry/README.intro
+%%PORTDOCS%%share/doc/hostsentry/README.modules
+%%PORTDOCS%%share/doc/hostsentry/README.paper
+%%PORTDOCS%%share/doc/hostsentry/README.technical
+%%PORTDOCS%%share/doc/hostsentry/README.why_python
+%%PORTDOCS%%share/doc/hostsentry/README.wtmp
+%%PORTDOCS%%@dirrm share/doc/hostsentry