aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2016-11-24 22:18:52 +0800
committerehaupt <ehaupt@FreeBSD.org>2016-11-24 22:18:52 +0800
commitaae6cd4c47aa393b07b0856d3ea8e13293c58c6b (patch)
tree502ab3d4ad220fd84f36ef8df803fc1a9b4335d1
parent25781898047c75f772627204fc0e828f0717682e (diff)
downloadfreebsd-ports-graphics-aae6cd4c47aa393b07b0856d3ea8e13293c58c6b.tar.gz
freebsd-ports-graphics-aae6cd4c47aa393b07b0856d3ea8e13293c58c6b.tar.zst
freebsd-ports-graphics-aae6cd4c47aa393b07b0856d3ea8e13293c58c6b.zip
- Fix build with libc++ 3.9
- Switch to USES=localbase - Add LICENSE: GPLv2+ for VBA code, LGPL21 for bundled libresample code and NONE for playgsf code, as no license is specified neither for it nor for code it's based on (http://www.caitsith2.com/gsf/) PR: 214653 Submitted by: amdmi3 Reported by: jbeich
-rw-r--r--audio/playgsf/Makefile15
-rw-r--r--audio/playgsf/files/patch-VBA_Util.cpp20
2 files changed, 27 insertions, 8 deletions
diff --git a/audio/playgsf/Makefile b/audio/playgsf/Makefile
index 016671441b2..714bbf57a2e 100644
--- a/audio/playgsf/Makefile
+++ b/audio/playgsf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= playgsf
PORTVERSION= 0.7.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://projects.raphnet.net/playgsf/ \
LOCAL/ehaupt
@@ -11,15 +11,16 @@ MASTER_SITES= http://projects.raphnet.net/playgsf/ \
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Command-line player for gsf audio files
+LICENSE= GPLv2+ LGPL21 NONE
+LICENSE_COMB= multi
+LICENSE_FILE_LGPL21= ${WRKSRC}/libresample-0.1.3/LICENSE.txt
+
LIB_DEPENDS= libao.so:audio/libao
-USES= gmake dos2unix
+USES= dos2unix gmake localbase:ldflags
GNU_CONFIGURE= yes
-
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-CONFIGURE_ARGS+= --enable-ccore --disable-optimisations
+CONFIGURE_ARGS= --enable-ccore \
+ --disable-optimisations
PLIST_FILES= bin/playgsf
diff --git a/audio/playgsf/files/patch-VBA_Util.cpp b/audio/playgsf/files/patch-VBA_Util.cpp
index b8997315312..4fa610d1a45 100644
--- a/audio/playgsf/files/patch-VBA_Util.cpp
+++ b/audio/playgsf/files/patch-VBA_Util.cpp
@@ -1,5 +1,23 @@
---- VBA/Util.cpp.orig 2016-07-26 15:40:39 UTC
+--- VBA/Util.cpp.orig 2016-11-24 13:15:44 UTC
+++ VBA/Util.cpp
+@@ -917,7 +917,7 @@ bool utilIsGSF(const char * file)
+
+
+ if(strlen(file) > 4) {
+- char *p = strrchr(file,'.');
++ const char *p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gsf") == 0)
+@@ -934,7 +934,7 @@ bool utilIsGBAImage(const char * file)
+ {
+ cpuIsMultiBoot = false;
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ //if(_stricmp(p, ".gba") == 0)
@@ -1484,7 +1484,8 @@ void utilWriteData(gzFile gzFile, variab
gzFile utilGzOpen(const char *file, const char *mode)