aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorimp <imp@FreeBSD.org>2004-12-13 06:23:07 +0800
committerimp <imp@FreeBSD.org>2004-12-13 06:23:07 +0800
commitab4ef14dabf8c4e904b9f1f0ff64a8ce3f01f320 (patch)
treebc1b4ab5ec418cb71853a4407f608d95aa4de268
parent7b73365a04b9efeaa465e44b4065e9e2a9eac284 (diff)
downloadfreebsd-ports-graphics-ab4ef14dabf8c4e904b9f1f0ff64a8ce3f01f320.tar.gz
freebsd-ports-graphics-ab4ef14dabf8c4e904b9f1f0ff64a8ce3f01f320.tar.zst
freebsd-ports-graphics-ab4ef14dabf8c4e904b9f1f0ff64a8ce3f01f320.zip
WPA supplicant daemon for 802.11 networks.
Submitted by: sam
-rw-r--r--security/Makefile1
-rw-r--r--security/wpa_supplicant/Makefile25
-rw-r--r--security/wpa_supplicant/distinfo2
-rw-r--r--security/wpa_supplicant/files/config.bsd3
-rw-r--r--security/wpa_supplicant/pkg-descr9
-rw-r--r--security/wpa_supplicant/pkg-plist3
6 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 837adb5cfe2..953bcac27c7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -472,6 +472,7 @@
SUBDIR += vulnerability-test-port
SUBDIR += vuxml
SUBDIR += vxquery
+ SUBDIR += wpa_supplicant
SUBDIR += xca
SUBDIR += xinetd
SUBDIR += xmlsec
diff --git a/security/wpa_supplicant/Makefile b/security/wpa_supplicant/Makefile
new file mode 100644
index 00000000000..603282515f4
--- /dev/null
+++ b/security/wpa_supplicant/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: wpa_supplicant
+# Date created: 7 December 2004
+# Whom: sam
+#
+# $FreeBSD$
+#
+
+PORTNAME= wpa_suplicant
+PORTVERSION= 0.3.0
+CATEGORIES= security
+MASTER_SITES= http://hostap.epitest.fi/releases/
+DISTNAME= wpa_supplicant-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Supplicant (client) for WPA/802.1x protocols
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_GMAKE= yes
+
+post-extract:
+ @${CP} ${FILESDIR}/config.bsd ${WRKSRC}/.config
+
+.include <bsd.port.mk>
diff --git a/security/wpa_supplicant/distinfo b/security/wpa_supplicant/distinfo
new file mode 100644
index 00000000000..f93a79570eb
--- /dev/null
+++ b/security/wpa_supplicant/distinfo
@@ -0,0 +1,2 @@
+MD5 (wpa_supplicant-0.3.0.tar.gz) = 579e663120882835b5b2484ccfa60548
+SIZE (wpa_supplicant-0.3.0.tar.gz) = 253706
diff --git a/security/wpa_supplicant/files/config.bsd b/security/wpa_supplicant/files/config.bsd
new file mode 100644
index 00000000000..814a97d5e28
--- /dev/null
+++ b/security/wpa_supplicant/files/config.bsd
@@ -0,0 +1,3 @@
+CONFIG_DRIVER_BSD=y
+CFLAGS += -I/usr/local/include
+LIBS += -L/usr/local/lib
diff --git a/security/wpa_supplicant/pkg-descr b/security/wpa_supplicant/pkg-descr
new file mode 100644
index 00000000000..df2abd11278
--- /dev/null
+++ b/security/wpa_supplicant/pkg-descr
@@ -0,0 +1,9 @@
+wpa_supplicant is a client (supplicant) for the WPA, 802.11i, and
+802.1x security protocols typically used over wireless networks.
+You must have a WPA, 802.11i, or 802.1x authenticator (server) to
+make use of this program.
+
+WWW: http://hostap.epitest.fi/wpa_supplicant/
+
+- Sam Leffler
+sam@FreeBSD.org
diff --git a/security/wpa_supplicant/pkg-plist b/security/wpa_supplicant/pkg-plist
new file mode 100644
index 00000000000..5b0ff52f7b5
--- /dev/null
+++ b/security/wpa_supplicant/pkg-plist
@@ -0,0 +1,3 @@
+bin/wpa_supplicant
+bin/wpa_passphrase
+bin/wpa_cli