aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-23 05:58:11 +0800
committermiwi <miwi@FreeBSD.org>2009-05-23 05:58:11 +0800
commitac89e231e8f245da8d01ad9c221971921bac9527 (patch)
tree5c4da1fc908328b294fc9b4ac53efd25ddd13524
parent3c42024ce91510233974e8a29d31afae83717740 (diff)
downloadfreebsd-ports-graphics-ac89e231e8f245da8d01ad9c221971921bac9527.tar.gz
freebsd-ports-graphics-ac89e231e8f245da8d01ad9c221971921bac9527.tar.zst
freebsd-ports-graphics-ac89e231e8f245da8d01ad9c221971921bac9527.zip
p5::Astro is a set of assorted astronomical routines.
WWW: http://search.cpan.org/dist/Astro/ PR: ports/134693 Submitted by: Wen Heping <wenheping at gmail.com>
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-Astro/Makefile23
-rw-r--r--astro/p5-Astro/distinfo3
-rw-r--r--astro/p5-Astro/pkg-descr7
-rw-r--r--astro/p5-Astro/pkg-plist6
5 files changed, 40 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index d36446cbb56..ee369feccb5 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -40,6 +40,7 @@
SUBDIR += openmap
SUBDIR += openuniverse
SUBDIR += orsa
+ SUBDIR += p5-Astro
SUBDIR += p5-Astro-ADS
SUBDIR += p5-Astro-Catalog
SUBDIR += p5-Astro-DSS
diff --git a/astro/p5-Astro/Makefile b/astro/p5-Astro/Makefile
new file mode 100644
index 00000000000..599a5277f16
--- /dev/null
+++ b/astro/p5-Astro/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: Astro
+# Date created: 18 May, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro
+PORTVERSION= 0.71
+CATEGORIES= astro perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A collection of useful astronomical routines in Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Astro::Time.3 \
+ Astro::Misc.3 \
+ Astro::Coord.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-Astro/distinfo b/astro/p5-Astro/distinfo
new file mode 100644
index 00000000000..863e59038d7
--- /dev/null
+++ b/astro/p5-Astro/distinfo
@@ -0,0 +1,3 @@
+MD5 (Astro-0.71.tar.gz) = e194a0532b93697cb0c2d906fc4fb071
+SHA256 (Astro-0.71.tar.gz) = a691de090b76d54e645cf6487ea77ce0859b1f38aa441d514638b1353fd61915
+SIZE (Astro-0.71.tar.gz) = 33582
diff --git a/astro/p5-Astro/pkg-descr b/astro/p5-Astro/pkg-descr
new file mode 100644
index 00000000000..f4c94f92086
--- /dev/null
+++ b/astro/p5-Astro/pkg-descr
@@ -0,0 +1,7 @@
+p5-Astro is a set of assorted astronomical routines.
+
+Astro::Time, Astro::Coord and Astro::Misc provide a collection of
+useful astronomical routines written entirely in Perl (so no
+hassling about installing external libraries is required).
+
+WWW: http://search.cpan.org/dist/Astro/
diff --git a/astro/p5-Astro/pkg-plist b/astro/p5-Astro/pkg-plist
new file mode 100644
index 00000000000..dd09e9f86fb
--- /dev/null
+++ b/astro/p5-Astro/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Astro/Coord.pm
+%%SITE_PERL%%/Astro/Misc.pm
+%%SITE_PERL%%/Astro/Time.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/.packlist
+@dirrmtry %%SITE_PERL%%/Astro
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro