aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-09 03:00:10 +0800
committermarcus <marcus@FreeBSD.org>2004-07-09 03:00:10 +0800
commitad7eb8f7bbde39c79e0299c92205f88960557bbb (patch)
tree6ebea12812ac28b0ff1d58e8de293cb778992f28
parent45d06d5277477f4412ec65407434eb08c495b2b0 (diff)
downloadfreebsd-ports-graphics-ad7eb8f7bbde39c79e0299c92205f88960557bbb.tar.gz
freebsd-ports-graphics-ad7eb8f7bbde39c79e0299c92205f88960557bbb.tar.zst
freebsd-ports-graphics-ad7eb8f7bbde39c79e0299c92205f88960557bbb.zip
* Fix crash when typing <space> <tab>
* Fix a Glib warning when using completion in dialogs Obtained from: http://xchat.org/files/source/2.0/patches/
-rw-r--r--irc/xchat2/Makefile1
-rw-r--r--irc/xchat2/files/patch-fixtabcomp24
2 files changed, 25 insertions, 0 deletions
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index ba8835d67c4..861644c2397 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xchat2
PORTVERSION= 2.0.10
+PORTREVISION= 1
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://xchat.org/files/source/2.0/
DISTNAME= xchat-${PORTVERSION}
diff --git a/irc/xchat2/files/patch-fixtabcomp b/irc/xchat2/files/patch-fixtabcomp
new file mode 100644
index 00000000000..0f96282fb27
--- /dev/null
+++ b/irc/xchat2/files/patch-fixtabcomp
@@ -0,0 +1,24 @@
+# Fixes two tab-nick-completion bugs:
+# 1. Crash when you type space-tab
+# 2. Critical glib warning when completion in a dialog-tab.
+--- src/fe-gtk/fkeys.c 2004-07-01 18:28:43.000000000 +0200
++++ src/fe-gtk/fkeys.c 2004-07-05 12:19:56.000000000 +0200
+@@ -1394,7 +1394,7 @@
+ skip_len++;
+ }
+ else
+- cursor_pos = g_utf8_pointer_to_offset(text, g_utf8_offset_to_pointer(ch, 1));
++ return 2;
+ }
+
+ comp = skip_len;
+@@ -1599,7 +1599,8 @@
+ gtk_entry_set_text (GTK_ENTRY (t), buf);
+ gtk_editable_set_position (GTK_EDITABLE (t), g_utf8_pointer_to_offset(buf, buf + cursor_pos));
+ }
+- g_completion_free(gcomp);
++ if (gcomp)
++ g_completion_free(gcomp);
+ return 2;
+ }
+ #undef COMP_BUF