aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-04-13 17:16:23 +0800
committerjylefort <jylefort@FreeBSD.org>2006-04-13 17:16:23 +0800
commitaf0eab74d695d1f8a871ed880f7f911870a4119c (patch)
tree6e16fbf7875d83447240cc4fb8045bdafc13a7ba
parentabadc6faf930976026c4e6890fd5deafa1c223a9 (diff)
downloadfreebsd-ports-graphics-af0eab74d695d1f8a871ed880f7f911870a4119c.tar.gz
freebsd-ports-graphics-af0eab74d695d1f8a871ed880f7f911870a4119c.tar.zst
freebsd-ports-graphics-af0eab74d695d1f8a871ed880f7f911870a4119c.zip
Add linux-padjoy.
padJoy is a PSEmu Pro joystick plugin. This is the Linux version, tested with emulators/linux-ePSXe. WWW: http://download.ammoq.com/ Hint by: Timothy Beyer <beyert@cs.ucr.edu>
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/linux-padjoy/Makefile51
-rw-r--r--emulators/linux-padjoy/distinfo3
-rw-r--r--emulators/linux-padjoy/pkg-descr8
-rw-r--r--emulators/linux-padjoy/pkg-message6
-rw-r--r--emulators/linux-padjoy/pkg-plist8
6 files changed, 77 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index c864100725b..29c2dbf45a2 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -53,6 +53,7 @@
SUBDIR += libvm68k
SUBDIR += linux-ePSXe
SUBDIR += linux-geepee32
+ SUBDIR += linux-padjoy
SUBDIR += linux-peops-softgpu
SUBDIR += linux-peops-spu
SUBDIR += linux-pete-mesagpu
diff --git a/emulators/linux-padjoy/Makefile b/emulators/linux-padjoy/Makefile
new file mode 100644
index 00000000000..97a01d3dfbe
--- /dev/null
+++ b/emulators/linux-padjoy/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: linux-padjoy
+# Date created: 13 Apr 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= padjoy
+PORTVERSION= 0.8.1
+CATEGORIES= emulators linux
+MASTER_SITES= http://members.chello.at/erich.kitzmueller/ammoq/
+PKGNAMEPREFIX= linux-
+DISTNAME= padJoy${MAJOR}${MINOR}${MICRO}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A PSEmu Pro joystick plugin (Linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk \
+ /boot/modules/linux_js.ko:${PORTSDIR}/devel/linux-js
+
+WRKSRC= ${WRKDIR}/padJoy
+NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
+
+ONLY_FOR_ARCHS= i386 amd64
+
+MAJOR= ${PORTVERSION:R:R}
+MINOR= ${PORTVERSION:R:E}
+MICRO= ${PORTVERSION:E}
+PLIST_SUB= MAJOR=${MAJOR} MINOR=${MINOR}
+
+PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
+PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
+
+do-install:
+ ${MKDIR} ${PSEMUPRO_PLUGINS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/libpadJoy-${MAJOR}.${MINOR}.so ${PSEMUPRO_PLUGINS_DIR}
+
+ ${MKDIR} ${PSEMUPRO_CFGBINS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/cfgPadJoy ${PSEMUPRO_CFGBINS_DIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/emulators/linux-padjoy/distinfo b/emulators/linux-padjoy/distinfo
new file mode 100644
index 00000000000..2aee37b463b
--- /dev/null
+++ b/emulators/linux-padjoy/distinfo
@@ -0,0 +1,3 @@
+MD5 (padJoy081.tgz) = 19940dedd33d76255375cfd1ba14fd9a
+SHA256 (padJoy081.tgz) = 5b964eee36eb9a8ba7e389b4b148a98e7b69112e4b6d797578ab13261881f1ae
+SIZE (padJoy081.tgz) = 48344
diff --git a/emulators/linux-padjoy/pkg-descr b/emulators/linux-padjoy/pkg-descr
new file mode 100644
index 00000000000..9adec3208c6
--- /dev/null
+++ b/emulators/linux-padjoy/pkg-descr
@@ -0,0 +1,8 @@
+padJoy is a PSEmu Pro joystick plugin.
+
+This is the Linux version, tested with emulators/linux-ePSXe.
+
+WWW: http://download.ammoq.com/
+
+- Jean-Yves Lefort
+jylefort@FreeBSD.org
diff --git a/emulators/linux-padjoy/pkg-message b/emulators/linux-padjoy/pkg-message
new file mode 100644
index 00000000000..a278c249c54
--- /dev/null
+++ b/emulators/linux-padjoy/pkg-message
@@ -0,0 +1,6 @@
+===============================================================================
+
+This plugin requires the linux_js kernel module. For more details, consult the
+linux_js(4) manual page.
+
+===============================================================================
diff --git a/emulators/linux-padjoy/pkg-plist b/emulators/linux-padjoy/pkg-plist
new file mode 100644
index 00000000000..894304a4f2a
--- /dev/null
+++ b/emulators/linux-padjoy/pkg-plist
@@ -0,0 +1,8 @@
+lib/psemupro/plugins/libpadJoy-%%MAJOR%%.%%MINOR%%.so
+libexec/psemupro/cfg/cfgPadJoy
+@dirrmtry lib/psemupro/plugins
+@dirrmtry lib/psemupro
+@dirrmtry libexec/psemupro/cfg
+@dirrmtry libexec/psemupro
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%