aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2002-08-08 19:52:15 +0800
committertrevor <trevor@FreeBSD.org>2002-08-08 19:52:15 +0800
commitaf2130c652727d1ca0fbfe0451973cde2e9d2d5a (patch)
tree731aa830318052895b5da65797fb51838676c2e4
parenta62680eec609bfef59e73421776d654efe376c7e (diff)
downloadfreebsd-ports-graphics-af2130c652727d1ca0fbfe0451973cde2e9d2d5a.tar.gz
freebsd-ports-graphics-af2130c652727d1ca0fbfe0451973cde2e9d2d5a.tar.zst
freebsd-ports-graphics-af2130c652727d1ca0fbfe0451973cde2e9d2d5a.zip
The patching with sed was done incorrectly. Patch the INSTALL
script with patch(1) only, not with both patch(1) and sed. Correct the use of sed for patching other files. PR: 41121 Submitted by: KOMATSU Shinichiro
-rw-r--r--print/acroread5/Makefile7
-rw-r--r--print/acroread5/files/patch-aa20
2 files changed, 18 insertions, 9 deletions
diff --git a/print/acroread5/Makefile b/print/acroread5/Makefile
index c904b31b607..988bbf531c2 100644
--- a/print/acroread5/Makefile
+++ b/print/acroread5/Makefile
@@ -21,7 +21,7 @@ ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_REINPLACE= yes
-REINPLACE_ARGS= -i
+REINPLACE_ARGS= -E
NO_FILTER_SHLIBS= yes
.if ${ARCH} == "i386"
@@ -29,9 +29,6 @@ PLIST_SUB= "ARCHDIR=intellinux"
.endif
WRKSRC= ${WRKDIR}
-pre-configure:
- ${REINPLACE_CMD} -E 's:Linux):FreeBSD|Linux):g' ${WRKDIR}/INSTALL
-
do-build:
@${ECHO_MSG} "Do a \`make install' as root."
@@ -44,7 +41,7 @@ do-install:
.endif
post-install:
- ${REINPLACE_CMD} -E 's:Linux):FreeBSD|Linux):g' ${PREFIX}/Acrobat5/bin/acroread
+ ${REINPLACE_CMD} 's:Linux):FreeBSD|Linux):g' ${PREFIX}/Acrobat5/bin/acroread
-@/compat/linux/usr/bin/strip ${PREFIX}/Acrobat5/Reader/intellinux/bin/acroread
@brandelf -t Linux ${PREFIX}/Acrobat5/Reader/intellinux/bin/acroread
${REINPLACE_CMD} -E 's:OSF1):FreeBSD|OSF1):g' ${PREFIX}/Acrobat5/bin/acroread
diff --git a/print/acroread5/files/patch-aa b/print/acroread5/files/patch-aa
index f7a047013bd..1df7cbfd412 100644
--- a/print/acroread5/files/patch-aa
+++ b/print/acroread5/files/patch-aa
@@ -1,8 +1,11 @@
---- INSTALL.orig Thu May 23 13:00:47 2002
-+++ INSTALL Thu May 23 13:04:47 2002
-@@ -135,6 +135,8 @@
+--- INSTALL.orig Mon Jul 1 15:09:57 2002
++++ INSTALL Thu Aug 8 04:28:23 2002
+@@ -133,8 +133,10 @@
+ total=0
+ for i in $* ; do
if [ "$i" -a -f "$i" ] ; then
- if [ `uname -s` = "Linux" ] ; then
+- if [ `uname -s` = "Linux" ] ; then
++ if [ `uname -s` = "FreeBSD|Linux" ] ; then
size=`ls -lLn "$i" | ( read perm links owner group size date ; echo $size )`
+ elif [ `uname -s` = "FreeBSD" ] ; then
+ size=`ls -lL "$i" | ( read perm links owner group size date ; echo $size )`
@@ -18,3 +21,12 @@
ReadLicense=""
PrintRequiredFree "$ReadTar" "$SearchTar" "$CustomTar" \
+@@ -524,7 +526,7 @@
+ ;;
+ esac
+ ;;
+- Linux)
++ FreeBSD)
+ ReadDefaultNum="$ReadIntelLinuxNum"
+ DefaultName="Intel/Linux"
+ ;;