aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2005-04-24 22:11:07 +0800
committermarkus <markus@FreeBSD.org>2005-04-24 22:11:07 +0800
commitb312708afce5effb67b1ebebe387c4316f1bbdb6 (patch)
treea7e50e1bd62cafa1eefcf743acedd7743f6275e5
parentdd5bd171e2623a93d82bc5623bcde75ec7d015fe (diff)
downloadfreebsd-ports-graphics-b312708afce5effb67b1ebebe387c4316f1bbdb6.tar.gz
freebsd-ports-graphics-b312708afce5effb67b1ebebe387c4316f1bbdb6.tar.zst
freebsd-ports-graphics-b312708afce5effb67b1ebebe387c4316f1bbdb6.zip
- Update to version 0.36
- Use OPTIONS - Support Python2.4
-rw-r--r--deskutils/superkaramba/Makefile32
-rw-r--r--deskutils/superkaramba/distinfo4
-rw-r--r--deskutils/superkaramba/files/patch-configure385
3 files changed, 16 insertions, 405 deletions
diff --git a/deskutils/superkaramba/Makefile b/deskutils/superkaramba/Makefile
index a401b20f5d2..1d827445703 100644
--- a/deskutils/superkaramba/Makefile
+++ b/deskutils/superkaramba/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= superkaramba
-PORTVERSION= 0.35
-PORTREVISION= 1
+PORTVERSION= 0.36
CATEGORIES= deskutils kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= netdragon
@@ -14,35 +13,32 @@ MASTER_SITE_SUBDIR= netdragon
MAINTAINER= markus@FreeBSD.org
COMMENT= KDE tool that allows interactive eye-candy on the desktop
-.if defined(WITH_XMMS)
-LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
-.endif
-
-.if defined(WITH_XMBMON)
-RUN_DEPENDS= mbmon:${PORTSDIR}/sysutils/xmbmon
-.endif
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
USE_KDEBASE_VER= 3
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= glib12 gtk12
USE_PYTHON= yes
-PYTHON_VERSION= python2.3
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CONFIGURE_ARGS+= --with-pythondir=${PYTHON_INCLUDEDIR}
-pre-everything::
-.if !defined(WITH_XMMS)
- @${ECHO_MSG} "You can enable XMMS support by defining WITH_XMMS."
+OPTIONS= XMMS "XMMS support" off \
+ XMBMON "Mainboard monitor support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_XMMS)
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
.endif
-.if !defined(WITH_XMBMON)
- @${ECHO_MSG} "You can enable mainboard monitor support by defining WITH_XMBMON."
+
+.if defined(WITH_XMBMON)
+RUN_DEPENDS= mbmon:${PORTSDIR}/sysutils/xmbmon
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-O2 ||g; s|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-O2 ||g;' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/superkaramba/distinfo b/deskutils/superkaramba/distinfo
index d8898b188ee..acaa06f7568 100644
--- a/deskutils/superkaramba/distinfo
+++ b/deskutils/superkaramba/distinfo
@@ -1,2 +1,2 @@
-MD5 (superkaramba-0.35.tar.gz) = c397c35fc98112f13c35cee101085dde
-SIZE (superkaramba-0.35.tar.gz) = 1363255
+MD5 (superkaramba-0.36.tar.gz) = 4c03567dde3583c53747e153a8aff867
+SIZE (superkaramba-0.36.tar.gz) = 1499295
diff --git a/deskutils/superkaramba/files/patch-configure b/deskutils/superkaramba/files/patch-configure
deleted file mode 100644
index ac450ef8504..00000000000
--- a/deskutils/superkaramba/files/patch-configure
+++ /dev/null
@@ -1,385 +0,0 @@
---- configure.orig Fri Nov 19 19:06:13 2004
-+++ configure Fri Nov 19 19:20:05 2004
-@@ -22257,7 +22257,103 @@
- fi
-
-
--echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
-+ LIBPTHREAD=""
-+
-+ if test -n "$PTHREAD_LIBS"; then
-+ if test "x$PTHREAD_LIBS" = "x-pthread" ; then
-+ LIBPTHREAD="PTHREAD"
-+ else
-+ PTHREAD_LIBS_save="$PTHREAD_LIBS"
-+ PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
-+ echo "$as_me:$LINENO: checking for pthread_create in $PTHREAD_LIBS" >&5
-+echo $ECHO_N "checking for pthread_create in $PTHREAD_LIBS... $ECHO_C" >&6
-+
-+ kde_save_LDFLAGS="$LDFLAGS"
-+ kde_save_LIBS="$LIBS"
-+ LDFLAGS="$LDFLAGS $all_libraries"
-+ case $host_os in
-+ aix*) LDFLAGS="-brtl $LDFLAGS"
-+ test "$GCC" = yes && LDFLAGS="-Wl,$LDFLAGS"
-+ ;;
-+ esac
-+ as_ac_Lib=`echo "ac_cv_lib_$PTHREAD_LIBS''_pthread_create" | $as_tr_sh`
-+echo "$as_me:$LINENO: checking for pthread_create in -l$PTHREAD_LIBS" >&5
-+echo $ECHO_N "checking for pthread_create in -l$PTHREAD_LIBS... $ECHO_C" >&6
-+if eval "test \"\${$as_ac_Lib+set}\" = set"; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+ ac_check_lib_save_LIBS=$LIBS
-+LIBS="-l$PTHREAD_LIBS $LIBS"
-+cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+
-+/* Override any gcc2 internal prototype to avoid an error. */
-+#ifdef __cplusplus
-+extern "C"
-+#endif
-+/* We use char because int might match the return type of a gcc2
-+ builtin and then its argument prototype would still apply. */
-+char pthread_create ();
-+int
-+main ()
-+{
-+pthread_create ();
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+ eval "$as_ac_Lib=yes"
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+eval "$as_ac_Lib=no"
-+fi
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+LIBS=$ac_check_lib_save_LIBS
-+fi
-+echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
-+echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
-+if test `eval echo '${'$as_ac_Lib'}'` = yes; then
-+ LIBPTHREAD="$PTHREAD_LIBS_save"
-+fi
-+
-+ LDFLAGS="$kde_save_LDFLAGS"
-+ LIBS="$kde_save_LIBS"
-+
-+ PTHREAD_LIBS="$PTHREAD_LIBS_save"
-+ fi
-+ fi
-+
-+ if test -z "$LIBPTHREAD"; then
-+ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
- echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
- if test "${ac_cv_lib_pthread_pthread_create+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-@@ -22324,6 +22420,277 @@
- if test $ac_cv_lib_pthread_pthread_create = yes; then
- LIBPTHREAD="-lpthread"
- fi
-+
-+ fi
-+
-+ if test -z "$LIBPTHREAD" ; then
-+ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
-+echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
-+ kde_safe_libs=$LIBS
-+ LIBS="$LIBS -lpthread"
-+ cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+#include <pthread.h>
-+int
-+main ()
-+{
-+(void)pthread_create(0,0,0,0);
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+
-+ echo "$as_me:$LINENO: result: yes" >&5
-+echo "${ECHO_T}yes" >&6
-+ LIBPTHREAD="-lpthread"
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+
-+ echo "$as_me:$LINENO: result: no" >&5
-+echo "${ECHO_T}no" >&6
-+fi
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+ LIBS=$kde_safe_libs
-+ fi
-+
-+ if test "x$LIBPTHREAD" = "xPTHREAD" ; then
-+ LIBPTHREAD=""
-+ fi
-+
-+
-+
-+
-+ USE_THREADS=""
-+ if test -z "$LIBPTHREAD"; then
-+
-+echo "$as_me:$LINENO: checking whether $CXX supports -pthread" >&5
-+echo $ECHO_N "checking whether $CXX supports -pthread... $ECHO_C" >&6
-+kde_cache=`echo pthread | sed 'y% .=/+-,%____p__%'`
-+if eval "test \"\${kde_cv_prog_cxx_$kde_cache+set}\" = set"; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+
-+
-+
-+ ac_ext=cc
-+ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-+ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
-+ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-+
-+ac_link='rm -rf SunWS_cache; ${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
-+
-+
-+ save_CXXFLAGS="$CXXFLAGS"
-+ CXXFLAGS="$CXXFLAGS -pthread"
-+ cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+
-+int
-+main ()
-+{
-+ return 0;
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_cxx_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+ eval "kde_cv_prog_cxx_$kde_cache=yes"
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+fi
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+ CXXFLAGS="$save_CXXFLAGS"
-+ ac_ext=c
-+ac_cpp='$CPP $CPPFLAGS'
-+ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-+ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
-+ac_compiler_gnu=$ac_cv_c_compiler_gnu
-+
-+
-+fi
-+
-+if eval "test \"`echo '$kde_cv_prog_cxx_'$kde_cache`\" = yes"; then
-+ echo "$as_me:$LINENO: result: yes" >&5
-+echo "${ECHO_T}yes" >&6
-+ :
-+ USE_THREADS="-D_THREAD_SAFE -pthread"
-+else
-+ echo "$as_me:$LINENO: result: no" >&5
-+echo "${ECHO_T}no" >&6
-+ :
-+
-+fi
-+
-+ fi
-+
-+
-+
-+ case $host_os in
-+ solaris*)
-+
-+echo "$as_me:$LINENO: checking whether $CXX supports -mt" >&5
-+echo $ECHO_N "checking whether $CXX supports -mt... $ECHO_C" >&6
-+kde_cache=`echo mt | sed 'y% .=/+-,%____p__%'`
-+if eval "test \"\${kde_cv_prog_cxx_$kde_cache+set}\" = set"; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+
-+
-+
-+ ac_ext=cc
-+ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-+ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
-+ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-+
-+ac_link='rm -rf SunWS_cache; ${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
-+
-+
-+ save_CXXFLAGS="$CXXFLAGS"
-+ CXXFLAGS="$CXXFLAGS -mt"
-+ cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+
-+int
-+main ()
-+{
-+ return 0;
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_cxx_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+ eval "kde_cv_prog_cxx_$kde_cache=yes"
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+fi
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+ CXXFLAGS="$save_CXXFLAGS"
-+ ac_ext=c
-+ac_cpp='$CPP $CPPFLAGS'
-+ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-+ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
-+ac_compiler_gnu=$ac_cv_c_compiler_gnu
-+
-+
-+fi
-+
-+if eval "test \"`echo '$kde_cv_prog_cxx_'$kde_cache`\" = yes"; then
-+ echo "$as_me:$LINENO: result: yes" >&5
-+echo "${ECHO_T}yes" >&6
-+ :
-+ USE_THREADS="-mt"
-+else
-+ echo "$as_me:$LINENO: result: no" >&5
-+echo "${ECHO_T}no" >&6
-+ :
-+
-+fi
-+
-+ CPPFLAGS="$CPPFLAGS -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DUSE_SOLARIS -DSVR4"
-+ ;;
-+ freebsd*)
-+ CPPFLAGS="$CPPFLAGS -D_THREAD_SAFE $PTHREAD_CFLAGS"
-+ ;;
-+ aix*)
-+ CPPFLAGS="$CPPFLAGS -D_THREAD_SAFE"
-+ LIBPTHREAD="$LIBPTHREAD -lc_r"
-+ ;;
-+ linux*) CPPFLAGS="$CPPFLAGS -D_REENTRANT"
-+ if test "$CXX" = "KCC"; then
-+ CXXFLAGS="$CXXFLAGS --thread_safe"
-+ NOOPT_CXXFLAGS="$NOOPT_CXXFLAGS --thread_safe"
-+ fi
-+ ;;
-+ *)
-+ ;;
-+ esac
-
-
-
/cgit.cgi/freebsd-ports-gnome/commit/benchmarks?h=gstreamer0.10-removal&id=81aad404bb3501e152cb6da22879db405ee5d0d3'>BROKEN on 5.x: Broken by make(1) changeskris2004-09-191-1/+7 * - use getnodeipbyname() instead of unsafe gethostbyname() to preventclement2004-09-142-0/+13 * - Update to 2.1.2clement2004-08-242-5/+6 * - Define JAVA_VERSION;thierry2004-08-212-11/+17 * OPTIMIZED_FLAGS should be WITH_OPTMIZED_FLAGSmaho2004-08-181-2/+2 * Fix many thingsmaho2004-08-182-39/+24 * Fix typomaho2004-08-161-2/+2 * Marked as RESTRICTED.maho2004-08-161-2/+1 * User settable USE_* -> WITH_*maho2004-08-161-12/+12 * WITH_IFC, WITH_ICC -> USE_IFC, USE_ICCmaho2004-08-162-25/+25 * Add Himeno Benchmark. this suite was made by HIMENO, Ryutaro,maho2004-08-1610-0/+220 * maho@ reported that atlas isn't broken any longer on amd64oliver2004-07-141-5/+0 * Add CONFLICTS - both pkg-plist files containes bin/ltrace.osa2004-07-142-0/+4 * Update to 1.5krion2004-07-022-3/+3 * Sipp is a performance test tool / traffic generator for the SIP protocol.lth2004-06-186-0/+557 * - Fix dependency on httperf forgotten in previous repocopyclement2004-06-101-1/+1 * - Move httperf from www to benchmarks categoryclement2004-06-102-1/+2 * - Chase checksum. Diff can be found in PRpav2004-06-102-4/+5 * - Fix MASTER_SITESclement2004-05-221-2/+1 * Since the recent updates, Jikes does not compile this programthierry2004-04-121-0/+1 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+2 * SIZEify (maintainer timeout)trevor2004-03-315-0/+8 * Upgrade to 2.2pl4.sumikawa2004-03-302-4/+4 * Makefile.pnet:pav2004-03-271-3/+0 * Add pnetmark, a benchmark program for Common Language Runtime (C#)pav2004-03-264-0/+55 * Add SIZE data to distinfo files.se2004-03-233-0/+3 * Add SIZE information.jkoshy2004-03-221-0/+1 * The gshar+gunshar port is renamed to ports/archivers/sharutils.trevor2004-03-201-1/+1 * SIZE-ify my ports.thierry2004-03-192-0/+2 * Add SIZE.sumikawa2004-03-181-0/+1 * - SIZEify.mich2004-03-181-0/+1 * Add size data.trevor2004-03-182-0/+2 * SIZEify my ports.leeym2004-03-181-0/+1 * Add SIZE information.jkoshy2004-03-181-0/+1 * SIZEify.trevor2004-03-181-0/+1 * - Mark BROKEN: Checksum mismatchkrion2004-03-031-0/+2 * unbreak ; it did build on my -current (Feb/09/2004)ijliao2004-03-022-9/+3 * Fix BROKEN by update to latest 2.8.0 version.osa2004-02-2710-98/+128 * - Update to version 1.3krion2004-02-263-14/+3 * High Performance Computing Linpack Benchmarkoliver2004-02-265-0/+153 * Mark as broken on 4.x as well as 5.x. No response from maintainerlinimon2004-02-122-4/+0 * add sizeleeym2004-02-111-0/+1 * - SIZEify distinfoclement2004-02-081-0/+1 * Use PLIST_FILES (bento-tested, marcus-reviewed).trevor2004-02-0620-11/+13 * Use PLIST_FILES.trevor2004-02-062-1/+1 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-042-0/+2 * - Fix build on -STABLEpav2004-01-313-0/+17 * - Update to 1.2pav2004-01-314-16/+3 * SIZEify.trevor2004-01-301-0/+1 * Fix build on -stable.ale2004-01-292-0/+15 * - Update to 2.59clement2004-01-293-14/+4 * Add SIZE.trevor2004-01-288-0/+8 * - Allow blasting 10000 blockspav2004-01-263-2/+4 * - Obey NO_INSTALL_MANPAGESpav2004-01-243-4/+19 * Add forkbomb 1.0, system stress testing tool.ale2004-01-236-0/+45 * - Update to version 1.4krion2004-01-224-30/+13 * - move the three individual distfiles into ${DISTFILES}/ttcp tomharo2004-01-172-7/+8 * [REPOCOPY WAITING] ports/net/nttcp and ports/net/ttcp appear miscategorizededwin2004-01-163-2/+4 * Add webbench 1.3, simple forking web benchmark.ale2004-01-146-0/+55 * - Update my email addressclement2004-01-131-1/+1 * - Update to v0.6krion2004-01-113-3/+3 * - Update to 2.1.1krion2004-01-112-3/+3 * [PATCH] benchmarks/rawio has a bug in commandline option parseredwin2004-01-102-5/+15 * Add category=benchmarks to the ports Makefileedwin2004-01-101-1/+1 * - support large filespetef2003-12-212-0/+48 * update MASTER_SITESmharo2003-12-171-1/+1 * - Update to 2.57pav2003-12-046-15/+72 * - Our other two 64-bit platforms needs min(int, int) workaround toopav2003-11-222-8/+2 * Reset unreachable MAINTAINERs to ports@FreeBSD.orgeik2003-11-201-1/+1 * - Unbreak by using EXTRACT_DEPENDS for gunshar.pav2003-11-191-1/+1 * USE_REINPLACE need be defined only when REINPLACE_CMD is used.trevor2003-11-171-1/+0 * Upgrade to v3.6.jkoshy2003-11-173-6/+6 * - Add patch to respect CFLAGSkrion2003-11-031-0/+15 * ports with possibly unreachable MAINTAINERsedwin2003-11-021-1/+1 * Move inclusion of bsd.port.pre.mk past all variable definitions.linimon2003-10-291-4/+4 * Cosmetic fix: use %%DOCSDIR%% macro.osa2003-10-226-18/+18 * Per bento logs, mark as broken on 5.x.linimon2003-10-221-1/+7 * add autobench 2.0.1ijliao2003-10-215-0/+49 * Respect CC and CFLAGSkris2003-10-191-0/+13 * Mark broken for gcc 3.3. The author seems to be tracking gcc updateslinimon2003-10-161-1/+7 * - Add CONFLICTS, because of the same item in pkg-plistkrion2003-10-112-0/+4 * Make portlint(1) happy by changing strip to ${STRIP_CMD}osa2003-09-243-4/+4 * Cease FreeBSD port maintainershipsedwin2003-09-241-1/+1 * New port: benchmarks/scimark2 - a Java benchmark.edwin2003-08-295-0/+101 * New port: benchmarks/scimark2c - an ANSI C version of the SciMark2 benchmark.edwin2003-08-297-0/+77 * Upgrade to version 3.196jmz2003-08-102-4/+2 * BROKEN: CHecksum mismatchkris2003-08-071-0/+2 * Take over maintainership with Dmitry's blessing.adrian2003-07-312-2/+2 * Mark BROKEN on 5.x: does not compilekris2003-07-312-2/+16 * Let be hohest: I really don't have a time now to properly maintain allsobomax2003-07-291-1/+1 * Make this compiled on -stable.simokawa2003-07-251-1/+0 * Add support for ipv6.simokawa2003-07-252-38/+50 * Upgrade to v3.5.jkoshy2003-07-123-16/+3 * update maintainer's email address.leeym2003-06-241-1/+1 * File moved on master site.se2003-06-182-2/+2 * Update to 0.62pat2003-06-132-2/+2 * Assign MAINTAINER to ports@FreeBSD.org.adamw2003-06-051-1/+1 * Update the checksum.jmz2003-05-201-1/+1 * Use USE_GETOPT_LONG.petef2003-05-191-7/+1 * Add 'ipv6' on CATEGORIES.sumikawa2003-05-181-1/+1 * Update iperf to 1.7.0.smace2003-05-172-3/+3 * Upgrade to version 3.172jmz2003-05-152-2/+2 * Change maintainer email to my @FreeBSD.org addressmich2003-05-072-2/+2 * [Maintainer Update]: benchmarks/pipebenchedwin2003-04-292-7/+8 * change maintainer addressedwin2003-04-221-1/+1 * Change MAINTAINER to new address.nork2003-04-191-1/+1 * Add missing fileskris2003-04-051-0/+3 * Clear moonlight beckons.ade2003-03-0732-16/+16 * Fix the build on 64-bit machines.obrien2003-03-061-0/+15 * Install the new docs, fix the path to them in the manpage, install all manpages.obrien2003-02-262-2/+13 * Update to version 1.93c.obrien2003-02-263-12/+7 * Upgrade to 2.2pl3.sumikawa2003-02-223-17/+10 * De-pkg-comment.knu2003-02-2114-7/+7 * De-pkg-comment.knu2003-02-212-1/+1 * De-pkg-comment.knu2003-02-2110-5/+5 * Fix pkg-plistedwin2003-02-031-1/+1 * Conditionalize libgnugetopt dependencies.nork2003-02-022-5/+19 * Fix typo in patch-makefile. IPv6 was not enabled.sumikawa2003-01-212-1/+2 * Upgrade to 2.2pl2. Almost of IPv6 patch was merged but netperf stillsumikawa2003-01-2115-334/+193 * Iperf 1.6.5 dropped doc/release.html. Update Makefile.smace2003-01-211-2/+2 * Upgrade to Iperf 1.6.5smace2003-01-192-3/+3 * misc/pipebench -> benchmarks/pipebenchedwin2003-01-186-0/+39 * Cleanup Makefile with after portlint.smace2003-01-081-2/+3 * Update to ipef-1.6.4.smace2003-01-082-3/+3 * upgrade to 2.56ijliao2003-01-042-3/+4 * upgrade to 1.03ijliao2003-01-023-15/+4 * Make benchmarks/dbench fetchable again.edwin2002-12-291-3/+1 * Old mastersite was unreachable for some time now, replaced it with ftp://ftp....edwin2002-12-282-5/+5 * Removed unreachable mater_site.edwin2002-12-281-1/+0 * Master_site is unreachable, informed author/maintainer.edwin2002-12-281-1/+3 * Update maintainersmace2002-11-231-1/+1 * add missing dependsijliao2002-11-211-3/+4 * upgrade to 0.8ijliao2002-11-206-22/+55 * gzcat -> ${GZCAT}arved2002-11-191-1/+1 * add WWWmharo2002-11-181-0/+2 * Maintainer update to version 2.55edwin2002-11-162-4/+5 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-118-8/+4 * Really show kBytes/s like the label says we are.simokawa2002-11-091-1/+1 * Upgrade to version 3.138jmz2002-11-094-45/+2 * Fix PORTCOMMENTs that were killing INDEX builds.adamw2002-11-072-2/+1 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-0710-5/+10 * Remove obsolete patch-filesedwin2002-11-053-42/+0 * PERL -> REINPLACEedwin2002-11-041-1/+2 * PERL -> REINPLACEedwin2002-11-041-1/+2 * Upgrade to version 3.137jmz2002-11-044-12/+32 * Fix typoes on MAINTAINER address.perky2002-11-021-1/+1 * Update iperf to version 1.6.3smace2002-10-184-53/+4 * Upgrade to version 1.2.grog2002-10-132-2/+2 * Update maintainer addressperky2002-10-081-1/+1 * Upgrade to v3.2.jkoshy2002-10-074-28/+29 * Upgrade to v2.4.jkoshy2002-09-182-2/+2 * Fix bonnie++ on -currentdwcjr2002-09-021-0/+2 * Use 8k chunks as Bonnie 1.0 did rather than 16k ones.obrien2002-08-281-1/+10 * Upgrade to version 2.0.6.obrien2002-08-27