aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-07-21 03:18:30 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-07-21 03:18:30 +0800
commitb55f847fa3877588d5ea8e3bb94ffb77442e6b8f (patch)
tree2a863f392d659b8df87a8c0c6f8d31b02643d0c5
parent1231feeeb8d5518531135fd4adac0825c9c468b9 (diff)
downloadfreebsd-ports-graphics-b55f847fa3877588d5ea8e3bb94ffb77442e6b8f.tar.gz
freebsd-ports-graphics-b55f847fa3877588d5ea8e3bb94ffb77442e6b8f.tar.zst
freebsd-ports-graphics-b55f847fa3877588d5ea8e3bb94ffb77442e6b8f.zip
- Update to 2.12.1
- Pass maintainership to pkubaj@anongoth.pl - Switch to options helpers - Cosmetic fixes - Switch to USES=ssl - While here, fix LICENSE and add LICENSE_FILE PR: 211083 [1], 211085 [2] Submitted by: pkubaj@anongoth.pl [1], serio.jeffrey@gmail.com (maintainer) [2] Approved by: serio.jeffrey@gmail.com (maintainer) [1]
-rw-r--r--irc/hexchat/Makefile57
-rw-r--r--irc/hexchat/distinfo5
2 files changed, 31 insertions, 31 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index 40825be1e55..a721c6a2f28 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -2,25 +2,30 @@
# $FreeBSD$
PORTNAME= hexchat
-PORTVERSION= 2.10.2
+PORTVERSION= 2.12.1
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://dl.hexchat.net/${PORTNAME}/
-MAINTAINER= serio.jeffrey@gmail.com
+MAINTAINER= pkubaj@anongoth.pl
COMMENT= IRC chat program with GTK and Text Frontend
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libproxy.so:net/libproxy
+LIB_DEPENDS= libproxy.so:net/libproxy \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libdbus-1.so:devel/dbus \
+ libfreetype.so:print/freetype2
-USES= gmake desktop-file-utils libtool pkgconfig tar:xz
-USE_GNOME= gtk20 intltool libxml2
+USES= gmake desktop-file-utils libtool pkgconfig tar:xz ssl
+USE_GNOME= cairo gtk20 intltool libxml2
+USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-openssl --enable-gtkfe --disable-sysinfo \
- --with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig
+ --with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig \
+ LUA=lua-${LUA_VER}
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
-USE_OPENSSL= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lX11
@@ -29,7 +34,7 @@ SUB_FILES= pkg-message
PORTDOCS= *
-OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOAT DOCS FISHLIM NLS NOTIFY \
+OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOAT DOCS FISHLIM LUA NLS NOTIFY \
PERL PYTHON SOCKS TEXTFE
OPTIONS_DEFAULT= CA_BUNDLE CANBERRA DBUS NOTIFY PERL PYTHON
@@ -45,21 +50,27 @@ SOCKS_DESC= SOCKS proxy support, FORBIDDEN in FreeBSD 10+
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
CANBERRA_LIB_DEPENDS= libcanberra.so:audio/libcanberra
-CANBERRA_CONFIGURE_ENABLE= libcanberra
+CANBERRA_CONFIGURE_ENABLE=libcanberra
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
DBUS_CONFIGURE_ENABLE= dbus
+DBUS_USE= GNOME=gconf2
DOAT_CONFIGURE_ENABLE= doat
-FISHLIM_CONFIGURE_ENABLE= fishlim
+FISHLIM_CONFIGURE_ENABLE=fishlim
+LUA_CONFIGURE_ENABLE= lua
+LUA_USES= lua
+LUA_USE= GCC=any
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
NLS_USES_OFF= gettext-tools # doesn't build otherwise
NOTIFY_RUN_DEPENDS= notify-send:devel/libnotify
-NOTIFY_CONFIGURE_ENABLE= libnotify
+NOTIFY_CONFIGURE_ENABLE=libnotify
PERL_CONFIGURE_ENABLE= perl
-PYTHON_CONFIGURE_ENABLE= python
+PERL_USES= perl5
+PYTHON_CONFIGURE_ENABLE=python
+PYTHON_USES= python
SOCKS_LIB_DEPENDS= libsocks.so:net/dante
SOCKS_CONFIGURE_ENABLE= socks
-TEXTFE_CONFIGURE_ENABLE= textfe
+TEXTFE_CONFIGURE_ENABLE=textfe
.include <bsd.port.options.mk>
@@ -73,28 +84,16 @@ CA_BUNDLE= "${LOCALBASE}/share/certs/ca-root-nss.crt"
CA_BUNDLE= NULL
.endif
-.if ${PORT_OPTIONS:MPYTHON}
-USES+= python
-.endif
-
-.if ${PORT_OPTIONS:MPERL}
-USES+= perl5
-.endif
-
-.if ${PORT_OPTIONS:MDBUS}
-USE_GNOME+= gconf2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%CA_BUNDLE%%|${CA_BUNDLE}|' \
${WRKSRC}/src/common/server.c
post-install:
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${LN} -sf ../share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.md ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/irc/hexchat/distinfo b/irc/hexchat/distinfo
index 4ed169e7111..abd75fcb158 100644
--- a/irc/hexchat/distinfo
+++ b/irc/hexchat/distinfo
@@ -1,2 +1,3 @@
-SHA256 (hexchat-2.10.2.tar.xz) = 87ebf365c576656fa3f23f51d319b3a6d279e4a932f2f8961d891dd5a5e1b52c
-SIZE (hexchat-2.10.2.tar.xz) = 1529732
+TIMESTAMP = 1468413582
+SHA256 (hexchat-2.12.1.tar.xz) = 5201b0c6d17dcb8c2cb79e9c39681f8e052999ba8f7b5986d5c1e7dc68fa7c6b
+SIZE (hexchat-2.12.1.tar.xz) = 1585532