aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2011-07-30 09:34:47 +0800
committersahil <sahil@FreeBSD.org>2011-07-30 09:34:47 +0800
commitb804b6a91bcb4b08086cce12203e55f2adbaacdb (patch)
treeb37e696ec4c53d133bfe4f22eba062fb77368522
parent909916d70021c6a6548c45861ad3b4a139d8fc18 (diff)
downloadfreebsd-ports-graphics-b804b6a91bcb4b08086cce12203e55f2adbaacdb.tar.gz
freebsd-ports-graphics-b804b6a91bcb4b08086cce12203e55f2adbaacdb.tar.zst
freebsd-ports-graphics-b804b6a91bcb4b08086cce12203e55f2adbaacdb.zip
- Update to 2.9-20110706
- Use ports framework to create USERS and GROUPS - Remove unused replace() function from pkg-install
-rw-r--r--mail/postfix-current/Makefile7
-rw-r--r--mail/postfix-current/distinfo4
-rw-r--r--mail/postfix-current/files/pkg-install.in74
3 files changed, 6 insertions, 79 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 6bd1d506b67..756e1636924 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-DISTVERSION= 2.9-20110615
+DISTVERSION= 2.9-20110706
PORTEPOCH= 4
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/ \
@@ -29,6 +29,8 @@ CONFLICTS= courier-0.* postfix-1.* postfix-2.* postfix-base-2.* \
IS_INTERACTIVE= yes
.endif
+USERS= postfix
+GROUPS= mail maildrop postfix
MAKE_JOBS_SAFE= yes
USE_SUBMAKE= yes
USE_PERL5_BUILD=yes
@@ -321,9 +323,6 @@ do-configure:
CCARGS="${POSTFIX_CCARGS}" AUXLIBS="${POSTFIX_AUXLIBS}" && \
${ECHO} "all: default" >> Makefile)
-pre-su-install:
- @${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
do-install:
@cd ${WRKSRC} && ${SH} postfix-install -non-interactive install_root=/ tempdir=/tmp \
config_directory=${ETCDIR} \
diff --git a/mail/postfix-current/distinfo b/mail/postfix-current/distinfo
index 760ff2f9cab..3e9b893ebbb 100644
--- a/mail/postfix-current/distinfo
+++ b/mail/postfix-current/distinfo
@@ -1,2 +1,2 @@
-SHA256 (postfix/postfix-2.9-20110615.tar.gz) = 004adf5de5835990471bbe865a1a0818d2f319cc8c1c69817bd6e6eb52a1bc59
-SIZE (postfix/postfix-2.9-20110615.tar.gz) = 3672939
+SHA256 (postfix/postfix-2.9-20110706.tar.gz) = 5ccd159418ddd84f71f53713af77e08b8d85051603c0824f6474450525b6a66a
+SIZE (postfix/postfix-2.9-20110706.tar.gz) = 3674088
diff --git a/mail/postfix-current/files/pkg-install.in b/mail/postfix-current/files/pkg-install.in
index b85eb41930a..fe97be9f3cb 100644
--- a/mail/postfix-current/files/pkg-install.in
+++ b/mail/postfix-current/files/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix-current/files/pkg-install.in,v 1.2 2011-02-20 06:21:36 sahil Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix-current/files/pkg-install.in,v 1.3 2011-07-30 01:34:47 sahil Exp $
#
# If the POSTFIX_DEFAULT_MTA environment variable is set to YES, it
@@ -56,64 +56,6 @@ yesno() {
done
}
-if [ "$2" = "PRE-INSTALL" ]; then
- USER=postfix
- UID=125
- GROUP=postfix
- GID=125
- GROUP2=maildrop
- GID2=126
-
- if /usr/sbin/pw groupshow "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if /usr/sbin/pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw groupshow "${GROUP2}" 2>/dev/null; then
- echo "You already have a group \"${GROUP2}\", so I will use it."
- else
- if /usr/sbin/pw groupadd ${GROUP2} -g ${GID2}; then
- echo "Added group \"${GROUP2}\"."
- else
- echo "Adding group \"${GROUP2}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if /usr/sbin/pw useradd ${USER} -u ${UID} -g ${GROUP} -h - -d /var/spool/postfix -s ${NOLOGIN} -c "Postfix Mail System"; then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw show group mail | grep -q "${USER}" 2>/dev/null; then
- echo "You already have user \"${USER}\" in group \"mail\", so I will use it."
- else
- echo "You need user \"${USER}\" added to group \"mail\"."
- if yesno "Would you like me to add it" y; then
- /usr/sbin/pw groupmod mail -m ${USER} || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-fi
-
if [ "$2" = "POST-INSTALL" ]; then
SAMPLES="main.cf master.cf"
for file in $SAMPLES
@@ -130,20 +72,6 @@ if [ "$2" = "POST-INSTALL" ]; then
upgrade-package
fi
-replace() {
- local orig repl
-
- orig=$1
- repl=$2
- if [ -e ${orig} ]; then
- /bin/mv -f ${orig} ${orig}.OFF
- /bin/chmod 0 ${orig}.OFF
- fi
- if [ -e ${repl} ]; then
- /bin/ln -s ${repl} ${orig}
- fi
-}
-
if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" ]; then
egrep -q "^sendmail.*${PREFIX}/sbin/sendmail" ${MC} && \
egrep -q "^send-mail.*${PREFIX}/sbin/sendmail" ${MC} && \