aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-03-15 19:43:57 +0800
committerahze <ahze@FreeBSD.org>2006-03-15 19:43:57 +0800
commitb8975f5daf3b8d75912a66f83ab6f30663846fb7 (patch)
tree27d963ea2ce5d28f7038069f68ddcc08fc94b5dc
parent4698bebf6c09b2ad103563445abf36edc3e9476d (diff)
downloadfreebsd-ports-graphics-b8975f5daf3b8d75912a66f83ab6f30663846fb7.tar.gz
freebsd-ports-graphics-b8975f5daf3b8d75912a66f83ab6f30663846fb7.tar.zst
freebsd-ports-graphics-b8975f5daf3b8d75912a66f83ab6f30663846fb7.zip
- Add support for USE_GECKO=xulrunner
- Remove quotes around BROKEN - Remove USE_REINPLACE
-rw-r--r--www/mozilla/Makefile5
-rw-r--r--www/mozilla/Makefile.common2
-rw-r--r--www/mozilla/bsd.gecko.mk6
-rw-r--r--www/mozilla/pkg-deinstall.in2
-rw-r--r--www/mozilla/pkg-install.in2
5 files changed, 8 insertions, 9 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 3c11dadaf6b..adefce7f818 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -3,7 +3,7 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/Makefile,v 1.31 2005/11/24 01:43:42 ahze Exp $
+# $MCom: ports/www/mozilla/Makefile,v 1.36 2006/03/09 00:45:43 ahze Exp $
#
PORTNAME= mozilla
@@ -26,7 +26,6 @@ USE_GMAKE= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
WANT_GNOME= yes
-USE_REINPLACE= yes
HAS_CONFIGURE= yes
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin
ALL_TARGET= default
@@ -74,7 +73,7 @@ IGNORE= core dumps on ${ARCH} during post-build
.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
defined(WITHOUT_COMPOSER))
-BROKEN= "Calendar requires Composer and Mailnews support."
+BROKEN= Calendar requires Composer and Mailnews support.
.endif
.if defined(WITHOUT_MAILNEWS)
MOZ_OPTIONS+= --disable-ldap --disable-mailnews
diff --git a/www/mozilla/Makefile.common b/www/mozilla/Makefile.common
index 9d55c33c4c7..a6312ee6c7b 100644
--- a/www/mozilla/Makefile.common
+++ b/www/mozilla/Makefile.common
@@ -4,7 +4,7 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/Makefile.common,v 1.17 2005/11/29 08:40:08 ahze Exp $
+# $MCom: ports/www/mozilla/Makefile.common,v 1.20 2006/03/09 00:45:43 ahze Exp $
# This file contains some reusable components for mozilla ports. It's of
# use primarily to apps from the mozilla project itself (such as Firefox,
diff --git a/www/mozilla/bsd.gecko.mk b/www/mozilla/bsd.gecko.mk
index ffd3978785e..c07a21a5b40 100644
--- a/www/mozilla/bsd.gecko.mk
+++ b/www/mozilla/bsd.gecko.mk
@@ -2,7 +2,7 @@
# ex:ts=4
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/bsd.gecko.mk,v 1.9 2005/11/29 20:30:06 adamw Exp $
+# $MCom: ports/www/mozilla/bsd.gecko.mk,v 1.17 2006/03/10 12:42:50 ahze Exp $
#
# 4 column tabs prevent hair loss and tooth decay!
@@ -64,7 +64,7 @@ Gecko_Pre_Include= bsd.gecko.mk
# .endif
.if ${OSVERSION} >= 500000
-_GECKO_ALL= firefox nvu seamonkey sunbird thunderbird
+_GECKO_ALL= firefox nvu seamonkey sunbird thunderbird xulrunner
.endif
_GECKO_ALL+= mozilla
@@ -127,7 +127,7 @@ XPIDL_INCL?= `${GECKO_CONFIG} --idlflags`
BUILD_DEPENDS+= ${${GECKO}_PLIST}:${${GECKO}_DEPENDS}
RUN_DEPENDS+= ${${GECKO}_PLIST}:${${GECKO}_DEPENDS}
.else
-BROKEN="Unable to find a supported gecko, please check USE_GECKO"
+BROKEN=Unable to find a supported gecko, please check USE_GECKO
.endif
pre-everything:: _gecko-pre-everything
diff --git a/www/mozilla/pkg-deinstall.in b/www/mozilla/pkg-deinstall.in
index 7d0d70f5da0..8afb74b4514 100644
--- a/www/mozilla/pkg-deinstall.in
+++ b/www/mozilla/pkg-deinstall.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/pkg-deinstall.in,v 1.9 2005/11/13 19:07:58 ahze Exp $
+# $MCom: ports/www/mozilla/pkg-deinstall.in,v 1.12 2006/03/09 00:45:43 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
diff --git a/www/mozilla/pkg-install.in b/www/mozilla/pkg-install.in
index 057d80bf594..fbc57949a6d 100644
--- a/www/mozilla/pkg-install.in
+++ b/www/mozilla/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/pkg-install.in,v 1.9 2005/11/13 19:07:58 ahze Exp $
+# $MCom: ports/www/mozilla/pkg-install.in,v 1.12 2006/03/09 00:45:43 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)