aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-05-18 19:59:35 +0800
committerkris <kris@FreeBSD.org>2003-05-18 19:59:35 +0800
commitb9427b6005b396d7c7f06794991a96c37639ef38 (patch)
treeae3b342ddbbf02e94f8276c078aaf5f4b14b8d08
parent085b9e13204c8e72a20b99a869b56959ca6e5acf (diff)
downloadfreebsd-ports-graphics-b9427b6005b396d7c7f06794991a96c37639ef38.tar.gz
freebsd-ports-graphics-b9427b6005b396d7c7f06794991a96c37639ef38.tar.zst
freebsd-ports-graphics-b9427b6005b396d7c7f06794991a96c37639ef38.zip
BROKEN on 5.1: bad C++
-rw-r--r--math/surf/Makefile8
-rw-r--r--x11-wm/clementine/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/math/surf/Makefile b/math/surf/Makefile
index fa90edb12bd..94e623af938 100644
--- a/math/surf/Makefile
+++ b/math/surf/Makefile
@@ -19,6 +19,12 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
gmp.6:${PORTSDIR}/math/libgmp4
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_GNOME= gtk12
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -26,4 +32,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= surf.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/clementine/Makefile b/x11-wm/clementine/Makefile
index 8ffc370056e..49d262a55d4 100644
--- a/x11-wm/clementine/Makefile
+++ b/x11-wm/clementine/Makefile
@@ -17,6 +17,12 @@ COMMENT= Has title bars, iconizing, and styles (unstable)
RUN_DEPENDS= xv:${PORTSDIR}/graphics/xv \
rxvt:${PORTSDIR}/x11/rxvt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
PLIST= ${WRKDIR}/pkg-plist
PKGMESSAGE= ${WRKDIR}/pkg-message
USE_GMAKE= yes
@@ -63,4 +69,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>