aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-04 04:54:30 +0800
committerpav <pav@FreeBSD.org>2006-04-04 04:54:30 +0800
commitba0f772db99dafbed493f30e81056bfd15e35b90 (patch)
tree9e15088673ffab162663dfbbed08f2ac4acc6308
parentcd89b4c80eb0c8d46076a69e8cb56a4b472e98bb (diff)
downloadfreebsd-ports-graphics-ba0f772db99dafbed493f30e81056bfd15e35b90.tar.gz
freebsd-ports-graphics-ba0f772db99dafbed493f30e81056bfd15e35b90.tar.zst
freebsd-ports-graphics-ba0f772db99dafbed493f30e81056bfd15e35b90.zip
- Mark broken on 4.X
Reported by: krismail
-rw-r--r--net-mgmt/flowd/Makefile8
-rw-r--r--net-mgmt/pads/Makefile8
-rw-r--r--polish/ekg2/Makefile8
-rw-r--r--www/clearsilver/Makefile4
4 files changed, 25 insertions, 3 deletions
diff --git a/net-mgmt/flowd/Makefile b/net-mgmt/flowd/Makefile
index fc43d48a0c5..b2dec1f1609 100644
--- a/net-mgmt/flowd/Makefile
+++ b/net-mgmt/flowd/Makefile
@@ -37,6 +37,12 @@ PLIST_SUB+= WITH_PYTHON=""
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile
+.endif
+
pre-extract:
@${ECHO_MSG} ""
.if defined(WITH_PERL)
@@ -76,4 +82,4 @@ post-install:
FLOWD_USER=${FLOWD_USER} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/pads/Makefile b/net-mgmt/pads/Makefile
index fee64deb05f..c9fb763d0ab 100644
--- a/net-mgmt/pads/Makefile
+++ b/net-mgmt/pads/Makefile
@@ -20,4 +20,10 @@ GNU_CONFIGURE= yes
MAN8= pads.8 pads-report.8 pads.conf.8
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/polish/ekg2/Makefile b/polish/ekg2/Makefile
index 43b2d539627..96dfa2f5004 100644
--- a/polish/ekg2/Makefile
+++ b/polish/ekg2/Makefile
@@ -45,4 +45,10 @@ MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/clearsilver/Makefile b/www/clearsilver/Makefile
index 33597363acc..8004eb50b32 100644
--- a/www/clearsilver/Makefile
+++ b/www/clearsilver/Makefile
@@ -66,6 +66,10 @@ MAN3= cBroadcast.3 cCreate.3 cDestroy.3 cSignal.3 cWait.3 \
BROKEN= Does not compile completely on sparc64
.endif
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile
+.endif
+
post-patch:
@# Remove CFLAGS when building the python module, pydistfile is used
@# and will do the right thing.