aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-01-07 19:28:09 +0800
committererwin <erwin@FreeBSD.org>2006-01-07 19:28:09 +0800
commitbce8272309907f5e1a3271414e8c8eca4fb09d2d (patch)
tree77b63eeb571892c932313e0cc7f5b2f322cec4a2
parentf7b24bd6ef2ed52a00cade0099d12ca36a174661 (diff)
downloadfreebsd-ports-graphics-bce8272309907f5e1a3271414e8c8eca4fb09d2d.tar.gz
freebsd-ports-graphics-bce8272309907f5e1a3271414e8c8eca4fb09d2d.tar.zst
freebsd-ports-graphics-bce8272309907f5e1a3271414e8c8eca4fb09d2d.zip
Unbreak for old perl
PR: 91440 Submitted by: leeym
-rw-r--r--www/p5-HTML-TableExtract/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/p5-HTML-TableExtract/Makefile b/www/p5-HTML-TableExtract/Makefile
index 4138374340c..0f79d2c9ae4 100644
--- a/www/p5-HTML-TableExtract/Makefile
+++ b/www/p5-HTML-TableExtract/Makefile
@@ -15,8 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@FreeBSD.org
COMMENT= Extract text contained in tables within an HTML document
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
@@ -25,7 +26,11 @@ MAN3= HTML::TableExtract.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+post-configure:
+ ${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/lib/HTML/TableExtract.pm
+ ${PERL} -pi -e 's/exists/defined/ if m{return 1}' ${WRKSRC}/lib/HTML/TableExtract.pm
+ ${PERL} -pi -e "s/'<',/'<'./" ${WRKSRC}/t/30_tree.t
+ ${PERL} -pi -e 's/-I\S+PERL\S+ //g if m{PERL_DL_NONLAZY}' ${WRKSRC}/${MAKEFILE}
.endif
.include <bsd.port.post.mk>