aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2012-03-23 04:18:00 +0800
committerskv <skv@FreeBSD.org>2012-03-23 04:18:00 +0800
commitbd3fc37ce1f2bbdb1d4ebf2a52097cdcbd3a77be (patch)
tree921152de70914e724b9c3127d707c03772434d8b
parentf6e66cc0a97aa1f2372d2c9f12c0768e6c17e5bc (diff)
downloadfreebsd-ports-graphics-bd3fc37ce1f2bbdb1d4ebf2a52097cdcbd3a77be.tar.gz
freebsd-ports-graphics-bd3fc37ce1f2bbdb1d4ebf2a52097cdcbd3a77be.tar.zst
freebsd-ports-graphics-bd3fc37ce1f2bbdb1d4ebf2a52097cdcbd3a77be.zip
- Add missing *_DEPENDS [1]
- pass maintainership to perl@ PR: ports/165688 [1] Submitted by: swills Feature safe: yes
-rw-r--r--mail/p5-POE-Component-SMTP/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/mail/p5-POE-Component-SMTP/Makefile b/mail/p5-POE-Component-SMTP/Makefile
index 1cbb4068ad1..f2cf7891e66 100644
--- a/mail/p5-POE-Component-SMTP/Makefile
+++ b/mail/p5-POE-Component-SMTP/Makefile
@@ -7,20 +7,27 @@
PORTNAME= POE-Component-SMTP
PORTVERSION= 1.6
+PORTREVISION= 1
CATEGORIES= mail devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= SMTP Protocol Implementation
-RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/POE/Session/MultiDispatch.pm:${PORTSDIR}/devel/p5-POE-Session-MultiDispatch
-BUILD_DEPENDS= ${RUN_DEPENDS} \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Session-MultiDispatch>=0:${PORTSDIR}/devel/p5-POE-Session-MultiDispatch \
+ p5-Mail-Tools>=0:${PORTSDIR}/mail/p5-Mail-Tools
+RUN_DEPENS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= POE::Component::Server::SMTP.3 POE::Filter::SMTP.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>