aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2008-05-02 05:04:57 +0800
committerhq <hq@FreeBSD.org>2008-05-02 05:04:57 +0800
commitbe1bbcac30f61ffc5e57f50aa5dd63d16ac5fbf8 (patch)
tree40a8d5f612bb3bc7f579586d2cdf8f74c6845631
parent07c9ba3e7a2f6788731467fff7805fb8741eb6e2 (diff)
downloadfreebsd-ports-graphics-be1bbcac30f61ffc5e57f50aa5dd63d16ac5fbf8.tar.gz
freebsd-ports-graphics-be1bbcac30f61ffc5e57f50aa5dd63d16ac5fbf8.tar.zst
freebsd-ports-graphics-be1bbcac30f61ffc5e57f50aa5dd63d16ac5fbf8.zip
Colt is a package for scalable scientific and technical computing in Java. It
consists of several free Java libraries, for user convenience bundled under one single uniform umbrella. Namely the Colt library, the Jet library, the CoreJava library, and the Concurrent library. The Colt library provides fundamental general-purpose data structures optimized for numerical data, such as resizable arrays, dense and sparse matrices (multi-dimensional arrays), linear algebra, associative containers and buffer management. WWW: http://dsd.lbl.gov/~hoschek/colt/ PR: 122913 Submitted by: Wen heping <wenheping@gmail.com>
-rw-r--r--science/Makefile1
-rw-r--r--science/colt/Makefile56
-rw-r--r--science/colt/distinfo3
-rw-r--r--science/colt/pkg-descr11
4 files changed, 71 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index ebe08e4306c..66fe71d6530 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -20,6 +20,7 @@
SUBDIR += chemtool
SUBDIR += chemtool-devel
SUBDIR += clhep
+ SUBDIR += colt
SUBDIR += crf++
SUBDIR += dcl
SUBDIR += devisor
diff --git a/science/colt/Makefile b/science/colt/Makefile
new file mode 100644
index 00000000000..c20595d2839
--- /dev/null
+++ b/science/colt/Makefile
@@ -0,0 +1,56 @@
+# Ports collection makefile for: colt
+# Date created: April 19, 2008
+# Whom: Wen heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= colt
+PORTVERSION= 1.2.0
+CATEGORIES= science java
+MASTER_SITES= http://dsd.lbl.gov/~hoschek/colt-download/releases/
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Java package for scalable scientific and technical computing
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.if !defined(WITHOUT_COMPILE)
+USE_ANT= yes
+ALL_TARGET= build
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= javadoc
+.endif
+.else
+NO_BUILD= yes
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+PLIST_FILES= %%JAVAJARDIR%%/colt.jar
+
+.include <bsd.port.pre.mk>
+
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_COMPILE=yes Install the pre-compiled .jar file"
+ @${ECHO_MSG} ""
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @cd ${WRKSRC}/doc && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
+ @cd ${WRKSRC}/doc && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} " [DONE]"
+.endif
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/colt.jar ${JAVAJARDIR}
+
+.include <bsd.port.post.mk>
diff --git a/science/colt/distinfo b/science/colt/distinfo
new file mode 100644
index 00000000000..95abb993129
--- /dev/null
+++ b/science/colt/distinfo
@@ -0,0 +1,3 @@
+MD5 (colt-1.2.0.tar.gz) = 9a64a845a09338709589f6ef00b06fad
+SHA256 (colt-1.2.0.tar.gz) = da26942314a4ab7ab6dc449460970b4ada464b6594f69cba1b88268effbdddbb
+SIZE (colt-1.2.0.tar.gz) = 2545695
diff --git a/science/colt/pkg-descr b/science/colt/pkg-descr
new file mode 100644
index 00000000000..4d49eef3228
--- /dev/null
+++ b/science/colt/pkg-descr
@@ -0,0 +1,11 @@
+Colt is a package for scalable scientific and technical computing in Java. It
+consists of several free Java libraries, for user convenience bundled under one
+single uniform umbrella. Namely the Colt library, the Jet library, the CoreJava
+library, and the Concurrent library.
+
+The Colt library provides fundamental general-purpose data structures optimized
+for numerical data, such as resizable arrays, dense and sparse matrices
+(multi-dimensional arrays), linear algebra, associative containers and buffer
+management.
+
+WWW: http://dsd.lbl.gov/~hoschek/colt/
/td>Rodrigo Moya2001-06-135-1/+211 * Committing the new My Evolution.Iain Holmes2001-06-094-21/+16 * Sync from laptop.JP Rosevear2001-06-073-0/+735 * update the blocked/selected days if the starting day of the appointmentJP Rosevear2001-06-053-1/+23 * Fix linking order for `$(DB3_LDADD)'s so that we avoid pullingEttore Perazzoli2001-06-034-5/+14 * no longer build widget-util.*, the code has been movedJP Rosevear2001-06-022-4/+8 * use new funcJP Rosevear2001-06-029-97/+50 * ShushJP Rosevear2001-06-021-1/+0 * UpdateJP Rosevear2001-06-024-468/+8 * oops, didn't mean to make that changeJP Rosevear2001-06-021-1/+2 * renamed from editor-page for consistency, more complete implementationJP Rosevear2001-06-0236-7753/+3562 * dittoJP Rosevear2001-06-023-1/+13 * Add a bunch of missing `$(DB3_LDADD)'s.Ettore Perazzoli2001-06-022-1/+6 * For JPR - FedericoFederico Mena Quintero2001-05-312-0/+256 * New function.Federico Mena Quintero2001-05-305-38/+90 * new files to contain layout code split off from EDayView an EWeekView, soDamon Chaplin2001-05-2917-1168/+2526 * implemented the 'remove_folder' function for the calendar shell componentRodrigo Moya2001-05-283-5/+355 * #include "evolution-shell-component-utils.h" rather than "e-gui-utils.h"Dan Winship2001-05-283-2/+10 * Reference libeshell.la instead of libeshell.a.Peter Williams2001-05-262-1/+5 * Finished porting from the old event-editor.c. Made it store a clone of theFederico Mena Quintero2001-05-248-29/+1229 * Fix bug #2831; the tasks toolbar and menu now have a button to delete theFederico Mena Quintero2001-05-226-59/+213 * Fix bug #2829.Federico Mena Quintero2001-05-196-141/+303 * Removed editor-page.[ch]Duncan Mak2001-05-171-0/+5 * *** empty log message ***Duncan Mak2001-05-171-2/+0 * Split the event and task editors into different objects for the separateFederico Mena Quintero2001-05-1721-638/+5239 * switch on the correct widget and mapJP Rosevear2001-05-102-1/+17 * free the alarm component if it doesn't have a parent, rather than if itJP Rosevear2001-05-093-5/+15 * unref the property bag when we finish with itJP Rosevear2001-05-094-2/+6 * Convert to bonobo xobjectJP Rosevear2001-05-085-495/+224 * use define from widgets/misc/e-filter-bar.h instead of own enumeration andGediminas Paulauskas2001-05-084-60/+59 * unref the calcomponent when we're done with itJP Rosevear2001-05-043-8/+22 * remove hardcoded values (edit_attendee): ditto, and there are only 4 rolesJP Rosevear2001-04-284-27/+38 * use enums not hard code valuesJP Rosevear2001-04-273-2/+6 * icalparameter_new_rsvp now takes an enumJP Rosevear2001-04-272-1/+6 * the value type should be inited with ICAL_VALUE_* rather than ICAL_*_VALUEJP Rosevear2001-04-272-3/+9 * Replace "<" by "<=" in the comparison for due dates against the currentFederico Mena Quintero2001-04-273-3/+17 * Merge build fix from the branch:Ettore Perazzoli2001-04-272-0/+5 * Remove UNICODE_LIBSDan Winship2001-04-273-2/+7 * Fixed Strftime so it uses the locale prefered way to display date/time.Duncan Mak2001-04-252-1/+7 * translate "Things to do" etc. and convert them to utf8. Changed some linkGediminas Paulauskas2001-04-222-13/+24 * Hot builddir != srcdir loving action.Ettore Perazzoli2001-04-194-1/+15 * Connect to the "changed" signal of the categories entry so that they willFederico Mena Quintero2001-04-184-9/+53 * the libical action stuff uses enums rather than strings to enumerate theJP Rosevear2001-04-182-15/+36 * Pull up fix from the branch:Ettore Perazzoli2001-04-182-0/+7 * Add EXTRA_GNOME_CFLAGS, for gal.Dan Winship2001-04-172-0/+5 * Create the ESearchBar thingy. (search_bar_query_changed_cb): Build theFederico Mena Quintero2001-04-165-18/+482 * Do this everywhere, also fixup CLEANFILESMichael Meeks2001-04-143-0/+10 * Fix the syntactic bogon here, and attempt to fix the logical bogon too.Dan Winship2001-04-142-2/+10 * New function to restart a query for the day view. (query_obj_updated_cb):Federico Mena Quintero2001-04-1311-284/+662 * prepend to both changes and change_ids when different and mark asJP Rosevear2001-04-122-2/+8 * Fix this to just send the data to the wombat instead of inserting itChristopher James Lahey2001-04-112-44/+26 * Display fixes, thanks to Kjartan for finding these.Gediminas Paulauskas2001-04-113-21/+26 * Here goes my additional simple include fixes.Gediminas Paulauskas2001-04-057-48/+46 * Fix headers. Same here. Same here. Same here. Same here. Same here. SameKjartan Maraas2001-04-0515-0/+78 * Plug leak.Federico Mena Quintero2001-04-0313-25/+942 * Plug leak.Federico Mena Quintero2001-04-032-61/+81 * Blessed by Ettore.Gediminas Paulauskas2001-04-023-39/+41 * Engine for live queries to calendars. A query object watches a CalBackendFederico Mena Quintero2001-03-3011-15/+1173 * A mockup of how meeting scheduling and editting should work. This design is b...Anna Dirks2001-03-291-0/+488 * fixed button placement to comply with gnome standards.Anna Marie Dirks2001-03-282-6/+11 * fixed spacing and label alignment to comply with gnome standards. AlsoAnna Marie Dirks2001-03-282-129/+105 * Replace includes of <gnome.h>, <bonobo.h> and <gtk/gtk.h> with the neededKjartan Maraas2001-03-2624-32/+90 * The model_rows_{inserted,deleted} signals changed names; deal with it.Federico Mena Quintero2001-03-258-58/+73 * Added ShowWeekView, ShowMonthView, ShowDay, ShowWorkWeek to the View menu.Miguel de Icaza2001-03-186-95/+97 * Moved functionality here from e_day_view_on_new_appointment. AllowsMiguel de Icaza2001-03-175-17/+139 * New function: inits the BonoboPersistFile server.Miguel de Icaza2001-03-173-1/+46 * Update arguments to e_canvas_item_grab_focus.Dan Winship2001-03-163-2/+8 * Removed .oafinfo files -- they are obsolete. Moved pixmaps fromGediminas Paulauskas2001-03-1513-309/+18 * create doc/devel/executive-summary/MakefileGediminas Paulauskas2001-03-152-0/+15 * PISOCK_INCLUDEDIR has become PISOCK_CFLAGS in gnome-pilot.m4 and removeJP Rosevear2001-03-138-758/+12 * Added a ShellComponent method to retrieve the selection for drag andEttore Perazzoli2001-03-084-9/+16 * Reorganize the menus to have entries always in a consistent fashion, asMiguel de Icaza2001-03-071-0/+19 * keep list of all Tasks folders so we can update the preference settingsDamon Chaplin2001-03-0519-386/+715 * install conduit iconsJP Rosevear2001-03-035-14/+30 * When when when when when when oh WHEN will I remember to add the files - Fede...Federico Mena Quintero2001-03-021-0/+180 * New function to set the EDateEdit's value when a row is selected in theFederico Mena Quintero2001-03-014-13/+74 * Create a little stand-alone library for the low-level alarm triggerFederico Mena Quintero2001-02-277-413/+31 * Switched to using our own refcounted structure for loaded clients.Federico Mena Quintero2001-02-2415-242/+187 * fixed generation of history recordsRodrigo Moya2001-02-242-2/+42 * IMAP subscriptions stuff.Aaron Weber2001-02-231-0/+1 * Added a `registered' field. (cal_factory_oaf_register): New function; nowFederico Mena Quintero2001-02-216-5/+149 * Oops, forgotten bits from last commitJP Rosevear2001-02-202-2/+2 * Remove PISOCK_LIBDIRJP Rosevear2001-02-203-2/+8 * close DB environment. Some compilation warnings removedRodrigo Moya2001-02-172-14/+33 * Ignore generated .oaf filesDan Winship2001-02-151-1/+4 * Added libmenus.la.Christopher James Lahey2001-02-147-9/+82 * call task_editor_focusJP Rosevear2001-02-142-1/+6 * Set toolbar new appointment icon (set_pixmap): load files rather thanJP Rosevear2001-02-147-222/+45 * implementedRodrigo Moya2001-02-142-38/+78 * Missing change log bitJP Rosevear2001-02-141-0/+2 * override value to string virtual method (calendar_model_value_to_string):JP Rosevear2001-02-143-6/+53 * cal_backend_db_update_object(): manage both updates and additions/addRodrigo Moya2001-02-132-194/+496 * Hook up the xml-i18n-tools + .oaf.in stuff. Marked strings forKjartan Maraas2001-02-135-13/+25 * added DB3 transactions supportRodrigo Moya2001-02-131-29/+145 * added the new DB3-based backend. This is just the beginning, there areRodrigo Moya2001-02-134-0/+1058 * Getting almost full and proper use of xml-i18n-tools.Gediminas Paulauskas2001-02-1128-351/+45 * Oops, remove old widgetJP Rosevear2001-02-094-80/+8 * fill in new classification stuff properly (get_widgets): load new class.JP Rosevear2001-02-099-1603/+1711 * Move the get_change code hereJP Rosevear2001-02-094-149/+191 * More 0.9 stuffJP Rosevear2001-02-092-0/+35 * Pull up from 0.9 branchJP Rosevear2001-02-0910-1380/+1214 * Fix the title and icon bug, and sort the UIDs into order beforeIain Holmes2001-02-082-1/+144 * Pulling stuff up from the branchJP Rosevear2001-02-079-36/+67 * If the categories string is empty, remove the property (get_period_list):JP Rosevear2001-02-072-11/+19 * Oops, that shouldn't have gone inJP Rosevear2001-02-072-11/+0 * Match new append_alarm signature (reminder_to_comp_object): only addJP Rosevear2001-02-074-22/+61 * Set the time and duration values in the trigger to null by defaultJP Rosevear2001-02-062-1/+10 * get the new reminder widgets (sync_entries): different callback dataJP Rosevear2001-02-0611-675/+776 * Fixed up these #includes.Christopher James Lahey2001-02-062-1/+7 * gnome_dialog_grab_focus() on the Yes button. Fixes bug #1242.Federico Mena Quintero2001-02-042-3/+10 * Mark a string for translation. Mark a bunch of strings for translation.Kjartan Maraas2001-01-303-20/+26 * Add a #include <sys/time.h> to work around libgnomeprint.h's lack ofEttore Perazzoli2001-01-302-0/+5 * <gnome.h> trimming to reduce compilation time. Likewise. Likewise.Federico Mena Quintero2001-01-3022-24/+38 * Added Slovak messagesStano Visnovsky2001-01-303-0/+6 * <gnome.h> trimming to reduce compilation time. Ditto. Ditto. Ditto. Ditto.Federico Mena Quintero2001-01-299-9/+32 * Fixed a crash that could happen when destroying a control without anyEttore Perazzoli2001-01-272-2/+9 * don't tag the calendar if no dates are shown.Damon Chaplin2001-01-252-6/+19 * make sure the status is set to "Completed". Fixes bug #1253.Damon Chaplin2001-01-243-10/+35 * libical import cleanupJP Rosevear2001-01-2412-48/+52 * properly ref the cal component when we use it, prevents double freeJP Rosevear2001-01-233-1/+10 * compile new stuffJP Rosevear2001-01-236-22/+105 * remove duplicate messageJP Rosevear2001-01-235-26/+30 * Remove alarm foo for nowJP Rosevear2001-01-233-27/+14 * Updated sl translationsAndraz Tori2001-01-221-0/+2 * Fix bug #1250; now we present a confirmation dialog before deleting theFederico Mena Quintero2001-01-222-7/+16 * Fix bug #1243. Turn on the Y expand/fill options for the date widgets inFederico Mena Quintero2001-01-213-29/+37 * Unset the GTK_CAN_FOCUS flag on the weekday picker. This will do until itFederico Mena Quintero2001-01-202-0/+8 * create a new cal component alarm (cal_component_add_alarm): add alarm toJP Rosevear2001-01-194-41/+191 * New files with a simple sequence to migrate the task components from theFederico Mena Quintero2001-01-1914-1426/+414 * gui/e-week-view*.c don't use the theme colors at all within the graphicalDamon Chaplin2001-01-1811-97/+324 * Check for open error and handledJP Rosevear2001-01-173-2/+14 * Fix transposition of sync db locationJP Rosevear2001-01-172-1/+6 * Ximianified email addresses and copyrights.Federico Mena Quintero2001-01-17