aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkiri <kiri@FreeBSD.org>2003-05-08 19:00:15 +0800
committerkiri <kiri@FreeBSD.org>2003-05-08 19:00:15 +0800
commitc02e408ab212bb818b4a6d4c34feb06f89dfca18 (patch)
tree32f348f7f9b52e1472a679e4e6c9bb92faa0baab
parent262d0a2f95068109fea6f021fb97cb489c111fff (diff)
downloadfreebsd-ports-graphics-c02e408ab212bb818b4a6d4c34feb06f89dfca18.tar.gz
freebsd-ports-graphics-c02e408ab212bb818b4a6d4c34feb06f89dfca18.tar.zst
freebsd-ports-graphics-c02e408ab212bb818b4a6d4c34feb06f89dfca18.zip
Change in-place replacement.
-rw-r--r--archivers/deepforest/Makefile1
-rw-r--r--archivers/deepforest/scripts/post-install2
-rw-r--r--editors/muggy/Makefile1
-rw-r--r--editors/muggy/scripts/post-install4
-rw-r--r--graphics/jgv/Makefile1
-rw-r--r--graphics/jgv/scripts/post-install4
-rw-r--r--x11-fm/binder/Makefile1
-rw-r--r--x11-fm/binder/scripts/post-install4
8 files changed, 11 insertions, 7 deletions
diff --git a/archivers/deepforest/Makefile b/archivers/deepforest/Makefile
index 3712d3a2867..3b28bacfdc4 100644
--- a/archivers/deepforest/Makefile
+++ b/archivers/deepforest/Makefile
@@ -24,6 +24,7 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
+REINPLACE_ARGS=
SCRIPTS_ENV= LANG=C LN=${LN} REINPLACE_CMD="${REINPLACE_CMD}" \
LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
PLIST_SUB= PIXMAP_PATH=${PIXMAPPATH:S@^${PREFIX}/@@}
diff --git a/archivers/deepforest/scripts/post-install b/archivers/deepforest/scripts/post-install
index 06d9aad764c..59f8e034e28 100644
--- a/archivers/deepforest/scripts/post-install
+++ b/archivers/deepforest/scripts/post-install
@@ -3,7 +3,7 @@
case ${LANGUAGE} in
Japanese)
for f in DeepForest.app; do
- ${REINPLACE_CMD} -E -e \
+ ${REINPLACE_CMD} -i "" -E -e \
"s/^(exec[[:space:]]+)wishstep[^[:space:]]*([[:space:]]+.*)\$/\1wishstep${VERSION}jp\2/" \
${PREFIX}/JDE/DeepForest/${f}
done
diff --git a/editors/muggy/Makefile b/editors/muggy/Makefile
index 44538603b8a..26071c16d2f 100644
--- a/editors/muggy/Makefile
+++ b/editors/muggy/Makefile
@@ -24,6 +24,7 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
+REINPLACE_ARGS=
SCRIPTS_ENV= LANG=C LN=${LN} REINPLACE_CMD="${REINPLACE_CMD}" \
LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
PLIST_SUB= PIXMAP_PATH=${PIXMAPPATH:S@^${PREFIX}/@@}
diff --git a/editors/muggy/scripts/post-install b/editors/muggy/scripts/post-install
index c87e77330fe..36eaa3043a4 100644
--- a/editors/muggy/scripts/post-install
+++ b/editors/muggy/scripts/post-install
@@ -5,7 +5,7 @@ installdir=${PREFIX}/JDE/Muggy; export installdir
case ${LANGUAGE} in
Japanese)
for f in Muggy.app; do
- ${REINPLACE_CMD} -E -e \
+ ${REINPLACE_CMD} -i "" -E -e \
"s/^(exec[[:space:]]+)wishstep[[:space:]]*([[:space:]]+.*)\$/\1wishstep${VERSION}jp\2/" \
${installdir}/bin/${f}
done
@@ -22,7 +22,7 @@ for f in Muggy Muggy.app; do
target=${installdir}/defaults/${f}
;;
esac
- ${REINPLACE_CMD} -E -e \
+ ${REINPLACE_CMD} -i "" -E -e \
"s@^([[:space:]]*set[[:space:]]+Jlib[[:space:]]+)\"[^\"]*\"\$@\1\"${installdir}/\"@" \
${target}
done
diff --git a/graphics/jgv/Makefile b/graphics/jgv/Makefile
index 655d3ad051b..e54d43973bb 100644
--- a/graphics/jgv/Makefile
+++ b/graphics/jgv/Makefile
@@ -24,6 +24,7 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
+REINPLACE_ARGS=
SCRIPTS_ENV= LANG=C LN=${LN} REINPLACE_CMD="${REINPLACE_CMD}" \
LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
PLIST_SUB= PIXMAP_PATH=${PIXMAPPATH:S@^${PREFIX}/@@}
diff --git a/graphics/jgv/scripts/post-install b/graphics/jgv/scripts/post-install
index 6440c565766..7d7d37fe2ca 100644
--- a/graphics/jgv/scripts/post-install
+++ b/graphics/jgv/scripts/post-install
@@ -5,7 +5,7 @@ installdir=${PREFIX}/JDE/JGV; export installdir
case ${LANGUAGE} in
Japanese)
for f in JGV.app; do
- ${REINPLACE_CMD} -E -e \
+ ${REINPLACE_CMD} -i "" -E -e \
"s/^(exec[[:space:]]+)wishstep[[:space:]]*([[:space:]]+.*)\$/\1wishstep${VERSION}jp\2/" \
${installdir}/bin/${f}
done
@@ -22,7 +22,7 @@ for f in JGV JGV.app; do
target=${installdir}/defaults/${f}
;;
esac
- ${REINPLACE_CMD} -E -e \
+ ${REINPLACE_CMD} -i "" -E -e \
"s@^([[:space:]]*set[[:space:]]+Jlib[[:space:]]+)\"[^\"]*\"\$@\1\"${installdir}/\"@" \
${target}
done
diff --git a/x11-fm/binder/Makefile b/x11-fm/binder/Makefile
index bfa606a19cd..d8dfef4a7f6 100644
--- a/x11-fm/binder/Makefile
+++ b/x11-fm/binder/Makefile
@@ -24,6 +24,7 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
+REINPLACE_ARGS=
SCRIPTS_ENV= LANG=C LN=${LN} REINPLACE_CMD="${REINPLACE_CMD}" \
LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
PLIST_SUB= PIXMAP_PATH=${PIXMAPPATH:S@^${PREFIX}/@@}
diff --git a/x11-fm/binder/scripts/post-install b/x11-fm/binder/scripts/post-install
index a746119ec11..86752cc9a17 100644
--- a/x11-fm/binder/scripts/post-install
+++ b/x11-fm/binder/scripts/post-install
@@ -5,7 +5,7 @@ installdir=${PREFIX}/JDE/Binder; export installdir
case ${LANGUAGE} in
Japanese)
for f in bin/Binder.app bin/Processes.app misc/Mounter/Mounter.app; do
- ${REINPLACE_CMD} -E -e \
+ ${REINPLACE_CMD} -i "" -E -e \
"s/^(exec[[:space:]]+)wishstep[[:space:]]*([[:space:]]+.*)\$/\1wishstep${VERSION}jp\2/" \
${installdir}/${f}
done
@@ -28,7 +28,7 @@ for f in Binder Binder.app Processes.app Mounter.app shortcut; do
target=${installdir}/lib/${f}
;;
esac
- ${REINPLACE_CMD} -E \
+ ${REINPLACE_CMD} -i "" -E \
-e "s@^([[:space:]]*set[[:space:]]+ttblibPath[[:space:]]+)\"[^\"]*\"\$@\1\"${installdir}\"@" \
-e "s@^([[:space:]]*set[[:space:]]+ttblibPath[[:space:]]+)\{[^\}]*\}\$@\1\{${installdir}\}@" \
-e "s@^([a-zA-Z.]+;)/usr/local/([a-zA-Z/.]+;[a-zA-Z]+)\$@\1${PREFIX}/\2@" \