aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-08-21 21:04:39 +0800
committersem <sem@FreeBSD.org>2004-08-21 21:04:39 +0800
commitc1f7626cb41aab99da0132fab6d8d7576272c2ba (patch)
tree9b3bdddd26980222b07be2a8072f57020197c4cc
parente9d1d5074f2ee83ee87da83b0ae21d30a5dbcb07 (diff)
downloadfreebsd-ports-graphics-c1f7626cb41aab99da0132fab6d8d7576272c2ba.tar.gz
freebsd-ports-graphics-c1f7626cb41aab99da0132fab6d8d7576272c2ba.tar.zst
freebsd-ports-graphics-c1f7626cb41aab99da0132fab6d8d7576272c2ba.zip
The Config::Objective module provides a mechanism for parsing config files
to manipulate configuration data. PR: ports/62979 Submitted by: Jim Pirzyk <pirzyk@freebsd.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-Objective/Makefile36
-rw-r--r--devel/p5-Config-Objective/distinfo2
-rw-r--r--devel/p5-Config-Objective/pkg-descr8
-rw-r--r--devel/p5-Config-Objective/pkg-plist14
5 files changed, 61 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3282e511939..e070f59b89e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -659,6 +659,7 @@
SUBDIR += p5-Config-General
SUBDIR += p5-Config-Ini
SUBDIR += p5-Config-IniFiles
+ SUBDIR += p5-Config-Objective
SUBDIR += p5-Config-Setting
SUBDIR += p5-Config-Simple
SUBDIR += p5-Config-Tiny
diff --git a/devel/p5-Config-Objective/Makefile b/devel/p5-Config-Objective/Makefile
new file mode 100644
index 00000000000..4a3d379690a
--- /dev/null
+++ b/devel/p5-Config-Objective/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Config-Objective
+# Date created: Mon Feb 16 15:50:34 CST 2004
+# Whom: Jim Pirzyk <pirzyk@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-Objective
+PORTVERSION= 0.9.1
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pirzyk@freebsd.org
+COMMENT= Configuration data as perl objects
+
+BUILD_DEPENDS= ${SITE_PERL}/Parse/Yapp.pm:${PORTSDIR}/devel/p5-Parse-Yapp \
+ ${SITE_PERL}/Parse/Lex.pm:${PORTSDIR}/devel/p5-ParseLex
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Config::Objective::List.3 Config::Objective::Boolean.3 \
+ Config::Objective::Table.3 Config::Objective.3 \
+ Config::Objective::Hash.3 Config::Objective::Integer.3 \
+ Config::Objective::String.3 Config::Objective::DataType.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= This port requires perl 5.6 or newer
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Config-Objective/distinfo b/devel/p5-Config-Objective/distinfo
new file mode 100644
index 00000000000..55085df9c35
--- /dev/null
+++ b/devel/p5-Config-Objective/distinfo
@@ -0,0 +1,2 @@
+MD5 (Config-Objective-0.9.1.tar.gz) = 3d8542a3fc7deb1f7658ef599a929c4c
+SIZE (Config-Objective-0.9.1.tar.gz) = 17633
diff --git a/devel/p5-Config-Objective/pkg-descr b/devel/p5-Config-Objective/pkg-descr
new file mode 100644
index 00000000000..88147e05bb7
--- /dev/null
+++ b/devel/p5-Config-Objective/pkg-descr
@@ -0,0 +1,8 @@
+The Config::Objective module provides a mechanism for parsing config files
+to manipulate configuration data. Unlike most other config file modules,
+which represent config data as simple variables, Config::Objective
+represents config data as perl objects. This allows for a much more
+flexible configuration language, since new classes can be easily written
+to add methods to the config syntax.
+
+WWW: http://search.cpan.org/~roth/Config-Objective/
diff --git a/devel/p5-Config-Objective/pkg-plist b/devel/p5-Config-Objective/pkg-plist
new file mode 100644
index 00000000000..dc91e5e8580
--- /dev/null
+++ b/devel/p5-Config-Objective/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Config/Objective.pm
+%%SITE_PERL%%/Config/Objective/List.pm
+%%SITE_PERL%%/Config/Objective/Parser.pm
+%%SITE_PERL%%/Config/Objective/Boolean.pm
+%%SITE_PERL%%/Config/Objective/Table.pm
+%%SITE_PERL%%/Config/Objective/Hash.pm
+%%SITE_PERL%%/Config/Objective/Integer.pm
+%%SITE_PERL%%/Config/Objective/String.pm
+%%SITE_PERL%%/Config/Objective/DataType.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Objective/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Objective 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Config/Objective 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Config 2>/dev/null || true