aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-06-08 02:15:25 +0800
committerdanfe <danfe@FreeBSD.org>2005-06-08 02:15:25 +0800
commitc261097e3ba68f9c80299d80a8a264eec367b642 (patch)
treea111d1221c1d3680dff8d9226d1523b252a943f1
parente4fc7130ca83179eafcc6e2da7cad31dba3e4a14 (diff)
downloadfreebsd-ports-graphics-c261097e3ba68f9c80299d80a8a264eec367b642.tar.gz
freebsd-ports-graphics-c261097e3ba68f9c80299d80a8a264eec367b642.tar.zst
freebsd-ports-graphics-c261097e3ba68f9c80299d80a8a264eec367b642.zip
Add Dzip, file compression utility specializing in Quake demo compression.
WWW: http://speeddemosarchive.com/dzip/
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/dzip/Makefile38
-rw-r--r--archivers/dzip/distinfo2
-rw-r--r--archivers/dzip/pkg-descr11
4 files changed, 52 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 164f101c335..2efeb6d938d 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -16,6 +16,7 @@
SUBDIR += deepforest
SUBDIR += dpkg
SUBDIR += dynamite
+ SUBDIR += dzip
SUBDIR += fastjar
SUBDIR += fileroller
SUBDIR += fpc-paszlib
diff --git a/archivers/dzip/Makefile b/archivers/dzip/Makefile
new file mode 100644
index 00000000000..4562a252983
--- /dev/null
+++ b/archivers/dzip/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Dzip
+# Date created: 08 May 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dzip
+PORTVERSION= 2.9
+CATEGORIES= archivers
+MASTER_SITES= http://speeddemosarchive.com/dzip/
+DISTNAME= dz${PORTVERSION:S/.//g}src
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= File compression utility specializing in Quake demo compression
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}
+MAKEFILE= ${WRKSRC}/Makefile.linux
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+ALL_TARGET= ${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-extract:
+ @${FIND} -E ${WRKDIR} -type f -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
+ @${REINPLACE_CMD} -e 's/ifdef BIG_ENDIAN/if _BYTE_ORDER == _BIG_ENDIAN/' \
+ -e 's/ifndef BIG_ENDIAN/if _BYTE_ORDER == _LITTLE_ENDIAN/' \
+ ${WRKSRC}/dzip.h ${WRKSRC}/conmain.c ${WRKSRC}/dzip.h
+ @${REINPLACE_CMD} -e 's/) $$(OBJECTS/&:T/' ${WRKSRCK}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/archivers/dzip/distinfo b/archivers/dzip/distinfo
new file mode 100644
index 00000000000..56c402bf9e6
--- /dev/null
+++ b/archivers/dzip/distinfo
@@ -0,0 +1,2 @@
+MD5 (dz29src.zip) = b02d69c7c6ee491380d77f26c6f5a6e0
+SIZE (dz29src.zip) = 100354
diff --git a/archivers/dzip/pkg-descr b/archivers/dzip/pkg-descr
new file mode 100644
index 00000000000..cf38407ab0d
--- /dev/null
+++ b/archivers/dzip/pkg-descr
@@ -0,0 +1,11 @@
+Dzip is a program for file compression. It's advantage over more popular
+compression software is in the size of the program, easily fitting on a
+floppy disk.
+
+It performs just as good as the competition, or slightly better, on average,
+both in compression ratio and time.
+
+Dzip's original purpose was to compress demo recordings of the id Software
+game Quake much better than any other program, and it still does!
+
+WWW: http://speeddemosarchive.com/dzip/