aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-03-30 08:13:03 +0800
committerpetef <petef@FreeBSD.org>2002-03-30 08:13:03 +0800
commitc54c7e994b0f39433688b0f3cefdd5c9e605b3e2 (patch)
tree78653fc3dc73a7baabf252bd7c9de9f09de5011e
parent28a3dd88db4ecaca77c1494c187ebdf703d68771 (diff)
downloadfreebsd-ports-graphics-c54c7e994b0f39433688b0f3cefdd5c9e605b3e2.tar.gz
freebsd-ports-graphics-c54c7e994b0f39433688b0f3cefdd5c9e605b3e2.tar.zst
freebsd-ports-graphics-c54c7e994b0f39433688b0f3cefdd5c9e605b3e2.zip
Fix build, don't clobber the system strcasestr() function.
PR: 36455
-rw-r--r--net-p2p/fidelio/Makefile3
-rw-r--r--net/fidelio/Makefile3
2 files changed, 6 insertions, 0 deletions
diff --git a/net-p2p/fidelio/Makefile b/net-p2p/fidelio/Makefile
index 3943c298ddc..6ac49f627e2 100644
--- a/net-p2p/fidelio/Makefile
+++ b/net-p2p/fidelio/Makefile
@@ -28,6 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/libxml2 \
LDFLAGS="-L${LOCALBASE}/lib `${GLIB_CONFIG} --libs gthread`" \
XML_CONFIG="${XML_CONFIG}"
CONFIGURE_ARGS= --without-included-gettext
+CFLAGS+= -DHAVE_STRCASESTR
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
@@ -37,5 +38,7 @@ pre-patch:
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
@${PERL} -pi -e 's|-lxml|-lxml2|g' \
${WRKSRC}/configure
+ @${PERL} -pi -e 's|extern int strcasestr|//extern int strcasestr|' \
+ ${WRKSRC}/src/trackers.c
.include <bsd.port.mk>
diff --git a/net/fidelio/Makefile b/net/fidelio/Makefile
index 3943c298ddc..6ac49f627e2 100644
--- a/net/fidelio/Makefile
+++ b/net/fidelio/Makefile
@@ -28,6 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/libxml2 \
LDFLAGS="-L${LOCALBASE}/lib `${GLIB_CONFIG} --libs gthread`" \
XML_CONFIG="${XML_CONFIG}"
CONFIGURE_ARGS= --without-included-gettext
+CFLAGS+= -DHAVE_STRCASESTR
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
@@ -37,5 +38,7 @@ pre-patch:
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
@${PERL} -pi -e 's|-lxml|-lxml2|g' \
${WRKSRC}/configure
+ @${PERL} -pi -e 's|extern int strcasestr|//extern int strcasestr|' \
+ ${WRKSRC}/src/trackers.c
.include <bsd.port.mk>