aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-11 23:55:46 +0800
committerclsung <clsung@FreeBSD.org>2006-07-11 23:55:46 +0800
commitc7fabf71db38bc157fe9fdfa476f5c74c492c440 (patch)
tree72369228fe1da548e1cdcb571fab4f79d50136f9
parent926a17d029c0ab5f4d38f71e7aea921128cbbf47 (diff)
downloadfreebsd-ports-graphics-c7fabf71db38bc157fe9fdfa476f5c74c492c440.tar.gz
freebsd-ports-graphics-c7fabf71db38bc157fe9fdfa476f5c74c492c440.tar.zst
freebsd-ports-graphics-c7fabf71db38bc157fe9fdfa476f5c74c492c440.zip
Add p5-Config-INI-Simple 0.01, simple reading and writing from an INI
file. PR: ports/100078 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-INI-Simple/Makefile23
-rw-r--r--devel/p5-Config-INI-Simple/distinfo3
-rw-r--r--devel/p5-Config-INI-Simple/pkg-descr8
-rw-r--r--devel/p5-Config-INI-Simple/pkg-plist8
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 496442ee458..3d629134751 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -845,6 +845,7 @@
SUBDIR += p5-Config-Auto
SUBDIR += p5-Config-Fast
SUBDIR += p5-Config-General
+ SUBDIR += p5-Config-INI-Simple
SUBDIR += p5-Config-IniFiles
SUBDIR += p5-Config-Objective
SUBDIR += p5-Config-Record
diff --git a/devel/p5-Config-INI-Simple/Makefile b/devel/p5-Config-INI-Simple/Makefile
new file mode 100644
index 00000000000..b1beecbee1c
--- /dev/null
+++ b/devel/p5-Config-INI-Simple/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Config-INI-Simple
+# Date created: 2006-07-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-INI-Simple
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Simple reading and writing from an INI file
+
+PERL_CONFIGURE= yes
+USE_ZIP= yes
+
+MAN3= Config::INI::Simple.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-INI-Simple/distinfo b/devel/p5-Config-INI-Simple/distinfo
new file mode 100644
index 00000000000..8dcd9e0686a
--- /dev/null
+++ b/devel/p5-Config-INI-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Config-INI-Simple-0.01.zip) = 42747ca2ea05ff5bb41c74bcda9c2476
+SHA256 (Config-INI-Simple-0.01.zip) = da44e32e293cc528f4cb9b39484d2d237980d9af80eb5f9addfc9863fc6adec0
+SIZE (Config-INI-Simple-0.01.zip) = 4930
diff --git a/devel/p5-Config-INI-Simple/pkg-descr b/devel/p5-Config-INI-Simple/pkg-descr
new file mode 100644
index 00000000000..8df0db0ba74
--- /dev/null
+++ b/devel/p5-Config-INI-Simple/pkg-descr
@@ -0,0 +1,8 @@
+Config::INI::Simple is for very simplistic reading and writing of INI
+files. A new object must be created for each INI file (an object keeps
+all the data read in from an INI which is used on the write method to
+write to the INI). It also keeps all your comments and original order
+intact.
+
+Author: C. J. Kirsle <kirsle -at- rainbowboi.com>
+WWW: http://search.cpan.org/dist/Config-INI-Simple/
diff --git a/devel/p5-Config-INI-Simple/pkg-plist b/devel/p5-Config-INI-Simple/pkg-plist
new file mode 100644
index 00000000000..70ab03d88fa
--- /dev/null
+++ b/devel/p5-Config-INI-Simple/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/INI/Simple/.packlist
+%%SITE_PERL%%/Config/INI/Simple.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/INI/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/INI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config
+@dirrmtry %%SITE_PERL%%/Config/INI
+@dirrmtry %%SITE_PERL%%/Config