aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-26 04:06:59 +0800
committerkrion <krion@FreeBSD.org>2004-01-26 04:06:59 +0800
commitc8ed127359d3a11ef8a90d77def4586f5daaaa4a (patch)
tree827b3097c08c58c316823ed875353cc495e1f248
parent74a7d22a1d88420ec26d2bdb0a18facc0057abbc (diff)
downloadfreebsd-ports-graphics-c8ed127359d3a11ef8a90d77def4586f5daaaa4a.tar.gz
freebsd-ports-graphics-c8ed127359d3a11ef8a90d77def4586f5daaaa4a.tar.zst
freebsd-ports-graphics-c8ed127359d3a11ef8a90d77def4586f5daaaa4a.zip
Add latex-caption 3.0.20031220,
The caption package provides many ways to customise the captions in floating environments such figure and table and cooperates with many other packages. PR: ports/61893 Submitted by: hrs@FreeBSD.org
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-caption/Makefile62
-rw-r--r--print/latex-caption/distinfo4
-rw-r--r--print/latex-caption/pkg-descr3
-rw-r--r--print/latex-caption/pkg-plist12
5 files changed, 82 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 897f0c3bf04..aaca996a39f 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -93,6 +93,7 @@
SUBDIR += kover
SUBDIR += latex
SUBDIR += latex-beamer
+ SUBDIR += latex-caption
SUBDIR += latex-keystroke
SUBDIR += latex-mathabx
SUBDIR += latex-pgf
diff --git a/print/latex-caption/Makefile b/print/latex-caption/Makefile
new file mode 100644
index 00000000000..ba98450a4a5
--- /dev/null
+++ b/print/latex-caption/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: latex-caption
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-caption
+PORTVERSION= 3.0.20031220
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/caption
+DISTFILES= caption.dtx caption2.dtx caption.ins caption.xml
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package that supports customization of captions
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS+= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+BUILD_DEPENDS+= tex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+USE_GMAKE= YES
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+TEX_BIN= ${LOCALBASE}/bin/tex
+YES_CMD= /usr/bin/yes
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+WRKSRC= ${WRKDIR}/${PORTNAME:S/^latex-//}
+
+CLASS_FILES= caption.dtx
+CLASS_FILES+= caption.sty
+CLASS_FILES+= caption.ins
+CLASS_FILES+= caption2.dtx
+CLASS_FILES+= caption2.sty
+
+DOC_FILES= manual.tex
+DOC_FILES+= caption.xml
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${CP} ${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${YES_CMD} | ${TEX_BIN} caption.ins
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ @${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-caption/distinfo b/print/latex-caption/distinfo
new file mode 100644
index 00000000000..661fd04df71
--- /dev/null
+++ b/print/latex-caption/distinfo
@@ -0,0 +1,4 @@
+MD5 (latex-caption/caption.dtx) = 58c953c4e24ecdacd50ea00f2a9f3274
+MD5 (latex-caption/caption2.dtx) = 241f88a1e1bfb67d9e93e33d4e6cf9d6
+MD5 (latex-caption/caption.ins) = 3617343d79edda46233594958344d184
+MD5 (latex-caption/caption.xml) = 6b4d7d970a2ed6f24c081cef7fb86e77
diff --git a/print/latex-caption/pkg-descr b/print/latex-caption/pkg-descr
new file mode 100644
index 00000000000..a159d78b73a
--- /dev/null
+++ b/print/latex-caption/pkg-descr
@@ -0,0 +1,3 @@
+The caption package provides many ways to customise the captions
+in floating environments such figure and table and cooperates with
+many other packages.
diff --git a/print/latex-caption/pkg-plist b/print/latex-caption/pkg-plist
new file mode 100644
index 00000000000..6496ced5bf1
--- /dev/null
+++ b/print/latex-caption/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/manual.tex
+%%PORTDOCS%%%%DOCSDIR%%/caption.xml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/caption.dtx
+%%CLASSDIR%%/caption.sty
+%%CLASSDIR%%/caption.ins
+%%CLASSDIR%%/caption2.dtx
+%%CLASSDIR%%/caption2.sty
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%