aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-07-15 04:32:14 +0800
committernovel <novel@FreeBSD.org>2005-07-15 04:32:14 +0800
commitc8fc939366fe02bd35c2a9fafe05e0df54711f2d (patch)
treedd9fbb949d14393652f8c43e22caa68c5a3be793
parent6cc207a18afaf8e0b7dbafcefbd57b2b6d95dc13 (diff)
downloadfreebsd-ports-graphics-c8fc939366fe02bd35c2a9fafe05e0df54711f2d.tar.gz
freebsd-ports-graphics-c8fc939366fe02bd35c2a9fafe05e0df54711f2d.tar.zst
freebsd-ports-graphics-c8fc939366fe02bd35c2a9fafe05e0df54711f2d.zip
Attempt to fix build on 7.x (7.x now is pretty same that 6.x, so teach
the configure script to deal with 7.x like with 6.x). Reported by: poinyhat via kris
-rw-r--r--deskutils/adesklets/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/deskutils/adesklets/Makefile b/deskutils/adesklets/Makefile
index 40086c07737..8dca90506dc 100644
--- a/deskutils/adesklets/Makefile
+++ b/deskutils/adesklets/Makefile
@@ -17,6 +17,7 @@ COMMENT= An interactive Imlib2 console for the X Window system
LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
USE_PYTHON= yes
USE_BZIP2= yes
USE_XLIB= yes
@@ -39,6 +40,11 @@ CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib" \
PORTDOCS= *.html
.endif
+.if ${OSVERSION} >= 700000
+pre-configure:
+ @${REINPLACE_CMD} -e "s|FreeBSD 6|FreeBSD 7|g" ${WRKSRC}/configure
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}