aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-04-28 02:06:41 +0800
committernaddy <naddy@FreeBSD.org>2003-04-28 02:06:41 +0800
commitca28427d9f526c7cc7aaf7f7d34dd50e56fe751d (patch)
tree274ab501d875ab7d165a7c26af33e21c1996e49a
parent4fa6c4f90214bce65ad0db02c27c65da789a60b8 (diff)
downloadfreebsd-ports-graphics-ca28427d9f526c7cc7aaf7f7d34dd50e56fe751d.tar.gz
freebsd-ports-graphics-ca28427d9f526c7cc7aaf7f7d34dd50e56fe751d.tar.zst
freebsd-ports-graphics-ca28427d9f526c7cc7aaf7f7d34dd50e56fe751d.zip
Use USE_GETOPT_LONG.
PR: 51222 Submitted by: Ports Fury
-rw-r--r--cad/gerbv/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/cad/gerbv/Makefile b/cad/gerbv/Makefile
index f79432c57ab..6cace0cdd3a 100644
--- a/cad/gerbv/Makefile
+++ b/cad/gerbv/Makefile
@@ -17,6 +17,7 @@ COMMENT= A Free Gerber Viewer
USE_GNOME= gdkpixbuf
USE_REINPLACE= yes
+USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-exportpng
@@ -26,13 +27,6 @@ MAN1= gerbv.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500041
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-LDFLAGS+= -lgnugetopt
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/src/amacro.c
@@ -46,4 +40,4 @@ post-install:
cpio -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>