aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-04-02 11:59:00 +0800
committersteve <steve@FreeBSD.org>1999-04-02 11:59:00 +0800
commitcbb969b01d05dea32d7a15cb3c4503e463d3e4fb (patch)
treedca8b1f029dac47292ed4da80cfe43016977c771
parent94e0040e3ca00b747795ba0d803422a605a18f2f (diff)
downloadfreebsd-ports-graphics-cbb969b01d05dea32d7a15cb3c4503e463d3e4fb.tar.gz
freebsd-ports-graphics-cbb969b01d05dea32d7a15cb3c4503e463d3e4fb.tar.zst
freebsd-ports-graphics-cbb969b01d05dea32d7a15cb3c4503e463d3e4fb.zip
Update to version 0.4.
PR: 10732 Submitted by: Martin Kammerhofer <mkamm@gmx.net>
-rw-r--r--textproc/c2html/Makefile23
-rw-r--r--textproc/c2html/distinfo2
-rw-r--r--textproc/c2html/files/patch-aa32
-rw-r--r--textproc/c2html/pkg-descr5
-rw-r--r--textproc/c2html/pkg-plist3
5 files changed, 38 insertions, 27 deletions
diff --git a/textproc/c2html/Makefile b/textproc/c2html/Makefile
index b800118aec3..2a876dcc863 100644
--- a/textproc/c2html/Makefile
+++ b/textproc/c2html/Makefile
@@ -1,26 +1,29 @@
# New ports collection makefile for: c2html
-# Version required: 0.1
+# Version required: 0.4
# Date created: 28 October 1997
# Whom: Andrey Zakhvatov
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/11/22 00:30:17 jseger Exp $
#
-DISTNAME= c2html-0.1
+DISTNAME= c2html-0.4
CATEGORIES= textproc www
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/www/converters
-MAINTAINER= andy@icc.surw.chel.su
+MAINTAINER= mkamm@gmx.net
+
+USE_AUTOCONF= yes
MAN1= c2html.1
-do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/c2html ${PREFIX}/bin
- @ ${INSTALL_MAN} ${WRKSRC}/c2html.1 ${PREFIX}/man/man1
- @ ${MKDIR} ${PREFIX}/share/doc/c2html
-.for file in COPYING README
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/c2html
+post-install:
+ strip ${PREFIX}/bin/c2html
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/c2html
+.for file in AUTHORS NEWS README
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${PREFIX}/share/doc/c2html
.endfor
+.endif
.include <bsd.port.mk>
diff --git a/textproc/c2html/distinfo b/textproc/c2html/distinfo
index 8c7aece830c..3d2520b3d68 100644
--- a/textproc/c2html/distinfo
+++ b/textproc/c2html/distinfo
@@ -1 +1 @@
-MD5 (c2html-0.1.tar.gz) = 66659aec84aad813e52042576abf6662
+MD5 (c2html-0.4.tar.gz) = 317c49ca99230865cb39fd54f091fad0
diff --git a/textproc/c2html/files/patch-aa b/textproc/c2html/files/patch-aa
index e07a13a8844..5e419428697 100644
--- a/textproc/c2html/files/patch-aa
+++ b/textproc/c2html/files/patch-aa
@@ -1,18 +1,20 @@
---- Makefile.orig Mon Sep 1 22:18:51 1997
-+++ Makefile Sun Nov 16 17:24:44 1997
-@@ -2,13 +2,13 @@
+--- Makefile.in~ Wed Mar 10 22:14:48 1999
++++ Makefile.in Sun Mar 21 18:19:16 1999
+@@ -12,7 +12,7 @@
+ # for gzip because otherwise the load on the web server
+ # grows without having big benefits.
+ # COMPRESSION = -DCOMPRESSION=4
+-COMPRESSION = -DCOMPRESSION=1
++COMPRESSION ?= -DCOMPRESSION=1
- CC = gcc
- FLEX = flex
--CFLAGS = -O2 -Wall -pedantic -ansi
-+CFLAGS+= -Wall -pedantic -ansi -DCOMPRESSION=1
+ # Dont change things beyond this line.
+ TARGET = c2html
+@@ -40,7 +40,7 @@
+ srcdir = @srcdir@
+ CPPFLAGS = @CPPFLAGS@
- all: c2html
-
- c2html: c2html.l
- $(FLEX) c2html.l
-- $(CC) $(CFLAGS) -o c2html lex.yy.c -static -lfl
-+ $(CC) $(CFLAGS) -o c2html lex.yy.c -lfl
- clean:
- rm -rf *.o *~ c2html
+-CFLAGS = -O2 -Wall -pedantic $(COMPRESSION)
++CFLAGS += -O2 -Wall -pedantic $(COMPRESSION)
+ ALL_CFLAGS = $(CFLAGS) -I$(srcdir)
+ all: $(TARGET)
diff --git a/textproc/c2html/pkg-descr b/textproc/c2html/pkg-descr
index d4bd0de3148..58f56c55b59 100644
--- a/textproc/c2html/pkg-descr
+++ b/textproc/c2html/pkg-descr
@@ -4,3 +4,8 @@ graphical WWW-Browser. If the browser understands the tags to change
font colors (as Netscape does) the output will look like highlighted
by emacs. Otherwise it will not look so nice, but readability is
increased too.
+
+c2html can also work as a CGI program and convert your sources on the
+fly. To use in this way copy it to your /cgi-bin directory and
+configure your webserver to call c2html for *.c and *.h files. An
+example that works with Apache is described in the manpage.
diff --git a/textproc/c2html/pkg-plist b/textproc/c2html/pkg-plist
index 8c45533a27f..d57ff09016f 100644
--- a/textproc/c2html/pkg-plist
+++ b/textproc/c2html/pkg-plist
@@ -1,4 +1,5 @@
bin/c2html
-share/doc/c2html/COPYING
+share/doc/c2html/AUTHORS
+share/doc/c2html/NEWS
share/doc/c2html/README
@dirrm share/doc/c2html