aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-12-09 01:07:22 +0800
committerfeld <feld@FreeBSD.org>2016-12-09 01:07:22 +0800
commitcc0df536fc6a7235d8ee4b21a8a5dcdd1b8a644b (patch)
tree0b3e12a5c24c198c9a5cf3af099cefaf2a90e7db
parentdc628f55ecc88d9a571a3d7c47afdf01d4b36c5f (diff)
downloadfreebsd-ports-graphics-cc0df536fc6a7235d8ee4b21a8a5dcdd1b8a644b.tar.gz
freebsd-ports-graphics-cc0df536fc6a7235d8ee4b21a8a5dcdd1b8a644b.tar.zst
freebsd-ports-graphics-cc0df536fc6a7235d8ee4b21a8a5dcdd1b8a644b.zip
security/py-pycryptography: Fix build on FreeBSD 9.3
Modern py-cryptography requires a more modern OpenSSL. This switch to requiring OpenSSL from ports is a disruptive change, but it will protect these users from the recently patched vulnerabilites. Support for OpenSSL 0.9.8 was removed in pycryptography as of version 1.4. The last release to support OpenSSL 0.9.8 was 1.3.4 which is still vulnerable to the HDKF key generation bug. It appears that version 1.4 did build successfully on FreeBSD 9.3, but upstream had abandoned support for OpenSSL 0.9.8 at that point so it is unclear if it was fully functional. PR: 214915 MFH: 2016Q4
-rw-r--r--security/py-cryptography/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 9fc184a00ef..7ca02284626 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -27,6 +27,11 @@ USE_PYTHON= autoplist distutils
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
+# Modern py-cyptography requires newer OpenSSL
+.if ${OSVERSION} < 1000000
+WITH_OPENSSL_PORT= yes
+.endif
+
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3300