aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-11-23 12:29:55 +0800
committerjylefort <jylefort@FreeBSD.org>2005-11-23 12:29:55 +0800
commitcec26a0766268cac76b2dbc0906470e182147b95 (patch)
tree7ff3a8f917f0481eb0ea2bd211d362df04eb1854
parent492cda65d14fc4ae74b93b74ecc9d66cdf6866a0 (diff)
downloadfreebsd-ports-graphics-cec26a0766268cac76b2dbc0906470e182147b95.tar.gz
freebsd-ports-graphics-cec26a0766268cac76b2dbc0906470e182147b95.tar.zst
freebsd-ports-graphics-cec26a0766268cac76b2dbc0906470e182147b95.zip
Disable compiler optimizations on 4.x, since they cause the build to fail.
Reported by: pointyhat via kris
-rw-r--r--devel/simgear/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 97c9acccd98..92d3c358f43 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -27,8 +27,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-jpeg-factory
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+CFLAGS+= -O0 # optimizations cause a build failure
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|' \
${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>