aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-11 11:06:55 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-11 11:06:55 +0800
commitd2465577297e3b792cdec160a145b265d0842079 (patch)
tree284258322390c481b7f3eca434d9e3d20f5b16fd
parent543e0f6e69d62bad4c46e0d1f3f8f7ec0c312185 (diff)
downloadfreebsd-ports-graphics-d2465577297e3b792cdec160a145b265d0842079.tar.gz
freebsd-ports-graphics-d2465577297e3b792cdec160a145b265d0842079.tar.zst
freebsd-ports-graphics-d2465577297e3b792cdec160a145b265d0842079.zip
- Convert LIB_DEPENDS to new syntax
- Convert USE_GMAKE to USES - Add stage support
-rw-r--r--games/tenebrae/Makefile28
1 files changed, 8 insertions, 20 deletions
diff --git a/games/tenebrae/Makefile b/games/tenebrae/Makefile
index 06c2db75412..333dbf6163f 100644
--- a/games/tenebrae/Makefile
+++ b/games/tenebrae/Makefile
@@ -12,11 +12,11 @@ DISTFILES= ${PORTNAME}_src${EXTRACT_SUFX} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Quake engine with lighting similar to that in Doom III
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+USES= gmake
USE_ZIP= yes
USE_DOS2UNIX= yes
-USE_GMAKE= yes
USE_GL= glu
USE_SDL= yes
USE_XORG= xxf86dga
@@ -32,12 +32,7 @@ OPTIONS_DEFAULT_i386= ASM
OPTIONS_DEFINE_amd64= ASM
OPTIONS_DEFAULT_amd64= ASM
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MASM}
-MAKE_ENV+= USE_ASM=1
-.endif
+ASM_MAKE_ENV= USE_ASM=1
post-patch:
${REINPLACE_CMD} -e 's|gray_1_2_4_to_8|expand_&|' \
@@ -48,19 +43,12 @@ pre-build:
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/bin/${PORTNAME} \
- ${PREFIX}/bin
- @${MKDIR} ${Q1DIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/Pak0.pak ${Q1DIR}/${PORTNAME}
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${Q1DIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/Pak0.pak ${STAGEDIR}${Q1DIR}/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${TR} -d '\r' < ${WRKDIR}/Tenebrae_Readme.txt \
- > ${DOCSDIR}/Tenebrae_Readme.txt
-.endif
-
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
+ > ${STAGEDIR}${DOCSDIR}/Tenebrae_Readme.txt
.include "${.CURDIR}/../quake-data/Makefile.include"
.include <bsd.port.mk>