aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-07 06:06:26 +0800
committerantoine <antoine@FreeBSD.org>2014-02-07 06:06:26 +0800
commitd28438096835de066a1de7b091d76bea6b81d1a2 (patch)
treecd702df07403ccfc89b9116dce5115434319449f
parent031c4a24225da8137b3fcaea461808b27176f54a (diff)
downloadfreebsd-ports-graphics-d28438096835de066a1de7b091d76bea6b81d1a2.tar.gz
freebsd-ports-graphics-d28438096835de066a1de7b091d76bea6b81d1a2.tar.zst
freebsd-ports-graphics-d28438096835de066a1de7b091d76bea6b81d1a2.zip
- Stage support
- Use OPTIONS helpers
-rw-r--r--graphics/py-opengl/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index 582dd3d62e4..20def390ed9 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -28,13 +28,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MTKINTER}
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
-.endif
+TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
+TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
post-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
@@ -42,4 +37,4 @@ post-patch:
@${FIND} ${WRKSRC} -name "*.bak" -delete
${REINPLACE_CMD} -e 's|posix |posix|g' ${WRKSRC}/OpenGL/__init__.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>