aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-08-09 17:17:29 +0800
committerijliao <ijliao@FreeBSD.org>2002-08-09 17:17:29 +0800
commitd3116505a605ef157389abe30e2d0d37cac9abc7 (patch)
treee0e0e4e9b09b6e8d9783ee5e2023e4e11ce7c93a
parent119e3bfa799a1b41b8e951ab2aa14ac06bb04435 (diff)
downloadfreebsd-ports-graphics-d3116505a605ef157389abe30e2d0d37cac9abc7.tar.gz
freebsd-ports-graphics-d3116505a605ef157389abe30e2d0d37cac9abc7.tar.zst
freebsd-ports-graphics-d3116505a605ef157389abe30e2d0d37cac9abc7.zip
add peeper 0.1
View an area of the screen at a certain magnification
-rw-r--r--x11/Makefile1
-rw-r--r--x11/peeper/Makefile31
-rw-r--r--x11/peeper/distinfo1
-rw-r--r--x11/peeper/pkg-comment1
-rw-r--r--x11/peeper/pkg-descr3
-rw-r--r--x11/peeper/pkg-plist1
6 files changed, 38 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 710a8d346f0..9359f8dcb7e 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -84,6 +84,7 @@
SUBDIR += offix-execute
SUBDIR += oooqs
SUBDIR += p5-X11-Protocol
+ SUBDIR += peeper
SUBDIR += portoseguro
SUBDIR += powershell
SUBDIR += props
diff --git a/x11/peeper/Makefile b/x11/peeper/Makefile
new file mode 100644
index 00000000000..6dca2dbfe5c
--- /dev/null
+++ b/x11/peeper/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: peeper
+# Date created: Aug 9, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= peeper
+PORTVERSION= 0.1
+CATEGORIES= x11
+MASTER_SITES= http://peeper.sourceforge.net/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12 imlib
+USE_GMAKE= yes
+ALL_TARGET= peeper
+MAKE_ENV= LIBS="-L${LOCALBASE}/lib -lpng -ljpeg -lungif -ltiff"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CC|#CC|g" -e "s|CFLAGS=|CFLAGS+=|g" \
+ -e "s|gtk-config|${GTK_CONFIG}|g" -e "s|-ldl||g" \
+ -e "s|LIBS=|LIBS+=|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/peeper ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/peeper/distinfo b/x11/peeper/distinfo
new file mode 100644
index 00000000000..8d0000fa319
--- /dev/null
+++ b/x11/peeper/distinfo
@@ -0,0 +1 @@
+MD5 (peeper-0.1.tar.gz) = 418585fdcf214990b1028c60a6ef1c10
diff --git a/x11/peeper/pkg-comment b/x11/peeper/pkg-comment
new file mode 100644
index 00000000000..1c4e6f67393
--- /dev/null
+++ b/x11/peeper/pkg-comment
@@ -0,0 +1 @@
+View an area of the screen at a certain magnification
diff --git a/x11/peeper/pkg-descr b/x11/peeper/pkg-descr
new file mode 100644
index 00000000000..60269e0bd2e
--- /dev/null
+++ b/x11/peeper/pkg-descr
@@ -0,0 +1,3 @@
+Peeper is a GTK program to view an area of the screen at a certain
+magnification. It has the ability to magnify animations, and view
+the screen at different levels of magnification.
diff --git a/x11/peeper/pkg-plist b/x11/peeper/pkg-plist
new file mode 100644
index 00000000000..d4f496e6822
--- /dev/null
+++ b/x11/peeper/pkg-plist
@@ -0,0 +1 @@
+bin/peeper