aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-05-02 13:40:34 +0800
committeradamw <adamw@FreeBSD.org>2004-05-02 13:40:34 +0800
commitd9cd48972bef0840dbeec3a0933e3c428e4b2090 (patch)
treee75c73e126e345abb2ccb9463424f9e9662ae6a5
parent620f1d55354102108ebd3ea5db12076693b3fa42 (diff)
downloadfreebsd-ports-graphics-d9cd48972bef0840dbeec3a0933e3c428e4b2090.tar.gz
freebsd-ports-graphics-d9cd48972bef0840dbeec3a0933e3c428e4b2090.tar.zst
freebsd-ports-graphics-d9cd48972bef0840dbeec3a0933e3c428e4b2090.zip
Allow non-root/non-wheel users to access tuxracer data files.
PR: ports/66155 Submitted by: Jonathan <j.e.drews@att.net>
-rw-r--r--games/etuxracer/Makefile4
-rw-r--r--games/tuxracer-commercial/Makefile4
-rw-r--r--games/tuxracer/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/games/etuxracer/Makefile b/games/etuxracer/Makefile
index 583eaa7a0c2..f26fee32715 100644
--- a/games/etuxracer/Makefile
+++ b/games/etuxracer/Makefile
@@ -20,7 +20,7 @@ COMMENT= A 3d penguin racing game using OpenGL
LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
USE_SDL= mixer sdl
-USE_MESA= yes
+USE_GL= yes
USE_GMAKE= yes
USE_AUTOMAKE_VER= 14
AUTOMAKE_ARGS= -a
@@ -40,7 +40,7 @@ post-extract:
post-install:
${MKDIR} ${DATADIR}
- (cd ${WORKDATA} && ${TAR} -c -f - *) | \
+ (${CHMOD} -R o+r ${WORKDATA} && cd ${WORKDATA} && ${TAR} -c -f - *) | \
(cd ${DATADIR} && ${TAR} -x -f - )
.include <bsd.port.mk>
diff --git a/games/tuxracer-commercial/Makefile b/games/tuxracer-commercial/Makefile
index 583eaa7a0c2..f26fee32715 100644
--- a/games/tuxracer-commercial/Makefile
+++ b/games/tuxracer-commercial/Makefile
@@ -20,7 +20,7 @@ COMMENT= A 3d penguin racing game using OpenGL
LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
USE_SDL= mixer sdl
-USE_MESA= yes
+USE_GL= yes
USE_GMAKE= yes
USE_AUTOMAKE_VER= 14
AUTOMAKE_ARGS= -a
@@ -40,7 +40,7 @@ post-extract:
post-install:
${MKDIR} ${DATADIR}
- (cd ${WORKDATA} && ${TAR} -c -f - *) | \
+ (${CHMOD} -R o+r ${WORKDATA} && cd ${WORKDATA} && ${TAR} -c -f - *) | \
(cd ${DATADIR} && ${TAR} -x -f - )
.include <bsd.port.mk>
diff --git a/games/tuxracer/Makefile b/games/tuxracer/Makefile
index 583eaa7a0c2..f26fee32715 100644
--- a/games/tuxracer/Makefile
+++ b/games/tuxracer/Makefile
@@ -20,7 +20,7 @@ COMMENT= A 3d penguin racing game using OpenGL
LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
USE_SDL= mixer sdl
-USE_MESA= yes
+USE_GL= yes
USE_GMAKE= yes
USE_AUTOMAKE_VER= 14
AUTOMAKE_ARGS= -a
@@ -40,7 +40,7 @@ post-extract:
post-install:
${MKDIR} ${DATADIR}
- (cd ${WORKDATA} && ${TAR} -c -f - *) | \
+ (${CHMOD} -R o+r ${WORKDATA} && cd ${WORKDATA} && ${TAR} -c -f - *) | \
(cd ${DATADIR} && ${TAR} -x -f - )
.include <bsd.port.mk>