aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-10-29 22:26:31 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-10-29 22:26:31 +0800
commitde9d59015a039c25ea472a8f8f26305f25cb34fd (patch)
tree4d9b4b31b4d9a9a4f401334a6dcc2353dfbe9d45
parent5d989c69a8281a37b57c3eb5e93524485c44f85a (diff)
downloadfreebsd-ports-graphics-de9d59015a039c25ea472a8f8f26305f25cb34fd.tar.gz
freebsd-ports-graphics-de9d59015a039c25ea472a8f8f26305f25cb34fd.tar.zst
freebsd-ports-graphics-de9d59015a039c25ea472a8f8f26305f25cb34fd.zip
- Add new OFL(1.0 and 1.1 versions) font licenses
PR: ports/183363 Submitted by: Ilya A. Arkhipov <rum1cro@yandex.ru> Reviewed by: tabthorpe With hat: portmgr
-rw-r--r--Mk/bsd.licenses.db.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/Mk/bsd.licenses.db.mk b/Mk/bsd.licenses.db.mk
index 9265a2925b3..cecb4fc2897 100644
--- a/Mk/bsd.licenses.db.mk
+++ b/Mk/bsd.licenses.db.mk
@@ -38,7 +38,8 @@ Licenses_db_Include_MAINTAINER= portmgr@FreeBSD.org
_LICENSE_LIST= AGPLv3 AL2 ART10 ARTPERL10 ART20 BSD BSL CDDL EPL GFDL GPLv1 GPLv2 \
GPLv3 ISCL LGPL20 LGPL21 LGPL3 LPPL10 LPPL11 LPPL12 LPPL13 LPPL13a \
- LPPL13b LPPL13c MIT MPL OWL PHP202 PHP30 PHP301 PSFL ZLIB ZPL21
+ LPPL13b LPPL13c MIT MPL OFL10 OFL11 OWL PHP202 PHP30 PHP301 PSFL \
+ ZLIB ZPL21
# List of groups (only names must be present)
@@ -50,6 +51,8 @@ _LICENSE_NAME_OSI= OSI Approved
_LICENSE_NAME_COPYFREE= Comply with Copyfree Standard Definition.
+_LICENSE_NAME_FONTS= Font licenses
+
# Default permissions for licenses here, if not defined
_LICENSE_PERMS_DEFAULT= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
@@ -151,6 +154,12 @@ _LICENSE_GROUPS_MIT= FSF GPL OSI COPYFREE
_LICENSE_NAME_MPL= Mozilla Public License
_LICENSE_GROUPS_MPL= FSF OSI
+_LICENSE_NAME_OFL10= SIL Open Font License version 1.0 (http://scripts.sil.org/OFL)
+_LICENSE_GROUPS_OFL10= FONTS
+
+_LICENSE_NAME_OFL11= SIL Open Font License version 1.1 (http://scripts.sil.org/OFL)
+_LICENSE_GROUPS_OFL11= FONTS
+
_LICENSE_NAME_OWL= Open Works License (owl.apotheon.org)
_LICENSE_GROUPS_OWL= COPYFREE