aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2003-10-08 04:26:18 +0800
committerglewis <glewis@FreeBSD.org>2003-10-08 04:26:18 +0800
commite408a69b1542fece50a6cb85602f9c210fc408c7 (patch)
tree758a95ccb9c4e53f9611bd7b2d5c7d6381ecfbe1
parent89075f14d6a1abb8bfc8280f54109f411be50c4d (diff)
downloadfreebsd-ports-graphics-e408a69b1542fece50a6cb85602f9c210fc408c7.tar.gz
freebsd-ports-graphics-e408a69b1542fece50a6cb85602f9c210fc408c7.tar.zst
freebsd-ports-graphics-e408a69b1542fece50a6cb85602f9c210fc408c7.zip
. Add a port of bed:
Menu driven binary editor. Dataformats are ascii, unsigned and signed integers, float, bitflags, bitfields, labels, ebcdic and time_t. Different sizes and byte ordenings are possible. Datatypes can be used in structures. Other dataformats, filters and procedures can be defined in plugins. Contains copy, past, undo, redo, search, replace, marks, record/play and context sensitive help. Linux & FreeBSD: edit block devices (linux limit 1023 gigabyte). PR: 27200 Submitted by: Jaap Korthals Altes <jkaltes@cyberbrain.com> (updated based on the port in the 0.2.19 distfile)
-rw-r--r--editors/Makefile1
-rw-r--r--editors/bed/Makefile50
-rw-r--r--editors/bed/distinfo1
-rw-r--r--editors/bed/files/patch-Makefile13
-rw-r--r--editors/bed/files/patch-config.in13
-rw-r--r--editors/bed/pkg-descr9
-rw-r--r--editors/bed/pkg-plist119
7 files changed, 206 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 80ce889157a..989e875d69f 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -15,6 +15,7 @@
SUBDIR += axe
SUBDIR += beav
SUBDIR += beaver
+ SUBDIR += bed
SUBDIR += biew
SUBDIR += bitedit
SUBDIR += bitmap
diff --git a/editors/bed/Makefile b/editors/bed/Makefile
new file mode 100644
index 00000000000..f309672cf64
--- /dev/null
+++ b/editors/bed/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: bed
+# Date created: 2001/05/07
+# Whom: jkaltes@hetnet.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= bed
+PORTVERSION= 0.2.19
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/editors/terminal
+EXTRACT_SUFX= .src.tar.gz
+
+MAINTAINER= jkaltes@hetnet.nl
+COMMENT= Variable dataformat binary editor
+
+.if !defined(WITHOUT_X11)
+CONFIGURE_DEPENDS= ${X11BASE}/bin/rxvt:${PORTSDIR}/x11/rxvt
+.endif
+
+GNU_CONFIGURE= yes
+
+USE_GMAKE= yes
+
+MAN1= bed.1 xbed.1
+MANCOMPRESSED= yes
+
+.if defined(WITHOUT_X11)
+CONFIGURE_ARGS+= --without-x
+PLIST_SUB+= X11="@comment "
+.else
+PLIST_SUB+= X11=""
+
+pre-configure:
+ @if "${X11BASE}/bin/rxvt" -h 2>&1 | ${GREP} -qi menubar; then \
+ else \
+ ${ECHO_MSG} "${PORTSDIR}/x11/rxvt must be compiled with the option"; \
+ ${ECHO_MSG} " WITH_MENUBAR=yes"; \
+ ${ECHO_MSG} "to enable X11 support."; \
+ exit 1; \
+ fi
+.endif
+
+post-configure:
+ ${ECHO_MSG} 'CONFIG_DEBUG=n' >> ${WRKSRC}/config
+ ${ECHO_MSG} 'CONFIG_MMAP=y' >> ${WRKSRC}/config
+ ${GMAKE} -C ${WRKSRC} dep
+
+.include <bsd.port.mk>
diff --git a/editors/bed/distinfo b/editors/bed/distinfo
new file mode 100644
index 00000000000..ca70a6aaed7
--- /dev/null
+++ b/editors/bed/distinfo
@@ -0,0 +1 @@
+MD5 (bed-0.2.19.src.tar.gz) = 96d340c164f220d303b986d5d68d8008
diff --git a/editors/bed/files/patch-Makefile b/editors/bed/files/patch-Makefile
new file mode 100644
index 00000000000..3bf151c35f2
--- /dev/null
+++ b/editors/bed/files/patch-Makefile
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- Makefile.orig Tue Oct 7 13:57:29 2003
++++ Makefile Tue Oct 7 13:58:03 2003
+@@ -57,7 +57,7 @@
+ -mv $(ROOTDIR)$(CONFDIRLINK) $(CONFDIRLINK).bak
+ -$(MKDIR) $(ROOTDIR)$(CONFDIR)
+ ifneq ($(CYGWIN),yes)
+- $(SYMLINK) $(CONFLASTDIR) $(ROOTDIR)$(CONFDIRLINK)
++# $(SYMLINK) $(CONFLASTDIR) $(ROOTDIR)$(CONFDIRLINK)
+ -mv $(ROOTDIR)$(CONFDIR)/$(CONFFILE) $(ROOTDIR)$(CONFDIR)/~$(CONFFILE)
+ endif
+ $(CP) $(CONFFILE) $(ROOTDIR)$(CONFDIR)
diff --git a/editors/bed/files/patch-config.in b/editors/bed/files/patch-config.in
new file mode 100644
index 00000000000..d633e036b42
--- /dev/null
+++ b/editors/bed/files/patch-config.in
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- config.in.orig Tue Oct 7 13:47:25 2003
++++ config.in Tue Oct 7 13:47:35 2003
+@@ -13,7 +13,7 @@
+ SYSTEM=@SYSTEM@
+ CYGWIN=@CYGWIN@
+ export CONFFILE=$(PROGRAM)rc
+-export CONFLASTDIR=$(PROGRAM)-$(VERSION)
++export CONFLASTDIR=$(PROGRAM)
+ export ROOTDIR=
+ LN_S=@LN_S@
+ # compile support for the use of plugins. Needs libdl
diff --git a/editors/bed/pkg-descr b/editors/bed/pkg-descr
new file mode 100644
index 00000000000..b3e706e4dfd
--- /dev/null
+++ b/editors/bed/pkg-descr
@@ -0,0 +1,9 @@
+Menu driven binary editor. Dataformats are
+ascii, unsigned and signed integers, float, bitflags,
+bitfields, labels, ebcdic and time_t. Different sizes
+and byte ordenings are possible. Datatypes can
+be used in structures. Other dataformats, filters and
+procedures can be defined in plugins. Contains copy,
+past, undo, redo, search, replace, marks, record/play and
+context sensitive help. Linux & FreeBSD: edit block devices
+(linux limit 1023 gigabyte).
diff --git a/editors/bed/pkg-plist b/editors/bed/pkg-plist
new file mode 100644
index 00000000000..a4ac128bf03
--- /dev/null
+++ b/editors/bed/pkg-plist
@@ -0,0 +1,119 @@
+%%DATADIR%%/bedrc
+%%DATADIR%%/.neededbybed
+%%DATADIR%%/misc/pushlpushl.bedda
+%%DATADIR%%/misc/hexasc.bedda
+%%DATADIR%%/misc/char2b.bedda
+%%DATADIR%%/misc/char2.bedda
+%%DATADIR%%/misc/bits.bedda
+%%DATADIR%%/misc/README.txt
+%%DATADIR%%/misc/symtab.bedda
+%%DATADIR%%/misc/sectionheader.bedda
+%%DATADIR%%/misc/programheader.bedda
+%%DATADIR%%/misc/elfheader.bedda
+%%DATADIR%%/misc/dynsym.bedda
+%%DATADIR%%/misc/wtmp-freebsd.bedda
+%%DATADIR%%/misc/win32sections.bedda
+%%DATADIR%%/utils/bin2byte
+%%DATADIR%%/utils/keyconfig
+%%DATADIR%%/plugins/plugin.cpp
+%%DATADIR%%/plugins/global.h
+%%DATADIR%%/plugins/faked.h
+%%DATADIR%%/plugins/Makefile
+%%DATADIR%%/plugins/ascii.h
+%%DATADIR%%/plugins/varmacro.h
+%%DATADIR%%/plugins/config.h
+%%DATADIR%%/plugins/digitstring.h
+%%DATADIR%%/plugins/views.h
+%%DATADIR%%/plugins/typelist.h
+%%DATADIR%%/plugins/type.h
+%%DATADIR%%/plugins/screenpart.h
+%%DATADIR%%/plugins/screen.h
+%%DATADIR%%/plugins/repeat.h
+%%DATADIR%%/plugins/mainprocedures.h
+%%DATADIR%%/plugins/offtypes.h
+%%DATADIR%%/plugins/multidigit.h
+%%DATADIR%%/plugins/hassub.h
+%%DATADIR%%/plugins/getfile.h
+%%DATADIR%%/plugins/filter.h
+%%DATADIR%%/plugins/contain.h
+%%DATADIR%%/plugins/defines.h
+%%DATADIR%%/plugins/examples/Makefile
+%%X11%%%%DATADIR%%/plugins/examples/switchsize.plug
+%%DATADIR%%/plugins/examples/rxvt.plug
+%%DATADIR%%/plugins/examples/elftables.plug
+%%DATADIR%%/plugins/examples/index2table.plug
+%%DATADIR%%/plugins/examples/cut.plug
+%%DATADIR%%/plugins/examples/datatypeinfo.plug
+%%DATADIR%%/plugins/examples/searchclip.plug
+%%DATADIR%%/plugins/examples/helpf1.plug
+%%DATADIR%%/plugins/examples/title.plug
+%%DATADIR%%/plugins/examples/backward.plug
+%%DATADIR%%/plugins/examples/file.plug
+%%DATADIR%%/plugins/examples/ebcdic2ascii.plug
+%%DATADIR%%/plugins/examples/macro2plug.sh
+%%DATADIR%%/plugins/examples/encodechar.sh
+%%DATADIR%%/plugins/examples/ebcdic2ascii.cc
+%%DATADIR%%/plugins/examples/ebcdic2ascii.h
+%%DATADIR%%/plugins/examples/ascii2ebcdic.h
+%%X11%%%%DATADIR%%/plugins/examples/putselect.cc
+%%X11%%%%DATADIR%%/plugins/examples/switchsize.cc
+%%DATADIR%%/plugins/examples/rxvt.cc
+%%DATADIR%%/plugins/examples/index2table.h
+%%DATADIR%%/plugins/examples/elftables.cc
+%%DATADIR%%/plugins/examples/index2table.cc
+%%DATADIR%%/plugins/examples/cut.cc
+%%DATADIR%%/plugins/examples/datatypeinfo.cc
+%%DATADIR%%/plugins/examples/install.cc
+%%DATADIR%%/plugins/examples/newdata.cc
+%%DATADIR%%/plugins/examples/searchclip.cc
+%%DATADIR%%/plugins/examples/helpf1.cc
+%%DATADIR%%/plugins/examples/title.cc
+%%DATADIR%%/plugins/examples/signed.h
+%%DATADIR%%/plugins/examples/oldsigned.h
+%%DATADIR%%/plugins/examples/hash.h
+%%DATADIR%%/plugins/examples/bitfields.h
+%%DATADIR%%/plugins/examples/oldsigned.cc
+%%DATADIR%%/plugins/examples/backward.cc
+%%DATADIR%%/plugins/examples/unsigned.cpp
+%%DATADIR%%/plugins/examples/undoall.cpp
+%%DATADIR%%/plugins/examples/translate.cc
+%%DATADIR%%/plugins/examples/time.cpp
+%%DATADIR%%/plugins/examples/skip.cpp
+%%DATADIR%%/plugins/examples/signed.cc
+%%DATADIR%%/plugins/examples/subtract.cc
+%%DATADIR%%/plugins/examples/nextitem.cpp
+%%DATADIR%%/plugins/examples/disass-use.c
+%%DATADIR%%/plugins/examples/disass.cc
+%%DATADIR%%/plugins/examples/float.cc
+%%DATADIR%%/plugins/examples/filter.cpp
+%%DATADIR%%/plugins/examples/file.cpp
+%%DATADIR%%/plugins/examples/edit.cc
+%%DATADIR%%/plugins/examples/duplicate.cpp
+%%DATADIR%%/plugins/examples/crc.c
+%%DATADIR%%/plugins/examples/chars.c
+%%DATADIR%%/plugins/examples/char2.cc
+%%DATADIR%%/plugins/examples/bitflags.cc
+%%DATADIR%%/plugins/examples/bitfields.cc
+%%DATADIR%%/plugins/examples/bitcpy.cc
+%%DATADIR%%/plugins/examples/bitcontains.cc
+%%X11%%%%DATADIR%%/plugins/examples/putselect.plug
+%%DATADIR%%/config
+%%DATADIR%%/terminfo/r/rxvtbed
+%%DATADIR%%/terminfo/r/rxvt
+%%DATADIR%%/LICENSE
+%%DATADIR%%/bed-0.2.19.lsm
+%%DATADIR%%/README
+%%DATADIR%%/public.key
+%%DATADIR%%/addmagic.sh
+%%DATADIR%%/bedmagic
+%%DATADIR%%/testmarks.bedm
+%%DATADIR%%/uninstallbed.sh
+bin/bed
+bin/xbed
+@dirrm %%DATADIR%%/utils
+@dirrm %%DATADIR%%/terminfo/r
+@dirrm %%DATADIR%%/terminfo
+@dirrm %%DATADIR%%/plugins/examples
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/misc
+@dirrm %%DATADIR%%