aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-06-05 21:27:47 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-06-05 21:27:47 +0800
commite513c0189fe4333c71d565a8c0ebfd0643a1571d (patch)
tree40adf5f274ee333981266f9f5409c310b0b8edc9
parent1594a2b796f83b44f0ac778d9d79c529a0e17c36 (diff)
downloadfreebsd-ports-graphics-e513c0189fe4333c71d565a8c0ebfd0643a1571d.tar.gz
freebsd-ports-graphics-e513c0189fe4333c71d565a8c0ebfd0643a1571d.tar.zst
freebsd-ports-graphics-e513c0189fe4333c71d565a8c0ebfd0643a1571d.zip
Update to 3.8.1
-rw-r--r--devel/valgrind-snapshot/Makefile21
-rw-r--r--devel/valgrind-snapshot/distinfo6
-rw-r--r--devel/valgrind-snapshot/files/extra-patch-libsupc++194
-rw-r--r--devel/valgrind-snapshot/files/patch-coregrind__m_stacktrace.c11
-rw-r--r--devel/valgrind-snapshot/pkg-plist2
5 files changed, 14 insertions, 220 deletions
diff --git a/devel/valgrind-snapshot/Makefile b/devel/valgrind-snapshot/Makefile
index 940acd49c7d..0e7dffc5dba 100644
--- a/devel/valgrind-snapshot/Makefile
+++ b/devel/valgrind-snapshot/Makefile
@@ -2,17 +2,14 @@
# $FreeBSD$
PORTNAME= valgrind
-PORTVERSION= 3.8.0
+PORTVERSION= 3.8.1
PORTEPOCH= 1
-PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://cdn.bitbucket.org/stass/valgrind-freebsd/downloads/:dist \
- http://mirror.shatow.net/freebsd/${PORTNAME}/:dist \
- http://mirror.shatow.net/freebsd/${PORTNAME}/:manpages
+ http://mirror.shatow.net/freebsd/${PORTNAME}/:dist
PKGNAMESUFFIX= -snapshot
DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:dist \
- ${DISTNAME}-manpages${EXTRACT_SUFX}:manpages
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:dist
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Memory debugging and profiling tool
@@ -40,6 +37,8 @@ USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+PORTDOCS= html
+
WRKSRC= ${WRKDIR}/${DISTNAME}
.include <bsd.port.options.mk>
@@ -51,11 +50,6 @@ PLIST_SUB+= MPI=""
PLIST_SUB+= MPI="@comment "
.endif
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-libsupc++
-
-post-install:
- (cd ${WRKDIR}/valgrind-manpages/ && ${COPYTREE_SHARE} \* ${MANPREFIX}/man/man1)
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
@@ -71,4 +65,9 @@ PLIST_SUB+= X86="" ARCH=x86
PLIST_SUB+= AMD64="@comment "
.endif
+.if !${PORT_OPTIONS:MDOCS}
+post-patch:
+ @${RM} -rf ${WRKSRC}/docs/html
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/valgrind-snapshot/distinfo b/devel/valgrind-snapshot/distinfo
index 5205dd1f911..a989433d8a5 100644
--- a/devel/valgrind-snapshot/distinfo
+++ b/devel/valgrind-snapshot/distinfo
@@ -1,4 +1,2 @@
-SHA256 (valgrind-freebsd-3.8.0.tar.bz2) = 0edf104f87f97712af0adab032c91c525c8d6e9e7b5f824f88f06a3f28249756
-SIZE (valgrind-freebsd-3.8.0.tar.bz2) = 7238044
-SHA256 (valgrind-freebsd-3.8.0-manpages.tar.bz2) = aeb586be19bafd583dd9faf5d616e574ee3ef13263ef886e4a3978d5542faf58
-SIZE (valgrind-freebsd-3.8.0-manpages.tar.bz2) = 23899
+SHA256 (valgrind-freebsd-3.8.1.tar.bz2) = d4d9a0c6a8581cd04f4091ce9e15ce307f364210c4ea4cd38d568a8df7527871
+SIZE (valgrind-freebsd-3.8.1.tar.bz2) = 6289247
diff --git a/devel/valgrind-snapshot/files/extra-patch-libsupc++ b/devel/valgrind-snapshot/files/extra-patch-libsupc++
deleted file mode 100644
index 2a9bc1a90d1..00000000000
--- a/devel/valgrind-snapshot/files/extra-patch-libsupc++
+++ /dev/null
@@ -1,194 +0,0 @@
-diff -r 85982e3e9c39 coregrind/m_replacemalloc/vg_replace_malloc.c
---- coregrind/m_replacemalloc/vg_replace_malloc.c Mon Oct 29 10:59:10 2012 -0700
-+++ coregrind/m_replacemalloc/vg_replace_malloc.c Thu Jan 31 22:53:54 2013 +0200
-@@ -294,12 +294,14 @@
- // operator new(unsigned int), GNU mangling
- #if VG_WORDSIZE == 4
- ALLOC_or_BOMB(VG_Z_LIBSTDCXX_SONAME, _Znwj, __builtin_new);
-+ ALLOC_or_BOMB(VG_Z_LIBSUPCXX_SONAME, _Znwj, __builtin_new);
- ALLOC_or_BOMB(VG_Z_LIBC_SONAME, _Znwj, __builtin_new);
- ALLOC_or_BOMB(SO_SYN_MALLOC, _Znwj, __builtin_new);
- #endif
- // operator new(unsigned long), GNU mangling
- #if VG_WORDSIZE == 8
- ALLOC_or_BOMB(VG_Z_LIBSTDCXX_SONAME, _Znwm, __builtin_new);
-+ ALLOC_or_BOMB(VG_Z_LIBSUPCXX_SONAME, _Znwm, __builtin_new);
- ALLOC_or_BOMB(VG_Z_LIBC_SONAME, _Znwm, __builtin_new);
- ALLOC_or_BOMB(SO_SYN_MALLOC, _Znwm, __builtin_new);
- #endif
-@@ -308,11 +310,13 @@
- // operator new(unsigned int), GNU mangling
- #if VG_WORDSIZE == 4
- ALLOC_or_BOMB(VG_Z_LIBSTDCXX_SONAME, _Znwj, __builtin_new);
-+ ALLOC_or_BOMB(VG_Z_LIBSUPCXX_SONAME, _Znwj, __builtin_new);
- ALLOC_or_BOMB(SO_SYN_MALLOC, _Znwm, __builtin_new);
- #endif
- // operator new(unsigned long), GNU mangling
- #if VG_WORDSIZE == 8
- ALLOC_or_BOMB(VG_Z_LIBSTDCXX_SONAME, _Znwm, __builtin_new);
-+ ALLOC_or_BOMB(VG_Z_LIBSUPCXX_SONAME, _Znwm, __builtin_new);
- ALLOC_or_BOMB(SO_SYN_MALLOC, _Znwm, __builtin_new);
- #endif
-
-@@ -337,12 +341,14 @@
- // operator new(unsigned, std::nothrow_t const&), GNU mangling
- #if VG_WORDSIZE == 4
- ALLOC_or_NULL(VG_Z_LIBSTDCXX_SONAME, _ZnwjRKSt9nothrow_t, __builtin_new);
-+ ALLOC_or_NULL(VG_Z_LIBSUPCXX_SONAME, _ZnwjRKSt9nothrow_t, __builtin_new);
- ALLOC_or_NULL(VG_Z_LIBC_SONAME, _ZnwjRKSt9nothrow_t, __builtin_new);
- ALLOC_or_NULL(SO_SYN_MALLOC, _ZnwjRKSt9nothrow_t, __builtin_new);
- #endif
- // operator new(unsigned long, std::nothrow_t const&), GNU mangling
- #if VG_WORDSIZE == 8
- ALLOC_or_NULL(VG_Z_LIBSTDCXX_SONAME, _ZnwmRKSt9nothrow_t, __builtin_new);
-+ ALLOC_or_NULL(VG_Z_LIBSUPCXX_SONAME, _ZnwmRKSt9nothrow_t, __builtin_new);
- ALLOC_or_NULL(VG_Z_LIBC_SONAME, _ZnwmRKSt9nothrow_t, __builtin_new);
- ALLOC_or_NULL(SO_SYN_MALLOC, _ZnwmRKSt9nothrow_t, __builtin_new);
- #endif
-@@ -351,11 +357,13 @@
- // operator new(unsigned, std::nothrow_t const&), GNU mangling
- #if VG_WORDSIZE == 4
- ALLOC_or_NULL(VG_Z_LIBSTDCXX_SONAME, _ZnwjRKSt9nothrow_t, __builtin_new);
-+ ALLOC_or_NULL(VG_Z_LIBSUPCXX_SONAME, _ZnwjRKSt9nothrow_t, __builtin_new);
- ALLOC_or_NULL(SO_SYN_MALLOC, _ZnwjRKSt9nothrow_t, __builtin_new);
- #endif
- // operator new(unsigned long, std::nothrow_t const&), GNU mangling
- #if VG_WORDSIZE == 8
- ALLOC_or_NULL(VG_Z_LIBSTDCXX_SONAME, _ZnwmRKSt9nothrow_t, __builtin_new);
-+ ALLOC_or_NULL(VG_Z_LIBSUPCXX_SONAME, _ZnwmRKSt9nothrow_t, __builtin_new);
- ALLOC_or_NULL(SO_SYN_MALLOC, _ZnwjRKSt9nothrow_t, __builtin_new);
- #endif
-
-@@ -383,12 +391,14 @@
- // operator new[](unsigned int), GNU mangling
- #if VG_WORDSIZE == 4
- ALLOC_or_BOMB(VG_Z_LIBSTDCXX_SONAME, _Znaj, __builtin_vec_new );
-+ ALLOC_or_BOMB(VG_Z_LIBSUPCXX_SONAME, _Znaj, __builtin_vec_new );
- ALLOC_or_BOMB(VG_Z_LIBC_SONAME, _Znaj, __builtin_vec_new );
- ALLOC_or_BOMB(SO_SYN_MALLOC, _Znaj, __builtin_vec_new );
- #endif
- // operator new[](unsigned long), GNU mangling
- #if VG_WORDSIZE == 8
- ALLOC_or_BOMB(VG_Z_LIBSTDCXX_SONAME, _Znam, __builtin_vec_new );
-+ ALLOC_or_BOMB(VG_Z_LIBSUPCXX_SONAME, _Znam, __builtin_vec_new );
- ALLOC_or_BOMB(VG_Z_LIBC_SONAME, _Znam, __builtin_vec_new );
- ALLOC_or_BOMB(SO_SYN_MALLOC, _Znam, __builtin_vec_new );
- #endif
-@@ -397,11 +407,13 @@
- // operator new[](unsigned int), GNU mangling
- #if VG_WORDSIZE == 4
- ALLOC_or_BOMB(VG_Z_LIBSTDCXX_SONAME, _Znaj, __builtin_vec_new );
-+ ALLOC_or_BOMB(VG_Z_LIBSUPCXX_SONAME, _Znaj, __builtin_vec_new );
- ALLOC_or_BOMB(SO_SYN_MALLOC, _Znaj, __builtin_vec_new );
- #endif
- // operator new[](unsigned long), GNU mangling
- #if VG_WORDSIZE == 8
- ALLOC_or_BOMB(VG_Z_LIBSTDCXX_SONAME, _Znam, __builtin_vec_new );
-+ ALLOC_or_BOMB(VG_Z_LIBSUPCXX_SONAME, _Znam, __builtin_vec_new );
- ALLOC_or_BOMB(SO_SYN_MALLOC, _Znaj, __builtin_vec_new );
- #endif
-
-@@ -426,12 +438,14 @@
- // operator new[](unsigned, std::nothrow_t const&), GNU mangling
- #if VG_WORDSIZE == 4
- ALLOC_or_NULL(VG_Z_LIBSTDCXX_SONAME, _ZnajRKSt9nothrow_t, __builtin_vec_new );
-+ ALLOC_or_NULL(VG_Z_LIBSUPCXX_SONAME, _ZnajRKSt9nothrow_t, __builtin_vec_new );
- ALLOC_or_NULL(VG_Z_LIBC_SONAME, _ZnajRKSt9nothrow_t, __builtin_vec_new );
- ALLOC_or_NULL(SO_SYN_MALLOC, _ZnajRKSt9nothrow_t, __builtin_vec_new );
- #endif
- // operator new[](unsigned long, std::nothrow_t const&), GNU mangling
- #if VG_WORDSIZE == 8
- ALLOC_or_NULL(VG_Z_LIBSTDCXX_SONAME, _ZnamRKSt9nothrow_t, __builtin_vec_new );
-+ ALLOC_or_NULL(VG_Z_LIBSUPCXX_SONAME, _ZnamRKSt9nothrow_t, __builtin_vec_new );
- ALLOC_or_NULL(VG_Z_LIBC_SONAME, _ZnamRKSt9nothrow_t, __builtin_vec_new );
- ALLOC_or_NULL(SO_SYN_MALLOC, _ZnamRKSt9nothrow_t, __builtin_vec_new );
- #endif
-@@ -440,11 +454,13 @@
- // operator new[](unsigned, std::nothrow_t const&), GNU mangling
- #if VG_WORDSIZE == 4
- ALLOC_or_NULL(VG_Z_LIBSTDCXX_SONAME, _ZnajRKSt9nothrow_t, __builtin_vec_new );
-+ ALLOC_or_NULL(VG_Z_LIBSUPCXX_SONAME, _ZnajRKSt9nothrow_t, __builtin_vec_new );
- ALLOC_or_NULL(SO_SYN_MALLOC, _ZnajRKSt9nothrow_t, __builtin_vec_new );
- #endif
- // operator new[](unsigned long, std::nothrow_t const&), GNU mangling
- #if VG_WORDSIZE == 8
- ALLOC_or_NULL(VG_Z_LIBSTDCXX_SONAME, _ZnamRKSt9nothrow_t, __builtin_vec_new );
-+ ALLOC_or_NULL(VG_Z_LIBSUPCXX_SONAME, _ZnamRKSt9nothrow_t, __builtin_vec_new );
- ALLOC_or_NULL(SO_SYN_MALLOC, _ZnajRKSt9nothrow_t, __builtin_vec_new );
- #endif
-
-@@ -534,11 +550,13 @@
- FREE(VG_Z_LIBC_SONAME, __builtin_delete, __builtin_delete );
- // operator delete(void*), GNU mangling
- FREE(VG_Z_LIBSTDCXX_SONAME, _ZdlPv, __builtin_delete );
-+ FREE(VG_Z_LIBSUPCXX_SONAME, _ZdlPv, __builtin_delete );
- FREE(VG_Z_LIBC_SONAME, _ZdlPv, __builtin_delete );
- FREE(SO_SYN_MALLOC, _ZdlPv, __builtin_delete );
-
- #elif defined(VGO_freebsd)
- FREE(VG_Z_LIBSTDCXX_SONAME, _ZdlPv, __builtin_delete );
-+ FREE(VG_Z_LIBSUPCXX_SONAME, _ZdlPv, __builtin_delete );
- FREE(SO_SYN_MALLOC, _ZdlPv, __builtin_delete );
-
- #elif defined(VGO_darwin)
-@@ -554,12 +572,14 @@
- #if defined(VGO_linux)
- // operator delete(void*, std::nothrow_t const&), GNU mangling
- FREE(VG_Z_LIBSTDCXX_SONAME, _ZdlPvRKSt9nothrow_t, __builtin_delete );
-+ FREE(VG_Z_LIBSUPCXX_SONAME, _ZdlPvRKSt9nothrow_t, __builtin_delete );
- FREE(VG_Z_LIBC_SONAME, _ZdlPvRKSt9nothrow_t, __builtin_delete );
- FREE(SO_SYN_MALLOC, _ZdlPvRKSt9nothrow_t, __builtin_delete );
-
- #elif defined(VGO_freebsd)
- // operator delete(void*, std::nothrow_t const&), GNU mangling
- FREE(VG_Z_LIBSTDCXX_SONAME, _ZdlPvRKSt9nothrow_t, __builtin_delete );
-+ FREE(VG_Z_LIBSUPCXX_SONAME, _ZdlPvRKSt9nothrow_t, __builtin_delete );
- FREE(SO_SYN_MALLOC, _ZdlPvRKSt9nothrow_t, __builtin_delete );
-
- #elif defined(VGO_darwin)
-@@ -578,12 +598,14 @@
- FREE(VG_Z_LIBC_SONAME, __builtin_vec_delete, __builtin_vec_delete );
- // operator delete[](void*), GNU mangling
- FREE(VG_Z_LIBSTDCXX_SONAME, _ZdaPv, __builtin_vec_delete );
-+ FREE(VG_Z_LIBSUPCXX_SONAME, _ZdaPv, __builtin_vec_delete );
- FREE(VG_Z_LIBC_SONAME, _ZdaPv, __builtin_vec_delete );
- FREE(SO_SYN_MALLOC, _ZdaPv, __builtin_vec_delete );
-
- #elif defined(VGO_freebsd)
- // operator delete[](void*), GNU mangling
- FREE(VG_Z_LIBSTDCXX_SONAME, _ZdaPv, __builtin_vec_delete );
-+ FREE(VG_Z_LIBSUPCXX_SONAME, _ZdaPv, __builtin_vec_delete );
- FREE(SO_SYN_MALLOC, _ZdaPv, __builtin_vec_delete );
-
- #elif defined(VGO_darwin)
-@@ -602,12 +624,14 @@
- #if defined(VGO_linux)
- // operator delete[](void*, std::nothrow_t const&), GNU mangling
- FREE(VG_Z_LIBSTDCXX_SONAME, _ZdaPvRKSt9nothrow_t, __builtin_vec_delete );
-+ FREE(VG_Z_LIBSUPCXX_SONAME, _ZdaPvRKSt9nothrow_t, __builtin_vec_delete );
- FREE(VG_Z_LIBC_SONAME, _ZdaPvRKSt9nothrow_t, __builtin_vec_delete );
- FREE(SO_SYN_MALLOC, _ZdaPvRKSt9nothrow_t, __builtin_vec_delete );
-
- #elif defined(VGO_freebsd)
- // operator delete[](void*, std::nothrow_t const&), GNU mangling
- FREE(VG_Z_LIBSTDCXX_SONAME, _ZdaPvRKSt9nothrow_t, __builtin_vec_delete );
-+ FREE(VG_Z_LIBSUPCXX_SONAME, _ZdaPvRKSt9nothrow_t, __builtin_vec_delete );
- FREE(SO_SYN_MALLOC, _ZdaPvRKSt9nothrow_t, __builtin_vec_delete );
-
- #elif defined(VGO_darwin)
-diff -r 85982e3e9c39 include/pub_tool_redir.h
---- include/pub_tool_redir.h Mon Oct 29 10:59:10 2012 -0700
-+++ include/pub_tool_redir.h Thu Jan 31 22:53:54 2013 +0200
-@@ -254,10 +254,11 @@
-
- #endif
-
--/* --- Soname of the GNU C++ library. --- */
-+/* --- Sonames of the GNU C++ library. --- */
-
- // Valid on all platforms(?)
- #define VG_Z_LIBSTDCXX_SONAME libstdcZpZpZa // libstdc++*
-+#define VG_Z_LIBSUPCXX_SONAME libsupcZpZpZa // libsupc++*
-
- /* --- Soname of the pthreads library. --- */
-
diff --git a/devel/valgrind-snapshot/files/patch-coregrind__m_stacktrace.c b/devel/valgrind-snapshot/files/patch-coregrind__m_stacktrace.c
deleted file mode 100644
index b540b1affba..00000000000
--- a/devel/valgrind-snapshot/files/patch-coregrind__m_stacktrace.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./coregrind/m_stacktrace.c.orig 2013-04-18 16:40:39.221762499 -0500
-+++ ./coregrind/m_stacktrace.c 2013-04-18 16:40:49.927758427 -0500
-@@ -329,7 +329,7 @@
- if (filename != NULL && VG_(strstr)(filename, "/libc.so")) {
- match = 1;
- }
-- if (match = 1 && fp_min <= uregs.xsp &&
-+ if (match == 1 && fp_min <= uregs.xsp &&
- uregs.xsp <= fp_max - 1 * sizeof(UWord)) {
- /* fp looks sane, so use it. */
- uregs.xip = (((UWord*)uregs.xsp)[0]);
diff --git a/devel/valgrind-snapshot/pkg-plist b/devel/valgrind-snapshot/pkg-plist
index 6869b0b9c6c..a7bb6027287 100644
--- a/devel/valgrind-snapshot/pkg-plist
+++ b/devel/valgrind-snapshot/pkg-plist
@@ -71,6 +71,8 @@ include/valgrind/vki/vki-arm-linux.h
include/valgrind/vki/vki-darwin.h
include/valgrind/vki/vki-freebsd.h
include/valgrind/vki/vki-linux.h
+include/valgrind/vki/vki-machine-types-amd64-freebsd.h
+include/valgrind/vki/vki-machine-types-x86-freebsd.h
include/valgrind/vki/vki-mips32-linux.h
include/valgrind/vki/vki-posixtypes-amd64-linux.h
include/valgrind/vki/vki-posixtypes-arm-linux.h