aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrog <grog@FreeBSD.org>2007-02-27 14:47:17 +0800
committergrog <grog@FreeBSD.org>2007-02-27 14:47:17 +0800
commite7225c55d8fdae4863448a657f093d8c4dc3150d (patch)
tree029fdf116a470a0d0820f87362e2630d9e636a4a
parent45f0d69c869cce3aa540b918332ad0a04926cda5 (diff)
downloadfreebsd-ports-graphics-e7225c55d8fdae4863448a657f093d8c4dc3150d.tar.gz
freebsd-ports-graphics-e7225c55d8fdae4863448a657f093d8c4dc3150d.tar.zst
freebsd-ports-graphics-e7225c55d8fdae4863448a657f093d8c4dc3150d.zip
New port for getting Australian TV listings.
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/tv_grab_au/Makefile27
-rw-r--r--multimedia/tv_grab_au/distinfo3
-rw-r--r--multimedia/tv_grab_au/files/patch-tv_grab_au20
-rw-r--r--multimedia/tv_grab_au/pkg-descr8
-rw-r--r--multimedia/tv_grab_au/pkg-plist4
6 files changed, 63 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index fc49f76530f..9104b138c19 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -225,6 +225,7 @@
SUBDIR += toxine
SUBDIR += transcode
SUBDIR += tunapie
+ SUBDIR += tv_grab_au
SUBDIR += umr
SUBDIR += v4l_compat
SUBDIR += vamps
diff --git a/multimedia/tv_grab_au/Makefile b/multimedia/tv_grab_au/Makefile
new file mode 100644
index 00000000000..c5b61d35661
--- /dev/null
+++ b/multimedia/tv_grab_au/Makefile
@@ -0,0 +1,27 @@
+#
+# Ports collection makefile for: tv-grab-au
+# Date created: 27 February 2007
+# Whom: Greg Lehey <grog@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= tv_grab_au
+PORTVERSION= 0.6.2
+CATEGORIES= multimedia
+MASTER_SITES= http://www.onlinetractorparts.com.au/rohbags/xmltvau/
+# DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= grog@FreeBSD.org
+COMMENT= X 'tv_grab_au' is an XMLTV grabber for Australian TV programmes
+
+RUN_DEPENDS= tv_check:${PORTSDIR}/textproc/p5-xmltv
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL} ${WRKDIR}/tv_grab_au ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/p5-xmltv/tv_grab_au
+ ${INSTALL} ${WRKDIR}/channel_ids ${PREFIX}/share/p5-xmltv/tv_grab_au/channel_ids
+
+.include <bsd.port.mk>
diff --git a/multimedia/tv_grab_au/distinfo b/multimedia/tv_grab_au/distinfo
new file mode 100644
index 00000000000..5c35b3aae08
--- /dev/null
+++ b/multimedia/tv_grab_au/distinfo
@@ -0,0 +1,3 @@
+MD5 (tv_grab_au-0.6.2.tar.gz) = b144bc65bb9768fde7bc4d0125a34178
+SHA256 (tv_grab_au-0.6.2.tar.gz) = 80c0184e8d19c274483272a71a4a8e2e1e3f701742d965a529917c3f4c08dd82
+SIZE (tv_grab_au-0.6.2.tar.gz) = 22547
diff --git a/multimedia/tv_grab_au/files/patch-tv_grab_au b/multimedia/tv_grab_au/files/patch-tv_grab_au
new file mode 100644
index 00000000000..b38867d38b2
--- /dev/null
+++ b/multimedia/tv_grab_au/files/patch-tv_grab_au
@@ -0,0 +1,20 @@
+--- tv_grab_au~ Tue May 31 15:59:17 2005
++++ tv_grab_au Tue Feb 27 17:05:10 2007
+@@ -68,7 +68,7 @@
+ B<--debug> Output debugging info.
+
+ B<--share> Specify alternate directory for channel_ids file, usally found
+-in /usr/share/xmltv/tv_grab_au/.
++in /usr/local/share/p5-xmltv/tv_grab_au/.
+
+ =head1 SEE ALSO
+
+@@ -218,7 +218,7 @@
+
+ # share/ directory for storing region-to-channel mapping files.
+ # The directory can be overridden with the --share option.
+-my $SHARE_DIR='/usr/share/xmltv';
++my $SHARE_DIR='/usr/local/share/p5-xmltv';
+ $SHARE_DIR = $opt_share if defined $opt_share;
+ my $OUR_SHARE_DIR = (defined $SHARE_DIR) ? "$SHARE_DIR/tv_grab_au" : '.';
+ my $channel_ids_file = "$OUR_SHARE_DIR/channel_ids";
diff --git a/multimedia/tv_grab_au/pkg-descr b/multimedia/tv_grab_au/pkg-descr
new file mode 100644
index 00000000000..4c120a12ae7
--- /dev/null
+++ b/multimedia/tv_grab_au/pkg-descr
@@ -0,0 +1,8 @@
+tv_grab_au is an XMLTV grabber for Australian TV programmes.
+
+Unlike other grabbers, tv_grab_au runs interactively from a terminal.
+If you're using it in conjunction with programs like mythtv-setup,
+you'll have to go back to the terminal from which mythtv-setup was
+started.
+
+WWW: http://www.onlinetractorparts.com.au/rohbags/xmltvau/
diff --git a/multimedia/tv_grab_au/pkg-plist b/multimedia/tv_grab_au/pkg-plist
new file mode 100644
index 00000000000..1221ba7c0e9
--- /dev/null
+++ b/multimedia/tv_grab_au/pkg-plist
@@ -0,0 +1,4 @@
+bin/tv_grab_au
+share/p5-xmltv/tv_grab_au/channel_ids
+@dirrm share/p5-xmltv/tv_grab_au
+