aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-05-26 20:05:08 +0800
committerpav <pav@FreeBSD.org>2005-05-26 20:05:08 +0800
commite88757a8ad344991ba2200c3ce25eeb47d9f9fd2 (patch)
tree35d07596e5d25ef27c5d978838d28aedb5902ada
parentc03df7673b78a7f5d2da7e4818e77c9a19e4afdb (diff)
downloadfreebsd-ports-graphics-e88757a8ad344991ba2200c3ce25eeb47d9f9fd2.tar.gz
freebsd-ports-graphics-e88757a8ad344991ba2200c3ce25eeb47d9f9fd2.tar.zst
freebsd-ports-graphics-e88757a8ad344991ba2200c3ce25eeb47d9f9fd2.zip
New sibling bogofilter port to use the sqlite3 database backend.
PR: ports/81448 Submitted by: Matthias Andree <matthias.andree@gmx.de>
-rw-r--r--mail/Makefile1
-rw-r--r--mail/bogofilter-sqlite/Makefile27
2 files changed, 28 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index c57c3bab81b..6ded375a2b8 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -29,6 +29,7 @@
SUBDIR += bmf
SUBDIR += bogofilter
SUBDIR += bogofilter-qdbm
+ SUBDIR += bogofilter-sqlite
SUBDIR += bogofilter-tdb
SUBDIR += bsfilter
SUBDIR += bsmtp
diff --git a/mail/bogofilter-sqlite/Makefile b/mail/bogofilter-sqlite/Makefile
new file mode 100644
index 00000000000..99e16067674
--- /dev/null
+++ b/mail/bogofilter-sqlite/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: bogofilter-sqlite
+# Date created: 2005-05-24
+# Whom: Matthias Andree <matthias.andree@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bogofilter
+PORTREVISION= 0
+CATEGORIES= mail
+PKGNAMESUFFIX= -sqlite
+
+MAINTAINER= matthias.andree@gmx.de
+
+LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+CONFLICTS= bogofilter-[0-9]* bogofilter-qdbm-[0-9]* bogofilter-tdb-[0-9]* \
+ [a-z][a-z]-bogofilter-[0-9]* bogofilter-current-[0-9]*
+
+CONFIGURE_ARGS= --with-database=sqlite
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+DESCR= ${PKGDIR}/pkg-descr
+
+MASTERDIR= ${.CURDIR}/../bogofilter
+
+.include "${MASTERDIR}/Makefile"