aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-04-27 18:30:10 +0800
committernovel <novel@FreeBSD.org>2005-04-27 18:30:10 +0800
commite9be68699df60d168f81aa9a24371183560f257a (patch)
treec3f4da2d250598ace1d7f581c35dad30d318a9f1
parent5517d012a0b66135b3876d909b47926efa6528b9 (diff)
downloadfreebsd-ports-graphics-e9be68699df60d168f81aa9a24371183560f257a.tar.gz
freebsd-ports-graphics-e9be68699df60d168f81aa9a24371183560f257a.tar.zst
freebsd-ports-graphics-e9be68699df60d168f81aa9a24371183560f257a.zip
- fix segfault on attempt to play next track from empty playlist [1]
- make mpg321 be RUN_DEPEND instead of BUILD_DEPEND PR: 80365 [1] Submitted by: Andrej Zverev (maintainer)
-rw-r--r--audio/orpheus/Makefile5
-rw-r--r--audio/orpheus/files/patch-src-uitext.cc26
2 files changed, 25 insertions, 6 deletions
diff --git a/audio/orpheus/Makefile b/audio/orpheus/Makefile
index a3780ac2687..b94e970b62c 100644
--- a/audio/orpheus/Makefile
+++ b/audio/orpheus/Makefile
@@ -7,13 +7,14 @@
PORTNAME= orpheus
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://thekonst.net/download/
MAINTAINER= az@inec.ru
COMMENT= Light-weight console UI audio player application
-BUILD_DEPENDS= mpg321:${PORTSDIR}/audio/mpg321
+RUN_DEPENDS= mpg321:${PORTSDIR}/audio/mpg321
USE_BZIP2= yes
HAS_CONFIGURE= yes
@@ -37,7 +38,7 @@ CONFIGURE_ARGS+= --enable-ghttp
.endif
.if defined(WITH_VORBIS)
-RUN_DEPENDS= ogg123:${PORTSDIR}/audio/vorbis-tools
+RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --enable-vorbis
diff --git a/audio/orpheus/files/patch-src-uitext.cc b/audio/orpheus/files/patch-src-uitext.cc
index 72f1651dd0c..7c57ca49adf 100644
--- a/audio/orpheus/files/patch-src-uitext.cc
+++ b/audio/orpheus/files/patch-src-uitext.cc
@@ -1,6 +1,24 @@
---- src/uitext.cc Tue Feb 17 04:18:21 2004
-+++ src/uitext.cc Sun Dec 12 22:12:41 2004
-@@ -577,14 +577,16 @@
+diff -Nru src.orig/uitext.cc src/uitext.cc
+--- src.orig/uitext.cc Tue Feb 17 04:18:21 2004
++++ src/uitext.cc Tue Apr 26 19:49:01 2005
+@@ -125,6 +125,8 @@
+ }
+
+ void OrpheusTextUI::nexttrack() {
++ if (!plist.empty())
++ {
+ if(conf.getplaymode() == Random) {
+ int k;
+ while(*(plist.begin()+(k = randlimit(0, plist.size()-1))) == currenttrack);
+@@ -143,6 +145,7 @@
+ }
+ }
+ }
++ }
+ }
+
+ void OrpheusTextUI::prevtrack() {
+@@ -577,14 +580,16 @@
autosavepl = !autosavepl;
break;
case 41:
@@ -19,7 +37,7 @@
sortorder = byFileName;
break;
case 44:
-@@ -719,7 +721,8 @@
+@@ -719,7 +724,8 @@
while(!finished) {
m.clear();