aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-01-31 15:04:20 +0800
committermiwi <miwi@FreeBSD.org>2014-01-31 15:04:20 +0800
commitea1b2fce461acdb550b3aa4fc18771156433bf38 (patch)
treed6f763a8203f37cdb61059017328f2cbdb9cbacb
parent0ff6cae1bf6c7fef5613adfe752db0e56f5ec478 (diff)
downloadfreebsd-ports-graphics-ea1b2fce461acdb550b3aa4fc18771156433bf38.tar.gz
freebsd-ports-graphics-ea1b2fce461acdb550b3aa4fc18771156433bf38.tar.zst
freebsd-ports-graphics-ea1b2fce461acdb550b3aa4fc18771156433bf38.zip
- Stage support
- Convert to USES
-rw-r--r--net/libnfs/Makefile4
-rw-r--r--net/libnss-mysql/Makefile1
-rw-r--r--net/linc/Makefile4
3 files changed, 2 insertions, 7 deletions
diff --git a/net/libnfs/Makefile b/net/libnfs/Makefile
index 4dc9a0892b6..7027a9a380f 100644
--- a/net/libnfs/Makefile
+++ b/net/libnfs/Makefile
@@ -13,15 +13,13 @@ LICENSE= LGPL21 GPLv3
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pkgconfig
-USE_GMAKE= yes
+USES= pkgconfig gmake
USE_AUTORECONF= yes
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
ACLOCAL_ARGS= -I.
AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} 's|$$(libdir)/\(pkgconfig\)|$$(prefix)/libdata/\1|' \
${WRKSRC}/Makefile.am
diff --git a/net/libnss-mysql/Makefile b/net/libnss-mysql/Makefile
index 62cb91e2f3c..e7ef189caa2 100644
--- a/net/libnss-mysql/Makefile
+++ b/net/libnss-mysql/Makefile
@@ -16,5 +16,4 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_MYSQL= yes
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/linc/Makefile b/net/linc/Makefile
index 5e852f08016..cf60a7054cf 100644
--- a/net/linc/Makefile
+++ b/net/linc/Makefile
@@ -15,8 +15,7 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
-USES= pkgconfig
-USE_GMAKE= yes
+USES= pkgconfig gmake
USE_GNOME= gnomehack glib20
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
@@ -25,7 +24,6 @@ CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
CPPFLAGS+= -I${LOCALBASE}/include -DGLIB_COMPILATION
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/ s|docs||' ${WRKSRC}/Makefile.in