aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2011-05-09 03:26:29 +0800
committerashish <ashish@FreeBSD.org>2011-05-09 03:26:29 +0800
commiteee78467c4eaaf28eed3c8b326d3456495bbb3c6 (patch)
tree38d90024e43289a114daaf8b3f57c2c3cb04b21e
parentea8259540b89fda230705b68b7c8651146f2208d (diff)
downloadfreebsd-ports-graphics-eee78467c4eaaf28eed3c8b326d3456495bbb3c6.tar.gz
freebsd-ports-graphics-eee78467c4eaaf28eed3c8b326d3456495bbb3c6.tar.zst
freebsd-ports-graphics-eee78467c4eaaf28eed3c8b326d3456495bbb3c6.zip
Cairo is a library to render high quality vector graphics. There exist various
backends that allows rendering to Gtk windows, PDF, PS, PNG and SVG documents, amongst others. WWW: http://www.haskell.org/gtk2hs/ Approved by: pgj (mentor) Obtained from: FreeBSD Haskell
-rw-r--r--graphics/hs-cairo/Makefile25
-rw-r--r--graphics/hs-cairo/distinfo2
-rw-r--r--graphics/hs-cairo/pkg-descr5
3 files changed, 32 insertions, 0 deletions
diff --git a/graphics/hs-cairo/Makefile b/graphics/hs-cairo/Makefile
new file mode 100644
index 00000000000..9abe098a9a5
--- /dev/null
+++ b/graphics/hs-cairo/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: hs-cairo
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cairo
+PORTVERSION= 0.12.0
+CATEGORIES= graphics haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Binding to the Cairo library
+
+LICENSE= BSD
+FILE_LICENSE= COPYRIGHT
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= gtk2hs-buildtools mtl
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/cairo-pdf.pc:${PORTSDIR}/graphics/cairo
+
+PORTDATA= *
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/graphics/hs-cairo/distinfo b/graphics/hs-cairo/distinfo
new file mode 100644
index 00000000000..cb86cbbd4cd
--- /dev/null
+++ b/graphics/hs-cairo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/cairo-0.12.0.tar.gz) = 29736aa5a6c7c3f4401c9ad53768a4806dbc0b3278be186aa95b4a8edcc25a58
+SIZE (cabal/cairo-0.12.0.tar.gz) = 47495
diff --git a/graphics/hs-cairo/pkg-descr b/graphics/hs-cairo/pkg-descr
new file mode 100644
index 00000000000..92ac1b68cfd
--- /dev/null
+++ b/graphics/hs-cairo/pkg-descr
@@ -0,0 +1,5 @@
+Cairo is a library to render high quality vector graphics. There exist various
+backends that allows rendering to Gtk windows, PDF, PS, PNG and SVG documents,
+amongst others.
+
+WWW: http://www.haskell.org/gtk2hs/