aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-03-16 22:07:55 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-03-16 22:07:55 +0800
commitefb6ddb271428e5b022ca40cf136245810903f8a (patch)
treea9eb910fc3daf9275b26b20a28deb1577ba07575
parentadc68ed10f409cb25460bdd4a84c8216087ec904 (diff)
downloadfreebsd-ports-graphics-efb6ddb271428e5b022ca40cf136245810903f8a.tar.gz
freebsd-ports-graphics-efb6ddb271428e5b022ca40cf136245810903f8a.tar.zst
freebsd-ports-graphics-efb6ddb271428e5b022ca40cf136245810903f8a.zip
- Add LICENSE_FILE
- Strip libraries
-rw-r--r--astro/py-astLib/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/astro/py-astLib/Makefile b/astro/py-astLib/Makefile
index c5159347c45..fcdbb24faa7 100644
--- a/astro/py-astLib/Makefile
+++ b/astro/py-astLib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= astLib
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= astro python
MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Astronomy modules for Python
LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY} \
${PKGNAMEPREFIX}scipy>=0.7.0:${PORTSDIR}/science/py-scipy \
@@ -24,4 +26,7 @@ PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
USES= python
USE_PYTHON= autoplist distutils
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyWCSTools/*.so
+
.include <bsd.port.mk>