aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-05-28 09:38:04 +0800
committertota <tota@FreeBSD.org>2011-05-28 09:38:04 +0800
commitf0cc728f15f2ef431e0b27ad9c81a98292164476 (patch)
tree61ebba187901bf9c7c4503612308baccfaf5a041
parent75df899be0495ae565fcd05b14186d02d4018813 (diff)
downloadfreebsd-ports-graphics-f0cc728f15f2ef431e0b27ad9c81a98292164476.tar.gz
freebsd-ports-graphics-f0cc728f15f2ef431e0b27ad9c81a98292164476.tar.zst
freebsd-ports-graphics-f0cc728f15f2ef431e0b27ad9c81a98292164476.zip
- Update MASTER_SITES to make fetchable
- Fix command lines in the do-install target * not to use undefined variable: INSTALL_DIR * not to use SITE_PERL that contains LOCALBASE
-rw-r--r--japanese/jcode.pl/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/japanese/jcode.pl/Makefile b/japanese/jcode.pl/Makefile
index 27891f0eb17..0184220bec1 100644
--- a/japanese/jcode.pl/Makefile
+++ b/japanese/jcode.pl/Makefile
@@ -8,7 +8,9 @@
PORTNAME= jcode.pl
PORTVERSION= 2.13
CATEGORIES= japanese perl5
-MASTER_SITES= http://srekcah.org/jcode/
+MASTER_SITES= ftp://ftp.iij.ad.jp/pub/IIJ/dist/utashiro/perl/ \
+ ftp://ftp.sra.co.jp/pub/lang/perl/sra-scripts/ \
+ http://srekcah.org/jcode/
EXTRACT_SUFX= # none
MAINTAINER= ports@FreeBSD.org
@@ -24,7 +26,7 @@ EXTRACT_AFTER_ARGS= .
PLIST_FILES= %%SITE_PERL%%/${PORTNAME}
do-install:
- ${MKDIR} ${INSTALL_DIR}/
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME} ${SITE_PERL}/${PORTNAME}
+ ${MKDIR} ${PREFIX}/${SITE_PERL_REL}/
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME} ${PREFIX}/${SITE_PERL_REL}/${PORTNAME}
.include <bsd.port.mk>