aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-05-03 01:46:47 +0800
committersat <sat@FreeBSD.org>2007-05-03 01:46:47 +0800
commitf1add8738d04d3f14d774782dab04206f8566479 (patch)
tree0cfc3d9f0d0f21b973c862edacf26c1901c44e14
parentc4cc19d0e956574ab5c00d2d241a374caddfa93f (diff)
downloadfreebsd-ports-graphics-f1add8738d04d3f14d774782dab04206f8566479.tar.gz
freebsd-ports-graphics-f1add8738d04d3f14d774782dab04206f8566479.tar.zst
freebsd-ports-graphics-f1add8738d04d3f14d774782dab04206f8566479.zip
Add port misc/cloc:
cloc counts blank lines, comment lines, and physical lines of source code in many programming languages. cloc contains code from David Wheeler's SLOCCount and Damian Conway and Abigail's Perl module Regexp::Common. WWW: http://cloc.sourceforge.net/ Author: Al Danial <al.danial@gmail.com>
-rw-r--r--misc/Makefile1
-rw-r--r--misc/cloc/Makefile27
-rw-r--r--misc/cloc/distinfo3
-rw-r--r--misc/cloc/pkg-descr8
4 files changed, 39 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index dddb5fa2eb7..a0bc8b4da28 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -38,6 +38,7 @@
SUBDIR += chord
SUBDIR += chord2html
SUBDIR += clex
+ SUBDIR += cloc
SUBDIR += clpbar
SUBDIR += cmatrix
SUBDIR += colortail
diff --git a/misc/cloc/Makefile b/misc/cloc/Makefile
new file mode 100644
index 00000000000..c4f14cd688f
--- /dev/null
+++ b/misc/cloc/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cloc
+# Date created: 2 May 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cloc
+PORTVERSION= 0.80
+CATEGORIES= misc
+MASTER_SITES= SF
+EXTRACT_SUFX= .pl
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Counts lines of code
+
+USE_PERL5_RUN= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ./${PORTNAME}
+PLIST_FILES= bin/${PORTNAME}
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/misc/cloc/distinfo b/misc/cloc/distinfo
new file mode 100644
index 00000000000..0a7a8bd2437
--- /dev/null
+++ b/misc/cloc/distinfo
@@ -0,0 +1,3 @@
+MD5 (cloc-0.80.pl) = 9c99f63cadb3db95dfa294cee079c86f
+SHA256 (cloc-0.80.pl) = 3329f2b7f8265787bf6504e9e3f315920e6e017bdc0706b4acdd81ed70c8549e
+SIZE (cloc-0.80.pl) = 144309
diff --git a/misc/cloc/pkg-descr b/misc/cloc/pkg-descr
new file mode 100644
index 00000000000..25faeba90d4
--- /dev/null
+++ b/misc/cloc/pkg-descr
@@ -0,0 +1,8 @@
+cloc counts blank lines, comment lines, and physical lines of source
+code in many programming languages.
+
+cloc contains code from David Wheeler's SLOCCount and Damian Conway and
+Abigail's Perl module Regexp::Common.
+
+WWW: http://cloc.sourceforge.net/
+Author: Al Danial <al.danial@gmail.com>